none
OCSPE Device Update Service Not Updating Phones RRS feed

  • Question

  • Hi Folks

    We have a bunch of Nortel IP8540 phones we are trying to get firmware updated to run with OCS 2007 R2 properly, everything works apart from the phone not ringing on an inbound call which we are hoping the firmware update will fix. The phones however are located externally i.e outside of our corporate network and are totally unrelated to our AD environment. I have read some blogs about how you configure the update service on the FE server etc and as far as I'm aware everything is configured ok and we can hit the URL externally via a web browser without any issues and download the update files.

    Shouldn't the phones retrieve the server URL when they are logged on to OCS via in band provisioning? or will they require the DNS A record for ucupdates-r2.sipdomain.com??

    I cannot see any evidence of the phones trying to contact our server at all in the logs, in fact their are no logs in the update service logs directory at all even though logging is enabled.

    One thing that I think may be worth mentioning is that their is no DNS suffix provided by the local DHCP server and I have read that this is required so the phone knows where to look for the DNS record. The users currently log into their phones using their UPN so user@company.com this UPN also matches their SIP login name. I was hoping the phones would look at this to determine where they should look for the ucupdates-r2 A record if that is required.

    The current revision of firmware is 1.0.522.71 (1.23) and the update status on the phones is (0x2f06/0) which I cant find any reference to!

    The next step is to deploy a proper DHCP server and configure it to return a DNS suffix that matches the domain name of where the A record has been any created. However like I said I thought this would not be required.

    Any help would be greatly appreciated

    Thanks as usual

    Adam

     

    Wednesday, May 19, 2010 5:22 PM

All replies

  • I actually found a way to look at the update server URL that was being provided by using WBEMTEST and it was Null. I have now changed this to the correct external URL so hopefully it will work.

    Just updating so I dont waste anyones time with answering this just yet :)

    Thanks

    Adam

    Wednesday, May 19, 2010 6:52 PM
  • Ok so its still not working :(

    No eveidence that the phones are contacting the server at all, like I said previously there are no log files at all in the log directory and the IIS log files dont show much either!

    any one have any suggestions on this one?

    Many thanks

    Adam

     

    Thursday, May 20, 2010 1:23 PM
  • You say you are not getting much in the IIS logs. Does this mean you are getting the phone connecting to IIS? If so seeing whatis in the log might be helpful.

    The most complete information on upgrading a tanjay is in these blogs http://blogs.technet.com/ucspotting/archive/tags/Communicator+Phone+Edition/default.aspx

    Have you tried upgrading any phones internally? It might be worth eliminating any firewall issues.


    Chris Clark - | MCTS:OCS & UC Voice Specialization | MCSE | MCSA | CCNA http://www.unitycomms.com
    Thursday, May 20, 2010 4:43 PM
  • Hi Chris

    Actually there is nothing in the IIS logs for the phones. I am just seeing Address book download traffic for MOC users, the phones are not even reaching out as far as I can tell. The device update VD's are published via ISA Server (HTTPS) just as the other Web Components are and I can hit them all via a browser externally without any issues.

    I have read that blog and various others but still no joy. DHCP server is not in place yet but from my reading we shouldn't need that at all.

    We dont have any phones internally and I dont have any to test with, but I'm 100% sure the firewall is not an issue due to being ble to hit the URLs externally. I am at a loss at the moment :( so frustrating......

    Thanks for taking the time to help out again, much appreciate all the help you guys are providing.

    Adam

    Thursday, May 20, 2010 5:44 PM
  • Hi Adam

    I thought I would check the 0x2f06 error you see, this indicates the url you are hitting the server with doesn't match the subject name. So assume that is a true representation what is happening you must have a cert mismatch somewhere. 


    Chris Clark - | MCTS:OCS & UC Voice Specialization | MCSE | MCSA | CCNA http://www.unitycomms.com
    Thursday, May 20, 2010 7:00 PM
  • Hmmm, since I can hit the URL externally without any issues and don't get any cert warnings, I think this must be a red herring. Unless the URL the phone is getting is not right, which I am sure it is. Do you happen to know the correct path to the update logs. In the blog I was reading it gives this path

    Logs\Server\Audit\imageUpdates\

    When all I have is Logs with no subdirectories in it.

    I will double check I am not getting any cert warnings.

    Thanks Chris

    Adam

    Thursday, May 20, 2010 8:12 PM
  • Now you've got me thinking, sometime ago I read that wild card certs were not supported on OCS 2007 R2 but I tried it anyway for the Web components and CWA, not the Edge as I have a UCC cert for that. BTW everything has been working without any issues up to now. I wonder if this is coming back to bite me? That would explain why I'm not getting any errors in IE. I think i better get a commercial cert and see if that helps. I am also going to do some logging on ISA to see if I can see any failed connection attempts from the phones IP range.

    Fingers crossed, you might of solved my issue!

    Thanks

    Adam 

    Thursday, May 20, 2010 8:31 PM
  • Of course I meant a non wildcard cert and not a commercial cert in my post above. The wildcard cert is a commercial one!

    Certificate is on its way...........

    Thanks

    Adam

    Thursday, May 20, 2010 8:49 PM
  • My logs directory isn't there at all on my lab system where I updated my tanjays from, so I can't help you with that.

    Using wildcard certs is likely to cause you problems whether this is the actual issue for the tanjays you should find out soon.


    Chris Clark - | MCTS:OCS & UC Voice Specialization | MCSE | MCSA | CCNA http://www.unitycomms.com
    Thursday, May 20, 2010 8:56 PM
  • Well the new certificate fixed it. I also had to follow this article to allow anonymous access as the phones were getting an IIS 401:

    http://www.ucguys.com/page/3/

    probably be worth mentioning that I also have the subdirectories inside my logs directory now as per the post above and more importantly actual log entries for the phones! :)

    Thanks for pointing me in the right direction Chris, seems like those error messages do sometimes indicate what the real issues are! :)

    Have a good weekend and many thanks again.

    Adam

     

     

    Friday, May 21, 2010 5:28 PM
  • Glad to hear it all worked in the end. I really should put together all the bits I have on the Tanjays and blog it sometime.
    Chris Clark - | MCTS:OCS & UC Voice Specialization | MCSE | MCSA | CCNA http://www.unitycomms.com
    Friday, May 21, 2010 7:15 PM