none
Outlook 2016 Exchange 2019 on-Prem - ExcludeExplicitO365Endpoint NOT WORKING RRS feed

  • Question

  • May 2019 and this is still an issue.

    Exchange 2016 on-premise
    Outlook 2016 v1094

    I cannot get Outlook 2016 to NOT try connecting to o365 and prompting for creds.

    I have a laptop NOT joined to the AD Domain of the Exchange 2016 Server.
    Outlook 2016 v1904 build 11601.20144

    For devices AD-joined, it seems to work with just the ExcludeScpLookup and ExcludeExplicitO365Endpoint

    Test Email Autoconfiguration (from system tray) goes to https://outlook.office365.com/autodiscover/autodiscover.xml

    I have added the ExcludeExplicitO365Endpoint to both:
    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\Outlook\AutoDiscover

    I've also added the other keys I've found to both of these locations:

    • PreferLocalXML
    • ExcludeHttpRedirect
    • ExcludeScpLookup
    • ExcludeLastKnownGoodURL(only applies to Outlook 2010 version 14.0.7140.5001 and later versions)
    • ExcludeExplicitO365Endpoint (only applies to Outlook 2016 version

    I've rebooted after every attempt.

    I've also added a key mentioned somewhere about WAMoverride.

    Autodiscover tests fine on testExchangeConnectivity site.

    Is there anything else I can try?

    Friday, May 10, 2019 3:24 PM

All replies

  • Hi David,

    >>I cannot get Outlook 2016 to NOT try connecting to o365 and prompting for creds.

    What kind of password prompting window did you get? Could you capture a screenshot and provide it to us?

    Is it a stand-alone Exchange 2016 in your environment? It is not a hybrid environment, correct?

    >>Test Email Autoconfiguration (from system tray) goes to https://outlook.office365.com/autodiscover/autodiscover.xml

    Could you also provide the full autodiscover lookup process to us so that we can know the issue more clearly? You can send the screenshot to us via ibsofc@microsoft.com. (Please add the URL of current thread in the message so that we can easily identify your message)

    Regards,
    Steve Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, May 13, 2019 7:07 AM
    Moderator
  • Hi David,

    How is everything going? Please don't hesitate to post back if you need further assistance here.

    Regards,
    Steve Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, May 15, 2019 1:32 AM
    Moderator
  • The prompt is the html O365 logon - I'm not at the machine to grab a screen snip and the log but I've attached a similar logon page.  It's definitely *NOT* the Windows credential panel.  No known credential works for this prompt.  (Confusing matters - for me at least - is that I have a Windows Live account with the same email address, and different password yet).

    I've sent the sample screen shot to the email - will send the log details later today.

    It is a completely on-prem Exchange environment.

    Wednesday, May 15, 2019 12:15 PM
  • Thank you David for the update.

    >>Confusing matters - for me at least - is that I have a Windows Live account with the same email address, and different password yet

    Could you elaborate more on this? What does same email address with different password refer to?

    You may also try clearing the credential cache which are related to the Microsoft or Office 365 account, and then check whether this issue continues.

    Regards,
    Steve Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, May 20, 2019 9:25 AM
    Moderator
  • Dear David,

    Just wanted to say hi and check if there is anything that we can do for you on this problem. If so, please do not hesitate to let us know and we will be happy to help.

    Best regards,
    Steve Fan 


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, May 24, 2019 9:49 AM
    Moderator