none
Failure to install Office 365 version of Lync via GPO RRS feed

  • Question

  • I am trying to create a GPO to allow me to install the Office 365 version of Lync to all the computers in my environment.  I started by following http://blogs.technet.com/b/mir/archive/2011/06/04/how-to-automate-lync-client-2010-deployment-in-multi-architect-environment-using-active-directory-group-policy.aspx which didn't work even after I followed the instructions to remove the "/fulluisuppression" switch.  I have also tried to use the GPO software deployment of MSI's by extracting the various MSI's and using those.  In both cases no Lync is installed.  When I look through the Program Files folder I do not see the OCSetup folder so it seems as though the issue is that even though we have set the GPO to allow admins the to run as elevated permissions and not ask for the elevation it is not allowing the GPO to write to the Program Files folder.  I have tried on Windows XP 32bit, Windows 7 32bit and Windows 7 64bit computers. 

    I have been fighting this for a while and have been told by Office 365 that it isn't their issue so they can't help me.

    I have found one other site that used a VBS script to install but looking through the colde it looks to just run the install file from the server which hasn't worked with the scipt from the Technet link and that file was local.

    Please any help or insight you can provide would be helpful.

    Thursday, July 26, 2012 8:50 PM

All replies

  • Hi,

    did you follow these Guide to install Lync?

    http://technet.microsoft.com/en-us/library/gg425733.aspx

    because you have to install some prequisites like Silverlight, Microsoft Visual C++ etc.


    regards Holger Technical Specialist UC

    Friday, July 27, 2012 6:35 AM
  • Hi Holger

    Yes I was testing on a computer that already had those.  Also the Microsoft recommendation to install using the EXE rather than an MSI is because the EXE will install those prerequisites.  I did extract the MSI's of Silverlight and Visual C++ to install at the same time I tied to install Lync.  The issue of it not installing remained.

    Thanks

    Friday, July 27, 2012 3:12 PM
  • So new development.  I am on site trying to manually set up Lync on a few crucial computers so we can at least get those who really need the application set up and have more time to work on the auto deployment through GPO.  When I try to install the file it says that there is already another version of Lync on the computer and I must remove it before installing Lync.  Unfortunately I cannot find it installed anywhere.  There is no Lync directory in Program Files, there is no Lync in the Programs and Features.  When I check the OCSetup log in Tracing I find the GUID which I remove from the registry and still get the error.  Reboots have not helped.  So it seems not only did it not properly install it also messed up the process where even a manual install is not possible.  Please any help you can give would be appreciated.

    Thanks

    Friday, July 27, 2012 7:22 PM
  • On Friday I was able to manually install from the files I had downloaded and have been trying to install originally.  Only one one computer was there any issues But on another 5 I was able to install without issue, these were both Windows XP and 7 computers and both 32 and 64 bit.  Does anyone know if there is a difference between the install for the Office 365 version of Lync and the standard install of Lync?
    Monday, July 30, 2012 2:56 PM
  • No, there is no different, be sure you don't install a Evaluation Version.

    regards Holger Technical Specialist UC

    Monday, July 30, 2012 6:35 PM
  • No, there is no different, be sure you don't install a Evaluation Version.

    regards Holger Technical Specialist UC


    If there is no difference then I am unsure as to why my installs would fail and those who commented in the link I provided seemed to work correctly.  I was thinking the issue was due to differences between the Office 365 version and the normal copy which was causing the script to not properly run or the files to not properly be installed.  This is very confusing and frustrating.
    Monday, July 30, 2012 6:58 PM
  • Ok my next test has also failed.  I downloaded and tried to use the Lync install from Technet to see if that would make a difference.  It did not. The install files appear to be about 20 megabytes smaller for both versions of the install however still there is no OCSetup folder created and nothing installed.  Is there some other part of the GPO I am missing?  I am not sure why so many others seem to have no issues with this and yet it won't work on any computers for my attempt.
    Tuesday, July 31, 2012 3:25 PM
  • Hi,

    Can you find any error logs about this problem in the client PC Event Viewer?

    Please check if the client PC try to install the application.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, August 2, 2012 6:01 AM
    Moderator
  • Hi Sean

    There never seemed to be any errors in the event logs stating if it ran or was successful.  Because the first part of the script copies a file from the server to a directory and that file was created it appears that the script itself did run it simply did not actually perform the install itself.

    Thanks

    Thursday, August 2, 2012 7:46 PM
  • Hi

    I have still not gotten this to work.  Does anyone have any suggestions or thoughts on how to get something going?  Has anyone here actually gotten Lync to install via GPO?

    Thanks

    Wednesday, August 8, 2012 4:15 PM