none
A problem occured while Microsoft Access was communicating with the OLE server or ActiveX Control RRS feed

  • Question

  • Hi,

    Error messages I receive when I click on my buttons in an Access form:

    A problem occured while Microsoft Access was communicating with the OLE server or ActiveX Control

    or

    The expression On Click you entered as the event property setting produced the following error:

    *The expression may not result in the name of a macro, the name of a user-defined function or [Event Procedure]

    *There may have been an error evaluating the function, event or macro

    All the macros are running without any problem.

    What is very interesting to me:

    I have some databases in Access and all of them are working well on my other computers (win10, office 365) but not on the new laptop I just purchased. Win 10 home, Office 365, fresh install, no other programs running, just office 365 is installed.

    Further to the subject, I created some buttons in random forms, and added the DoCmd.close command just to test. This command is working on my main form but does not work on other forms and the error message above appears.

    What could be the problem?

    Your help is much appreciated!

    Best wishes,

    Tamas

    Monday, July 10, 2017 11:58 AM

All replies

  • Just got word from an Access expert:

    RUN > intl.cpl > administrative > language for non-Unicode programs > change system locale

    Select the language on the platform you have created the database in the first place, mine was Hungarian.

    Then everything works!

    (It seems like the new edition of Windows 10 has different settings than the ones shipped earlier this year!)

    Monday, July 10, 2017 2:08 PM
  • Hi Tamas,

    Glad that the issue has been resolved. And thanks for your solution sharing.

    Please remember to mark the solution as an reply for this thread. It would be helpful to other users who encounter the same issue and read this thread.

    Thanks again for your understanding :)

    Best Regards,

    Winnie Liang


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 11, 2017 9:28 AM
    Moderator
  • Dear Sir, 

    Thank you very much for your help, I had this issue for a month now and I couldn't solve it. Thanks to your detailed report I manage to run successfully my database at last today. You have been extremely helpful.

    Best regards,

    Konstantina Zevgitou

    Wednesday, November 8, 2017 7:46 PM
  • Its works!!
    Sunday, December 24, 2017 6:41 AM
  • I had a the problem but tracked it down to me using character with an umlaut (ü) in a temporary column name in a Query (as I'm working in Germany). As soon as I changed that everything was ok. The above solution would have probably also worked too.
    Wednesday, February 28, 2018 1:27 PM
  • Good Day.

    I have the same issue.

    Where do I have to go to "RUN: ??

    Can you be more specific ??

    I would appreciate your answer a lot.

    Thanks


    Stratos


    Tuesday, March 6, 2018 7:24 AM
  • in my case, this solution worked

    Regards Remus Rigo

    Thursday, April 26, 2018 12:56 PM
  • Well as someone asked before, where do you run "RUN > intl.cpl > administrative > language for non-Unicode programs > > change system locale"
    Friday, April 27, 2018 3:09 PM
  • Hello, did you find where to type the"RUN:" words
    Friday, April 27, 2018 3:29 PM
  • "Run" is a windows future.

    You can find it in star menu or simply just press Win key + R

    Wednesday, May 9, 2018 3:40 PM
  • Big thanks T Zettner :) it solved my problem
    Tuesday, November 20, 2018 11:39 AM
  • Thanks Very much , it`s work with me :)
    Thursday, May 9, 2019 1:17 PM
  • windows menu setting > language > related setting additional.... > Region > Administrative > change system locale > your place
    Friday, May 24, 2019 10:03 AM
  • thank you very much mister
    Monday, September 2, 2019 11:13 AM