none
error ID 504 (source ID 239).

    Question

  • Dears,

    We have OCS 2007 R1 installed in our company. I sucessfully installed Lync server. I enabled a user for Lync server. When a Lync enabled user talked with an ocs enabled user, the following error appear :

    When contacting your support team, reference error ID 504 (source ID 239).

    How can i solve this issue ? 


    Ahmed Mostafa
    Monday, October 18, 2010 8:12 AM

All replies

  • Hi,

    Are you using same CA server for both or its different CA from OCS box?

    Also check that can you ping your Lync FQDN from client or not?

    Regards.

    Shafaquat Ali.


    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2, URL: http://blog.WhatDoUC.net Phone: +923008210320
    • Proposed as answer by MattPendleton Friday, October 28, 2011 3:53 PM
    Monday, October 18, 2010 8:41 AM
  • Hi,

    Than I will suggest you to add Lync's IP in host file of your client and OCS box, it will work.

     

    Regards.

    Shafaquat Ali.


    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2, URL: http://blog.WhatDoUC.net Phone: +923008210320
    Monday, October 18, 2010 10:38 AM
  • I already can ping on OCS Pool & Lync server from client side.


    Ahmed Mostafa
    Monday, October 18, 2010 10:43 AM
  • Hi,

    I am telling you in reference of SRV records not pinging reference.

     

    Regards.

    Shafaquat Ali.


    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2, URL: http://blog.WhatDoUC.net Phone: +923008210320
    Monday, October 18, 2010 11:04 AM
  • done, but problem still exist, and required steps for intergrate OCS with Lync ?


    Ahmed Mostafa
    Monday, October 18, 2010 11:57 AM
  • Hi, please enable logging on both clients, and enable SIPStack and S4 logging on Lync server to check errors for narrow down the issue.
    Best regards,
    Tuesday, October 19, 2010 8:31 AM
  • I got the following error :

    TL_ERROR(TF_NETWORK) [0]04A4.16F0::10/19/2010-09:24:59.620.0000000b (SIPStack,NegotiateLogic::ProcessPeerIdentity:NegotiateLogic.cpp(1081))( 0 )( 0000000006083BA0 ) Exit - failed to validate peer with S2S FQDN. Returned 0xC3E93D6A(SIPPROXY_E_CONNECTION_UNKNOWN_SERVER)
    TL_ERROR(TF_CONNECTION) [0]04A4.16F0::10/19/2010-09:24:59.620.0000000c (SIPStack,SIPAdminLog::TraceConnectionRecord:SIPAdminLog.cpp(160))$$begin_record
    LogType: connection
    Severity: error
    Text: The peer is not a configured server on this network interface
    Peer-IP: 192.168.0.10:1589
    Transport: TLS
    Result-Code: 0xc3e93d6a SIPPROXY_E_CONNECTION_UNKNOWN_SERVER
    Data: fqdn="Pool1.mydomain.com"
    $$end_record

    TL_ERROR(TF_NETWORK) [0]04A4.16F0::10/19/2010-09:24:59.620.0000000d (SIPStack,CTLSSocket::EvaluateIncomingMessage:TLSSocket.cpp(1195))( 0000000006083760 ) Exit - negotiation logic failed, socket will be closed. Returned 0xC3E93D6A(SIPPROXY_E_CONNECTION_UNKNOWN_SERVER)
    TL_ERROR(TF_DIAG) [0]04A4.16F0::10/19/2010-09:24:59.621.0000000e (SIPStack,SIPAdminLog::TraceDiagRecord:SIPAdminLog.cpp(143))$$begin_record
    LogType: diagnostic
    Severity: error
    Text: Message was not sent because the connection was closed
    SIP-Start-Line: SIP/2.0 400 Bad request
    SIP-Call-ID: CFEAD5348D387A5A8537
    SIP-CSeq: 12 NEGOTIATE
    Peer: 192.168.0.10:1589
    $$end_record

    TL_ERROR(TF_PROTOCOL) [0]04A4.16F0::10/19/2010-09:24:59.621.0000000f (SIPStack,SIPAdminLog::TraceProtocolRecord:SIPAdminLog.cpp(115))$$begin_record
    Trace-Correlation-Id: 566289466
    Instance-Id: 00001A34
    Direction: no-direction-info;source="local"
    Message-Type: response
    Start-Line: SIP/2.0 400 Bad request
    From: sip:LOCALHOST;tag=C2F7A3B0CB458BE3C4EF04979F15A6EF
    To: sip:192.168.0.20;tag=F822EEA7236D2FDAC66EFB347783DB87
    CSeq: 12 NEGOTIATE
    Call-ID: CFEAD5348D387A5A8537
    Via: SIP/2.0/TLS 192.168.0.10:1589;branch=z9hG4bK82192CCF.445CCD25;branched=FALSE;ms-received-port=1589;ms-received-cid=6DE00
    ms-diagnostics: 2;reason="See response code and reason phrase";HRESULT="0xC3E93C77(SIPPROXY_E_COMPRESSION_ALGORITHM_NOT_ENABLED)";source="lync.mydomain.com"
    Server: RTC/4.0
    Content-Length: 0
    Message-Body: –
    $$end_record


    Ahmed Mostafa
    Tuesday, October 19, 2010 10:27 AM
  • Hi, how did you assign certificates on OCS and Lync pool?

    The errors showed that certificates may not be assigned correct on Pool1.mydomain.com.

    On my Lab, the certificates of Lync pool should be assigned like as:

    SN: Lyncpool.contoso.com

    SAN: Lyncpool.contoso.com,Lync-fe.contoso.com,dialin.contoso.com,meet.contoso.com,admin.contoso.com,webext.contoso.com

    The certificates of OCS pool should be like as:

    SN: Ocspool.contoso.com

    SAN: sip.contoso.com,ocspool.contoso.com, ocs-fe.contoso.com


    Best regards,
    Wednesday, October 20, 2010 3:11 AM
  • Hi, Ahmed Mostafa, updates let us know.
    Best regards,
    Wednesday, October 27, 2010 9:13 AM
  • I see this same thing. I have OCS and Lync installed. I can logon on OCS Communicator and Llync Commumnicator, but when IMing from Lync to OCS, I get this error. I also get presence unknown on Lync for OCS users and vice versa.

    It looks like co-existance is very flakey and does not fully work Shame.


    Thomas Lee Doctordns@Gmail.Com
    Tuesday, November 30, 2010 4:34 PM
  • This worked.  I was using different SSL certs on the Front End OCS 2007 R2 server from the Lync 2010 Front End server.  Installing a cert from the same trust CA worked.
    • Proposed as answer by K2Snow Wednesday, November 09, 2011 6:36 PM
    Friday, October 28, 2011 3:55 PM
  • I also ran into the issue, it turned out since we had the collaboration service running on the same machine as the admin service, they were both trying to listen on port 443, causing the lync server to see the wrong cert when it tried connecting back to the bes server.  Changing the listening port for the collaboration service fixed the issue
    Tuesday, November 15, 2011 1:59 PM