locked
RemoteApp - Pop-ups hidden behind main window RRS feed

  • Question

  • We are using RemoteApp in Windows Server 2012 to publish Microsoft Dynamics AX 2012.

    Sometimes when the user clicks on something inside the application that generates a popup of a new windows, this new window is opened behind the main windows. This causes confusion to the users.

    I have found the following Kb articles/hotfixes that seem to describe the problem:
    http://support.microsoft.com/kb/2580346
    http://support.microsoft.com/kb/2384602
    http://support.microsoft.com/kb/983533

    However, all these hotfixes are applicable only to Windows 2008 (R2), and not Windows Server 2012.

    Are there any updated hotfixes for 2012 somewhere?

    Friday, October 11, 2013 10:51 AM

Answers

All replies

  • Hi,

    For your issue, I am scared to inform that still there is no any hotfix available but there is one workaround which you can try. For that you need to make changes in registry.

    For changing in registry, open Registry editor and then navigate to HKEY_CURRENT_USER\Control Panel\Desktop and change the value of “ForegroundLockTimeout” into 0.(You can Perform for Server 2012)

    Refer below threads for more information:

    1.  Published Application POPUPS   behind main window 
    2.  windows 7 (x64 pro) window focus issues:when i open a program/window, sometimes it opens in the background instead of the foreground

    Hope it helps!
    Thanks.

    Monday, October 14, 2013 6:06 AM
  • Thank you for your answer, I will try it.

    Monday, October 14, 2013 8:13 AM
  • Hi,

    How is everything going? Could you please tell us the present situation? If you need any further assistance, please do not hesitate to respond back.

    Thanks.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Thursday, October 17, 2013 1:10 AM
  • I have the same situation when running Dynamics AX as a remote app.  Did you make a change on the Remote Desktop Server?  If so, what did you change?  Were you able to do this with a GPO policy?

    Thanks.

    Friday, November 1, 2013 3:28 PM
  • any update on this ? i am have the same issue in remote app
    Tuesday, November 12, 2013 1:15 PM
  • I could use some help with this also.. I tried the latest RDP client, this registry fix is not working for me. Do you do it on the users machine or on the server or both?

    Friday, November 22, 2013 4:19 PM
  • Did you already found a fix for this, as we also have the issue but then with Dynamics AX 2009 on 2012R2
    Friday, November 28, 2014 11:51 AM
  • We are experience this same issue with Dynamics GP.  Has anyone found a solution?  Our users are not very happy with us at the moment.  Tried registry fix and various hotfixes.  Using Server 2012 r2, WIndows 7 clients.
    • Edited by donaldkbart Friday, January 9, 2015 2:22 PM
    Friday, January 9, 2015 2:20 PM
  • Hi,

    this suggested fix solved the issue for us:

    http://blogs.msdn.com/b/axsupport/archive/2014/06/21/forms-opening-up-with-focus-in-background.aspx

    Best regards, Ben

    • Proposed as answer by Benj H Thursday, May 7, 2015 8:48 AM
    Thursday, May 7, 2015 7:44 AM
  • We ran into a similar problem after updating our 2008 r2 rds farm environment to 2012r2. Some new popup windows, within our published RemoteApp application, would hide behind the parent window and the session seemed frozen to the end user. We noticed that clicking away from the RemoteApp and clicking on something on the taskbar and than clicking back, would show the popup window(of course this was unacceptable to our users).

    The solution that fixed this issue was to:

    Disable “Use advanced RemoteFX graphics for RemoteApp” in Local GP on the 2012R2 RDS Host(s):

    Computer Configuration/Administrative Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Remote Session Environment/

    • Proposed as answer by S. Noordijk Monday, June 13, 2016 11:26 AM
    Wednesday, March 16, 2016 1:55 PM
  • You should try applying the following update for RDS 2012R2  before disabling RemoteFX.

    Please look at RDS 2012R2 Update list : https://support.microsoft.com/en-us/kb/2933664

    • 3103000 RemoteApp windows disappear and screen flickers when you switch between windows in Windows 8.1 or Windows Server 2012 R2
    • 3026738 RemoteApp window is too large or too small when you use RDP to run a RemoteApp application in Windows Server 2012 R2
    • 2977219 Updates to improve the compatibility of Azure RemoteApp in Windows 8.1 or Windows Server 2012 R2
    • 2959626 Reliability improvements for Remote Desktop Session Host and RemoteApp
    • 2925336 Shortcut menu items flicker as you move the mouse pointer over them in a RemoteApp in Windows




    Wednesday, March 16, 2016 2:02 PM
  • We ran into a similar problem after updating our 2008 r2 rds farm environment to 2012r2. Some new popup windows, within our published RemoteApp application, would hide behind the parent window and the session seemed frozen to the end user. We noticed that clicking away from the RemoteApp and clicking on something on the taskbar and than clicking back, would show the popup window(of course this was unacceptable to our users).

    The solution that fixed this issue was to:

    Disable “Use advanced RemoteFX graphics for RemoteApp” in Local GP on the 2012R2 RDS Host(s):

    Computer Configuration/Administrative Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Remote Session Environment/

    This is was the solution in my situation with a RDS 2012 R2 environment with Windows 10 clients, thanks

    Monday, June 13, 2016 11:27 AM
  • Hi

        This issue is du to incompatibility between Remote app 2012 and rdp win 7.  The solution is to upgrade your RDP to rdp 8.0 on your clients computer. the issue is not side server but side client.

    step 1 :  insure that your win 7 is sp1 else download your  Win 7 SP1 and install it
    step 2 : , download and install hotfix (prerequest for rdp 8.0 update)
    step 3 :   download and install rdp 8.0 update (https://support.microsoft.com/en-us/kb/2592687)

    it work fine

    regards

    Mourad

     


      

    Thursday, June 30, 2016 11:08 PM
  • Hi, I had the same problem. We found that the rpd-Client (C:\Windows\System32\mstsc.exe) has Version 6.1.x. On Computers where the problem does not occour the Version was 6.3.9600.x

    We installed the following KBs and the problem was solved:

    KB2574419
    KB2830477
    KB2857650
    KB2913752

    Kind regards

    Markus

    Thursday, August 11, 2016 12:18 PM
  • This worked perfectly for me!
    Wednesday, April 25, 2018 6:18 PM
  • We are experiencing the same issue with a client on GP2015, however the Use advanced RemoteFX graphics for RemoteApp parameter is set to Not Configured.

    Wednesday, July 11, 2018 2:37 PM