none
Skype for business federation to skype consumer RRS feed

  • Question

  • Hello, I've got a weird one here, my federation works fine between Skype for business users, teams and consumer, BUT, I've lost the ability to see the pictures from the consumer Skype when searching or when i add new contacts, all of this was working fine until I had to reboot the Front END

    I am running a standard Skype for business 2019 with the latest updates

    As I wrote, i am able to call, IM and video chat with all my federated domains including the Skype consumer, but when looking up the directory I no longer see the pictures or if I change the contact picture of one of my Skype consumer test accounts it does not get updated on my already added contact on the Skype for business

    Any insight ?


    • Edited by pjaneiro Tuesday, February 11, 2020 6:03 AM
    Tuesday, February 11, 2020 6:01 AM

All replies

  • Hi pjaneiro!

    Does anyone else have the same issue?

    Are users’ pictures stored in Active Directory?

    We recommend you troubleshoot this issue in these ways:

    *Make sure your consumer in Skype for Business client disabled “hide my picture”.


    *Run the command “Update-CsAdressBook” manually in Skype for Business PowerShell after you change the contact picture and see if you can see it well.

    Based on my knowledge, contact profiles get a lot of data from Active Directory. Changes to AD are replicated to the back-end SQL Server.Once a day(the default is 1:30 AM) the changes in SQL Server are synchronized to Address Book. For more details, you can refer to:

    http://lyncinsider.com/lync-server-2010/microsoft-lync-lync-server-2010/updating-lync-contacts-using-active-directory-to-store-and-push-contact-photos-part-1-of-3/

    Besides, you can also follow these steps to clear the client cache to see if it works:

    1. Please right click the Windows icon and open the Run bar.

    2. Then type in: %localappdata%\Microsoft\Office\16.0\Lync\

    3. Delete the sip profile folder.

    4. Go into the Tracing folder, delete all files, but not the folders.

    For more details about troubleshooting this issue, you can refer to:

    http://skype4businessinsider.com/skype-for-business/3-ways-make-sure-contact-photos-display-skype-business/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    Best Regards,
    Jimmy Yang

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.
    Tuesday, February 11, 2020 9:20 AM
  • Hello, thanks for the reply, it's the same for all users, I've tried deleting the local profile, it's a no go, the problem is not with the local user pictures, but with getting the profile pictures from the skype consumer accounts as seen here no pictures seem to show when searching the directory

    

    Thank you

    Tuesday, February 11, 2020 5:26 PM
  • Hello, just a bump for update
    Wednesday, February 12, 2020 5:04 PM
  • no takers on this issue ?

    If i were to rebuild the front end, is everything saved in the ad or the sql database also has configurations ?

    Thursday, February 13, 2020 10:12 PM
  • Hi pjaneiro,

    Sorry for reply you too late!

    According to your description, can we understand that the affected users are from external rather than local?

    Now we assume you have checked these users’ client settings for these users.

    You can try to re-enable Skype directory search in the Skype for Business Client. The following link tells you how to re-enable Skype connectivity if you have PIC provisioned.

    http://lyncinsider.com/skype-for-business/how-to-re-enable-skype-directory-search-in-the-skype-for-business-client/

    And yes, if you want to rebuild the front end, everything is still saved in the AD.

    Best Regards,
    Jimmy Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Friday, February 14, 2020 10:33 AM
  • Yes the affected users are all from consumer skype that are contacting our internal users on SFB 2019

    When we search for them, using the skype directory, their names appear fine but not the pictures, since there can be a lot of people having the same names, using the profile picture helps

    I have deleted and enabled the federation on the front end, I have deleted and recreated the directory search, I've also rebuilt the edge server, 

    IM, AUDIO AND VIDEO works with federated users, we no longer get the profile picture while searching or the profile picture no longer gets updated.


    Friday, February 14, 2020 4:24 PM
  • Hi pjaneiro!

    Based on my knowledge, you will only see photos for federated users when they have their photo configured at a publicly accessible URL.

    Besides, you should notice the following consideration for using images from a web address:

    *File size limits are determined by the MaxPhotoSize attribute in the client policy. The default size limit is 30 KB. If you try to use an image file that exceeds the size limit it will not be downloaded to client.

    Also, please check displayphoto parameter value in your client policy. For more details, you can refer to:

    https://docs.microsoft.com/en-us/powershell/module/skype/set-csclientpolicy?view=skype-ps

    If you want to learn how to user photos are displayed in Lync, you can refer to the following link:

    https://docs.microsoft.com/en-us/lyncserver/how-user-photos-are-displayed-in-lync

    Best Regards,
    Jimmy Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Wednesday, February 19, 2020 9:29 AM
  • Hi,
    Is there any update on this case?
    Please feel free to drop us a note if there is any update.
    Have a nice day!

    Best Regards,
    Jimmy Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, February 21, 2020 11:15 AM
  • Hello, no this is still not resolved, as stated earlier,  this was working, I was able to see my skype consumer test user's photo fine, after a reboot of the Front end server, the pictures are no longer being displayed, i do not see any errors in the logs

    I've just verified with another tech in another firm who also has skype for business 2019, he is able to see the skype for consumer profile photos

    I've validated my install and so far everything seems ok

    my policy is set to "all photos"

    everything works fine for internal users

    Saturday, February 22, 2020 12:17 AM