none
Enable_CsUser cannot bind parameter 'SipAddresType' RRS feed

  • Question

  • I have lync server 2015 and Ad user

    I try to enable lync account by powershell on this server. I use microsoft instruction to it:

    Enable-CsUser -Identity "Pilar Ackerman" -RegistrarPool "atl-cs-001.litwareinc.com" -SipAddressType SamAccountName -SipDomain litwareinc.com

    In my case (example):

    Enable-CsUser -Identity "vasya petrov" -RegistrarPool "lync.domane.net" -SipAddressType v.petrov -SipDomain domane.net

    I try to use -SipAddress "sip:pilar@litwareinc.com" (from instruction)

    But every time have the same error:

    Cannot bind parameter 'SipAddressType'. Cannot convert value "v.petrov" to type "Microsoft.Rtc.Management.AD.Cmdlets.AddressType". Error: "Unable to match the 
    identifier name v.petrov to a valid enumerator name.  Specify one of the following enumerator names and try again: FirstLastName, EmailAddress, 
    UserPrincipalName, SAMAccountName, None"
        + CategoryInfo          : InvalidArgument: (:) [Enable-CsUser], ParameterBindingException
        + FullyQualifiedErrorId : CannotConvertArgumentNoMessage,Microsoft.Rtc.Management.AD.Cmdlets.EnableOcsUserCmdlet
        + PSComputerName        : lync.domane.net

    Monday, February 11, 2019 11:39 AM

Answers

  • Hi xAxellx,

    If you want to use -SipAddressType to enable user, the value of  -SipAddressType must as following: 
    FirstLastName, EmailAddress, UserPrincipalName or SamAccountName, so the command should as below for the example:
    Enable-CsUser -Identity "vasya petrov" -RegistrarPool "lync.domane.net" -SipAddressType SamAccountName -SipDomain domane.net

    In addition, if you want to type user’s sip address, you could run the following command:
    Enable-CsUser -Identity "vasya petrov" -RegistrarPool "lync.domane.net" -SipAddress sip:pilar@litwareinc.com

    Details about this you could refer to the following official document: Enable-CsUser

    Best Regards,
    Evan Jiang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by xAxellx Tuesday, February 12, 2019 6:45 AM
    Tuesday, February 12, 2019 2:38 AM
    Moderator

All replies

  • Hi xAxellx,

    If you want to use -SipAddressType to enable user, the value of  -SipAddressType must as following: 
    FirstLastName, EmailAddress, UserPrincipalName or SamAccountName, so the command should as below for the example:
    Enable-CsUser -Identity "vasya petrov" -RegistrarPool "lync.domane.net" -SipAddressType SamAccountName -SipDomain domane.net

    In addition, if you want to type user’s sip address, you could run the following command:
    Enable-CsUser -Identity "vasya petrov" -RegistrarPool "lync.domane.net" -SipAddress sip:pilar@litwareinc.com

    Details about this you could refer to the following official document: Enable-CsUser

    Best Regards,
    Evan Jiang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by xAxellx Tuesday, February 12, 2019 6:45 AM
    Tuesday, February 12, 2019 2:38 AM
    Moderator
  • Thanks a lot, when i sow SipAddressType SamAccountName i think i should take real SamAccountname from my user setting, but i just should write exectly SamAccountname.

    Thanks a lot, sorry for my stupidy.

    Tuesday, February 12, 2019 6:45 AM