IISAdministration on NanoServer RRS feed

  • Question

  • Hey all, I have been pulling my hair out the last 4 days, I would like to install the new version of IISAdministration on my IIS nano server (kb4093120 update is installed) but im facing a lot of problems.

    After several hours of troubleshooting I managed to install the NuGet PackageProvider on my nano server, and the IISAdministration module was installed with no error; but when i run import-module IISAdministration I get an error:

    import-module iisadministration Could not load file or assembly 'Microsoft.Web.Administration, Version=, Culture=neutral

    when I run find-module IISAdministration I can see it right there

    after a little bit of digging i discovered that Microsoft.web.Administration is related to a DLL file that should be inside :C:\Windows\assembly\GAC_MSIL\Microsoft.Web.Management\

    when I went into C:\windows, i noticed that there is nothing such as assembly Folder. How to get the assembly folder installed on my server ?

    after hours and hours of googling, I came to conclusion that this is may be related to ASP.NET core . pleaz confirm this to me?

    in the process of this ASP.Core installation, I need to import-IISAdministration ???

    I can’t import this module so how can I install the ASP Core framework on my nano server?

    Thursday, October 17, 2019 2:15 PM