none
Lync 2010 Install Error: System.UnauthorizedAccessException RRS feed

  • Question

  • Hey everyone,

     

    I'm receiving the following error when trying to create the Central management Store:

    Action   Action Information   Time Logged   Execution Result
       Install-CSDatabase           Failed
         Get Forest State       12/6/2010 11:19:06 AM   Success
              Find root domain gotovelocity.com.   12/6/2010 11:19:06 AM    
              Schema type: server   12/6/2010 11:19:06 AM    
              Action: Check Groups   12/6/2010 11:19:06 AM    
              Action: Check Group permissions   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCUniversalGlobalReadOnlyGroup,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCUniversalGlobalWriteGroup,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCUniversalServerReadOnlyGroup,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCUniversalUserReadOnlyGroup,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCHSUniversalServices,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCComponentUniversalServices,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCProxyUniversalServices,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCUniversalServerAdmins,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCUniversalUserAdmins,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCUniversalReadOnlyAdmins,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCUniversalConfigReplicator,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCUniversalSBATechnicians,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:06 AM    
              Action: Process permissions on "CN=RTCSBAUniversalServices,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:07 AM    
              Action: Process permissions on "CN=CSAdministrator,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:07 AM    
              Action: Process permissions on "CN=CSVoiceAdministrator,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:07 AM    
              Action: Process permissions on "CN=CSUserAdministrator,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:07 AM    
              Action: Process permissions on "CN=CSResponseGroupAdministrator,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:07 AM    
              Action: Process permissions on "CN=CSLocationAdministrator,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:07 AM    
              Action: Process permissions on "CN=CSArchivingAdministrator,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:07 AM    
              Action: Process permissions on "CN=CSServerAdministrator,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:07 AM    
              Action: Process permissions on "CN=CSViewOnlyAdministrator,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:07 AM    
              Action: Process permissions on "CN=CSHelpDesk,CN=Users,DC=gotovelocity,DC=com".   12/6/2010 11:19:07 AM    
              Action: Check Permission settings of CN=RTC Service,CN=Services,CN=Configuration,DC=gotovelocity,DC=com   12/6/2010 11:19:07 AM    
              Action: Check Permission settings of ConfigurationContainer   12/6/2010 11:19:07 AM    
              Action: Check Permission settings of RootDomainSystemContainer   12/6/2010 11:19:07 AM    
              Access permission only applies to the Active Directory System container.   12/6/2010 11:19:07 AM    
              Forest state: LC_FORESTSETTINGS_STATE_READY   12/6/2010 11:19:07 AM    
          Found "RTCUniversalServerAdmins": True   12/6/2010 11:19:07 AM    
          Found "RTCUniversalConfigReplicator": True   12/6/2010 11:19:07 AM    
          Found "RTCUniversalReadOnlyAdmins": True   12/6/2010 11:19:07 AM    
          Error: An error occurred: "System.UnauthorizedAccessException" "Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))"   12/6/2010 11:19:08 AM   Error
    • Edited by Der Hai Tuesday, December 7, 2010 1:44 PM
    Monday, December 6, 2010 4:18 PM

All replies

  • Hi,

    Have you got these permissions for your user from which you are installing Lync ?

    01. Domain Admins

    02. Enterprise Admins

    03. System Admins

    04. Administrators on Domain

    05. Administrators on local Lync Server

     

    Regards.

    Shafaquat Ali.


    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2, URL: http://blog.WhatDoUC.net Phone: +923008210320
    Monday, December 6, 2010 8:14 PM
  • Yes, the user has all of the correct permissions.
    Monday, December 6, 2010 8:19 PM
  • Hi,

    Than I would like to ask that have you make the share folder and gave full permissions to your user ?

    Also check this step by step guide for Lync Deployment I hope this will help you.

    Lync Server 2010 Installation step by step

     

    Regards.

    Shafaquat Ali.


    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2, URL: http://blog.WhatDoUC.net Phone: +923008210320
    Monday, December 6, 2010 8:25 PM
  • I wiped the server and reloaded following step by step to the letter as shown in the above link and I still get stuck at the same spot with the same error.
    Monday, December 6, 2010 11:09 PM
  • I was able to get passed that point but now I can't seem to get the Lync Control Panel to launch.

     

    When I launch the panel a username and password box appear, I enter the credentials for the uaser account and I get an HTTP Error 401.1 Unauthorized.

    Tuesday, December 7, 2010 12:55 AM
  • J Dig,

    Have you added your self to the CSAdministrators group and logged in and out of the server? 

     

    Hope this helps!

    -kp


    Kevin Peters blog: www.ocsguy.com MVP Communications Server, MCITP: Enterprise Administration | MCTS:OCS | MCSE | MCSA | CCNA
    Tuesday, December 7, 2010 2:54 AM
  • i'm running into the same problem too. can you explain how you fixed it?
    Tuesday, December 7, 2010 6:30 AM
  • J Dig,

    Have you added your self to the CSAdministrators group and logged in and out of the server? 

     

    Hope this helps!

    -kp


    Kevin Peters blog: www.ocsguy.com MVP Communications Server, MCITP: Enterprise Administration | MCTS:OCS | MCSE | MCSA | CCNA

    I have added that user to the CSAdmin group, logged out, and restarted the server for good measure.

    There is something else odd happening. I decided to go back in to the Deployment Wizard and the "Install or Update Lync Server System" option. Step 2 now shows as not completed, however, when I re-run it the step completes without any errors. After that I'll refresh the Wizard and it shows as not complete again.

     

    Any ideas???

     

    Tuesday, December 7, 2010 1:43 PM
  • i'm running into the same problem too. can you explain how you fixed it?
    The solution to my original problem was to create a new share folder and verify it was accessible across the network. Then I created a new topology and it published fine. Not sure what I had done wrong before, I know the only difference was I placed the new share folder in the C:/ directory as opposed to the /Microsoft/Lync Server directory.
    Tuesday, December 7, 2010 1:58 PM
  • What Edition did you attempt to install? If you're attempting to install Standard edition, you'll need to use the Local FQDN of the machine for your CMS.
    James Ooi MCTS - Office Communications Server 2007 - Blog:http://JamesOSW.Wordpress.com
    • Proposed as answer by TLE377 Monday, December 13, 2010 3:20 PM
    Thursday, December 9, 2010 8:27 AM
  • Hi, J Dig, do above approaches help you? any updates let us know.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, December 15, 2010 10:51 AM
  • Make sure that the name of the FQDN you specify for the pool (during the topology wizard) matches that of the server name FQDN - I had the problems described above until I did that.  My lab server name was lync2010 but in the pool fqdn I just set that to lync.labdomainname.local

    When I tried to access file shares using the lync.labdomainname.local name it did not work and kept prompting for credentials which I knew were correct, changed to pool FQDN to lync2010.labdomainname.local and hey presto it worked!

    Hope this helps someone else

    • Proposed as answer by amd183 Tuesday, April 24, 2012 6:10 PM
    Thursday, January 27, 2011 5:24 PM
  • I can confirm that making the pool name match the server name will resolve this issue.  To change the pool name, expand the Central Site, then Standard Edition Front End Servers and right click your pool and select Edit Properties.
    Friday, February 4, 2011 4:16 PM
  • hello,

    i have done all the above and i still have this error:Error: An error occurred: "System.UnauthorizedAccessException" "Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))"

    any ideas?

     
    Thursday, February 17, 2011 9:27 AM
  • I too am encountering the same error "System.UnauthorizedAccessException" when trying to publish topology for the first time. I have verified the file share as accessable from other computers and have rechecked the installing user's authority. Any other ideas???
    Wednesday, March 23, 2011 6:54 PM
  • Try disabling the Loopback Check, for example via Powershell:

    New-ItemProperty HKLM:\System\CurrentControlSet\Control\Lsa -Name "DisableLoopbackCheck" -Value "1" -PropertyType dword

    Loopback Check disables using FQDN on local server.

     

    • Proposed as answer by Tarun Verma Tuesday, June 28, 2011 11:58 PM
    Monday, April 4, 2011 11:58 AM
  • Try disabling the Loopback Check, for example via Powershell:New-ItemProperty HKLM:\System\CurrentControlSet\Control\Lsa -Name "DisableLoopbackCheck" -Value "1" -PropertyType dword

    This worked for me

    • Proposed as answer by DMTEAM2 Monday, June 18, 2012 1:53 PM
    Friday, May 27, 2011 5:54 PM
  • Yes, I also had the similar issue which got fixed by adding the mentioned Regkey... Thank you all.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, June 28, 2011 11:57 PM
  • I also get similar error while trying to install the standard edition server on win 2k 8 r2

    And it get solved by adding the Regkey

    • Proposed as answer by Ali Al Rubkhi Wednesday, April 25, 2012 5:58 AM
    • Unproposed as answer by Ali Al Rubkhi Wednesday, April 25, 2012 5:58 AM
    Sunday, October 2, 2011 7:06 AM
  • When you create the pool on lync standard edition, you have to use the server name FQDN as pool name.
    Wednesday, April 25, 2012 6:03 AM
  • Hello askwizard,

    I also get simillar error like u.
    for troubleshooting, make sure the server name FQDN same with FQDN on SQL Store,,

    I Hope usefull

    Thursday, January 10, 2013 7:17 PM
  • have you added the dns entry to route to the Control panel. Also have you added the path to the topology.?

    regards 

    Iain Smith

    www.northernlync.co.uk

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Saturday, January 12, 2013 4:09 PM
  • are you running Standard edition or enterprise edition.? csadmins>? windows firewall open?

    regards 

    Iain Smith

    www.northernlync.co.uk

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Saturday, January 12, 2013 4:09 PM
  • Hi,

    Have you tried the solutions written in this thread ? http://social.technet.microsoft.com/Forums/en-US/ocsplanningdeployment/thread/241610f2-5951-4c75-99ef-ac94368c1830

    You problem can be related to a manual installation of SQL Express or a problem with File Share Rights... I suggest you take a close look at this...

    It should probably fix your issue.

    Hope it helps !

    Regards,


    Adrian TUPPER - ABC Systemes - http://thelyncexperience.blog.com/ If answer is helpful, please hit the green arrow on the left, or mark as answer Thank you


    • Edited by adrian.tupper Friday, January 18, 2013 5:48 PM
    • Proposed as answer by adrian.tupper Thursday, January 24, 2013 12:10 PM
    Friday, January 18, 2013 5:47 PM
  • Hey guys,

    what worked for me in this instance was to use CNAMEs pointing to the original host name. That way I could keep all my FQDNs standard should we decide to scale out into pools and such.

    Example: 

    • pool Alias(CNAME) machinename.contoso.com.
    • meet Alias(CNAME) machinename.contoso.com.
    • admin Alias(CNAME) machinename.contoso.com.

    Best of luck!

    Friday, August 23, 2013 1:55 PM
  • thanks for the solution , it worked perfectly
    Saturday, December 8, 2018 7:03 AM