locked
RDP to Hyper-V Guest from Remote Site RRS feed

  • Question

  • We have Server 2008R2 Ent. on a Dell R510.  I've installed another Server 2008R2 Ent as a guest in Hyper-V, and completed the following steps;

    1. Allow RDP connections to the guest OS.

    2. Turned on Network Discovery.

    3. Changed RDP listening port to 3390 on guest.

    4. Created a new firewall rule to allow 3390 access on guest.

    4. Forwarded 3390 on router to guest machine.

    5. NIC on guest has been set to external.

    6. The host has also had the RDP port changed, firewall rule created and router port forwarded.

    Here's the problem...We can RDP to the guest from any other computer on the network using "computername:portnumber", and we can RDP to the host from remote sites using "domainname:portnumber", but can't RDP to the guests from remote sites using "domainname:portnumber".

    Any suggestions appreciated.

    Wednesday, May 23, 2012 5:29 AM

Answers

  • Solved the problem...

    Your comment : hyper-v manager does not care whether the connection is established from the internal network or the external (default gateway). got me thinking.  When the Virtual machines connect to the domain, they get network information from the DHCP server which is also the SBS2003 DC (This DC is being replaced with the new system).  Each of the Virtual Machines had the default gateway set to the DHCP server IP address rather than the router.   Changed the Default Gateway to the Router's internal IP address and all is right with the world.  Interestingly, each VM previously had internet access using the DC as Default Gateway.

    Thanks for the comment...it put me on the right track.


    • Marked as answer by appin Thursday, May 24, 2012 1:14 PM
    • Edited by appin Thursday, May 24, 2012 10:15 PM Extra Comment
    Thursday, May 24, 2012 1:14 PM

All replies

  • I don't know why you changed the listening port of the client to 3390, because you can do this with port forwarding on your firewall. You complicated things to much. Try pinging the guest machine from the remote site, see if it replies. Try changing back client RDP port, see if it works then.


    Adrian Costea - MCP, MCTS, MCSA 2003, MCITP: Windows 7

    My Blog: www.vkernel.ro/blog

    Wednesday, May 23, 2012 7:15 AM
  • Hi,

    Did you get the same issue if you use the default port of remote desktop?

     

     

    Wednesday, May 23, 2012 7:42 AM
  • Thanks for the reply...

    I change the listening port firstly for security but also so that the VM's can be used from remote sites via RDP.  The modem/router I'm using will only forward 3389 to one internal IP address.  You can't access a number of machines, virtual or physical from remote sites unless you use different RDP listening ports...or so I have always been led to believe (I'm a very long way from being an expert in this area). 

    This approach has worked for many years with our existing SBS2003 domain with Virtual Server 2005 Ent. and virtual machines running our Web Server, Email Server and RDS, but I'm having issues with Server 2008 Ent. and Hyper-V.

    I've just tried to reproduce the problem with my home server which uses Server 2008 Std and Hyper-V with an XP VM, very similiar modem/router and tried to connect from work...it works perfectly. 

    I've also loaded a Windows 7 Pro VM onto the work system and can't connect from home.

    Wednesday, May 23, 2012 7:46 AM
  • Please confirm from remote location your PC is able to resolve domain name to IP.

    Or, run command -> nslookup domainname

    An alternative is to use IP instead of domain name.


    ___________________________________________________ Naruphon blog: http://www.vm360degree.com

    Wednesday, May 23, 2012 10:36 AM
  • Hi,

    Make sure that the name of the guest server is resolved to the right IP from remote sites, in your config this should be the external address of you router.

    Try to rdp (or telnet) to the external IP of the router on port 3390
    How is your host domain name resolved from remote?

    Best regards,

    Markus

    Wednesday, May 23, 2012 12:29 PM
  • Chaba_OK...The system is resolving domain names to ip addressses correctly. 

    Markus...The existing system on SBS2003 and Virtual server allows me to use Remote Desktop Connection from anywhere on the planet by either using www.xyz.com:portnumber or ipaddress:portnumber.  The router attached to the internet will only forward 3389 to a single internal ip address.  For this reason I need to change the RDP listening port on internal machines so they have a unique RDP listening port and then forward that port from the router to that machine.  At the moment there are 4 internal machines on the SBS2003 domain that are working perfectly like this ...2 are virtual 2 physical.

    The new system using Server 2008 and Hyper-V allows me to do the same on the physical host, not the virtual machines...these are resolved internally, not externally.  Win XP on my home system resolves both internally as well as externally.

    Wednesday, May 23, 2012 10:21 PM
  • Hi,

    this means:

    rdp to IP:3389 and ports xxxx1 to xxxx3 works and rdp to ip:3390 does not?

    Just for a test, take one of the working ports and use it for the guest.

    Markus

    Thursday, May 24, 2012 7:31 AM
  • RDP to host:3389 works.  RDP to guest:3390 does not work.   Change RDP listening ports in the registry and port forwarding on the router, then RDP to host:3390 works. RDP to guest:3389 does not work.  So it does not appear to be a port problem.

    The only explaination that I can see is that Hyper-V Manager is preventing the port forwarding to the virtual machines.  The same results happen when you try to telnet to the machines for the internet.

    Thursday, May 24, 2012 11:04 AM
  • in your first post you said that rdp to guest:3390 worked from your internal network.

    then it should have nothing to do with your hyper-v manager as the hyper-v manager does not care whether the connection is established from the internal network or the external (default gateway).

    Thursday, May 24, 2012 11:16 AM
  • Solved the problem...

    Your comment : hyper-v manager does not care whether the connection is established from the internal network or the external (default gateway). got me thinking.  When the Virtual machines connect to the domain, they get network information from the DHCP server which is also the SBS2003 DC (This DC is being replaced with the new system).  Each of the Virtual Machines had the default gateway set to the DHCP server IP address rather than the router.   Changed the Default Gateway to the Router's internal IP address and all is right with the world.  Interestingly, each VM previously had internet access using the DC as Default Gateway.

    Thanks for the comment...it put me on the right track.


    • Marked as answer by appin Thursday, May 24, 2012 1:14 PM
    • Edited by appin Thursday, May 24, 2012 10:15 PM Extra Comment
    Thursday, May 24, 2012 1:14 PM
  • I had a similar problem. Solved it assigning an static MAC address to the virtual adapter of the guest machine.
    Thursday, February 9, 2017 12:19 AM