none
SQL Server 2017 Snapshot Replication Issue RRS feed

  • Question

  • Hello,

    I am trying to configure an SQL Server 2017 transactional replication to another SQL Server  2017 , but the snapshot agent returns the following error:
    Message: An unspecified error had occurred in the native SQL Server connection component.
     MSSQL_REPL, Error number: MSSQL_REPL55012)

    I have tried the solutions provided in one of the article posted in this group but even after that i get the same issue.

    I have Configured Publisher, Distributor,Subscriber everything. The permissions are correct and also Updated both the instances to the Latest Service-Pack. Even then it didn't fix the issue.

    Any suggestions how to solve this issue?


    Thanks,
    Hemanth



    • Edited by HemanthJR Friday, May 29, 2020 9:00 PM
    Friday, May 29, 2020 8:51 PM

All replies

  • Hi Hemanth,

    This issue is related to OLE DB driver. Please refer to following posts for solution:
    https://stackoverflow.com/questions/60653504/exception-when-starting-snapshot-agent-when-setting-up-database-replication

    https://social.technet.microsoft.com/Forums/en-US/e2c23cda-9e78-4514-bae6-27c6d34767a4/sql-server-2019-snapshot-agent-error?forum=sqlreplication(Dan68's reply)

    Best Regards,
    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, June 1, 2020 5:46 AM
  • Hi Hemanth,

    Is there any update on this case?
    Please feel free to drop us a note if there is any update.

    Best Regards,
    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, June 2, 2020 8:28 AM
  • Hi,
    I have tried this solution already but none of them didnt help. Im still getting the same issue.
    I have tried multiple times even after making all the changes i have no luck in resolving it.


    Thanks,

    Hemanth

    Thursday, June 4, 2020 1:49 PM
  • Hi Hemanth,

    Can you  see any error message from event viewer or Errorlog?

    Have you tried to add Path variable to SYSTEM Path?

    Uninstall the OLE DB Driver on your computer and reinstall the latest x64 OLE DB driver,  and try the solutions.

    Best Regards,
    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, June 5, 2020 2:21 AM
  • Hi Cris,

    I have tried reinstalling the OLE DB driver with latest one and also added the system path.I still get same error.
    Even in the event viewer i get the same error

    Error messages:
    Message: An unspecified error had occurred in the native SQL Server connection component.
    Stack:    at Microsoft.SqlServer.Replication.Snapshot.SqlServer.NativeBcpOutProvider.ThrowNativeBcpOutException(CConnection* pNativeConnectionWrapper)
       at Microsoft.SqlServer.Replication.Snapshot.SqlServer.NativeBcpOutProvider.ThrowConnectionFailureException(CConnection* pNativeConnectionWrapper)
       at Microsoft.SqlServer.Replication.Snapshot.SqlServer.NativeBcpOutProvider.InitializeNativeBcpOutProvider(LogMessageCallback logMessageCallback, String strName, String strApplication, String strHost, String strServer, String strNetwork, Int32 encryptionLevel, String strDatabase, SecurityMode securityMode, String strLogin, SecureString strPassword, Int32 bcpBatchSize, Int32 loginTimeout, Int32 queryTimeout, Int32 packetSize, DeadlockPriority deadlockPriority, String strRowDelimiter, String strFieldDelimiter, Byte syncMethod, Boolean forceOdbcBcp, Boolean forceOleDbBcp, Boolean enableMultipleActiveResultSets, Boolean useReadPastHint, Boolean usePageLockHint)
       at Microsoft.SqlServer.Replication.Snapshot.TransSnapshotProvider.InstantiateBcpOutProviderWorker(String strBcpConnectionName)
       at Microsoft.SqlServer.Replication.Snapshot.SqlServerSnapshotProvider.InstantiateBcpOutProvider(String strBcpConnectionName)
       at Microsoft.SqlServer.Replication.Snapshot.SqlServer.BcpOutThreadProvider.Initialize()
       at Microsoft.SqlServer.Replication.WorkerThread.NonExceptionBasedAgentThreadProc()
       at Microsoft.SqlServer.Replication.AgentCore.BaseAgentThread.AgentThreadProcWrapper() (Source: MSSQL_REPL, Error number: MSSQL_REPL55012)
    Get help: http://help/MSSQL_REPL55012

    Friday, June 5, 2020 4:06 AM
  • Hi Hemanth,

    Have you installed the Latest CU(CU20) for SQL Server 2017?

    Try to copy the folder 1033 (and its contents) from C:\Windows\System32  to C:\Program Files\Microsoft SQL Server\140\COM.

    Best Regards,
    Cris

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, June 5, 2020 5:19 AM
  • Hi Cris,
    Sorry for delay, 
    I have tried copying the 1033 folder to 140\COM but no luck. Ill try to update the Sql Server wit (CU 20) tonight and see if that helps.

    Can you explain me why i am getting this error? Also. I want to know only the transnational replication will have issue or all the replication methods will have issue due to this error?


    Thanks,

    Hemanth

     
    Wednesday, June 10, 2020 2:58 PM
  • try installing the latest CU

    hiphopza.com

    Wednesday, June 10, 2020 3:37 PM
  • Hi Hemanth,

    Is there any update on this case?
    Please feel free to drop us a note if there is any update.
    Have a nice day!

    Best Regards,
    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, June 15, 2020 1:26 AM
  • Hi Cris,
    I have updated to the latest CU-20 but even after that the issue still exits. Can you tell me what to do next?

    Thanks,
    Hemanth
    Thursday, June 18, 2020 7:14 PM
  • Hi Hemanth,

    Have you tried to clear this transactional replication settings and reconfigure?

    Maybe you can ask professional engineer for help, and they will deal with your problem separately and confidentially.
    https://support.microsoft.com/en-us/assistedsupportproducts 

    Best Regards,
    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, June 19, 2020 1:22 AM