none
Communicator 2007 R2 - Phone Integration Greyed Out RRS feed

  • Question

  • I just purchased a Plantronics Calisto 835-M phone system to use with Communicator 2007 R2.  Windows 7 seemed to install the drivers just find for the Calisto phone, but unfortunately the check box for "Enable Integration With Your Phone System" under the 'Phone Integration' section of the 'Phones' section is greyed out.

    The closest I've come to finding a solution seems to only apply to Communicator 2005, because I do not have "Communicator" listed in:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Communicator

    As descrived here: http://office.microsoft.com/en-us/communicator-help/set-up-your-computer-to-control-your-phone-HP001154833.aspx?redir=0

    The only other leads that seem promising have to do with Group Policies and .adm files, which I've never dealt with before, so I don't even know where to start there.

    I'm hoping this can be fixed with a simple registry edit, any advice would be appreciated.

    Thanks


    Tuesday, November 8, 2011 1:53 AM

All replies

  • Hi,

    as far as i know, Calisto is a plug and play USB device. once you sign in to the communicator, plug in the device and it'll automatically sign in. it'll ring for inbound calls and you can make calls using the device.

    Please note that you need to sign in to the communicator on the PC for calisto to work, it does not have the capability to function by it self.

    For your information, "Enable Integration With Your Phone System" is for RCC with a PBX Integration. Tis feature has nothing to do with the calisto.

    Thamara.

    Tuesday, November 8, 2011 2:20 AM
  • Hi there,

    Please check the group policies for telephony.

    TelephonyMode 1, 2, 3, 4, or 5.

    1.        Enterprise voice

    2.        RCC and computer-to-computer calling

    3.        Enables both RCC and Enterprise Voice

    4.        RCC, no computer-to-computer calling

    5.        No audio, only IM and presence available

    For details, see this document. Hope it helps.

    Thursday, November 10, 2011 6:25 AM
    Moderator
  • Hi there,

    Please check the group policies for telephony.

    TelephonyMode 1, 2, 3, 4, or 5.

    1.        Enterprise voice

    2.        RCC and computer-to-computer calling

    3.        Enables both RCC and Enterprise Voice

    4.        RCC, no computer-to-computer calling

    5.        No audio, only IM and presence available

    For details, see this document. Hope it helps.


    I believe you are on the right track, but unfortunately I do not know how to check which TelephonyMode I currently have.  I looked at your link to Technet, but did not find the instructions there on how to check which TelephonyMode I have.  If you could provide me with a hint on how to do this I would greatly appreciate it. 
    Thursday, November 10, 2011 2:28 PM
  • go to Lync Server control Pannel, users, search for enabled users and open the user properties. in there you can find what's the method that the user enabled for.

    Thamara.

    Thursday, November 10, 2011 2:39 PM
  • Thamara, I am running Communicator 2007 R2.  I believe Lync is a different product, correct?  I realize I am posting in the Lync forum, but that is due to Microsoft redirecting all Communicator forum questions here.
    Thursday, November 10, 2011 6:41 PM
  • you can check it from AD Users and Computers, open user properties and go to "communications" tab and configure "Telephony Options". in there you can see the method that your enabled for OCS. I also have a Calisto 800 and it works just fine with the communicator. I have enabled Enterprice voice for my profile.

    Friday, November 11, 2011 10:05 AM
  • you can check it from AD Users and Computers, open user properties and go to "communications" tab and configure "Telephony Options". in there you can see the method that your enabled for OCS. I also have a Calisto 800 and it works just fine with the communicator. I have enabled Enterprice voice for my profile.

     


    I'm running Windows 7 Enterprise Edition.  In control panel I have "User Accounts".  From there, if I click "Manage User Accounts", I get brought to the "User Accounts" dialog box.  Here there are two tabs, "Users" and "Advanced".

    In "Users" I can highlight my username and select "Properties".  From there the only option is to change myself from my current status of "Administrator" in "Administrator Group", to "Standard User" in "User Group".

    If instead of the "Users" tab I click on the "Advanced" tab, I can "Manage Passwords" or "Advanced".  If I click on "Advanced" in the "Advanced User Management" section a new dialog box pops up called "lusrmgr - [Local Users and Groups (Local)]"

    This dialog box has three vertical panes, "Local Users and Groups (Local)", "Name", and "Actions"

    In the first vertical pane "Local Users and Groups (Local)", there are two folders, "Users" and "Groups".  If I click on either of these folders, then the second vertical pane is populated with different items, none of which seem to be what I need.

     

    Saturday, November 12, 2011 1:43 AM
  • I was talking about the Active Directory Users and Computers. not the local user settings. go the ther sever that installed OCS 2007 R2 and in administrative tools, you can find this.

    Thamara.

    Saturday, November 12, 2011 3:50 AM