locked
Add the second IP to the DAG RRS feed

  • Question

  • Hi all,

    We have the one DAG (DAG1) set up in the production site which includes two MBX servers; mapi network is 172.18.1.0/24 and replication network is 192.168.1.0/24 between these two servers;

    Now, we got the DR site and we want to set up one DAG member in th DR site (active/passive and no user is at DR site). I added the additional DAG memeber in the DR site to the current DAG1 and network subnet is 10.1.10.0/24. When I add the second IP 10.1.10.112 to the current DAG1, the three networks are up in the failover cluster manager. But, I am not able to ping 10.1.10.112. What am I missing?

    Thank you.

    Thursday, July 14, 2011 2:43 PM

Answers

  • Hi,

     

     

    I assume  the  MAPI network in the DR is 192.168.2.0/24.

    So let me summary the network settings.

    Primary site:

    MAPI Network: 172.18.1.0/24

    Replication Network: 192.168.1.0 /24

     

    DR site

    MAPI Network: 10.1.10.0/24

    Replication Network:  192.168.2.0/24

     

    So you need to add one IP address from 172.18.1.0/24 and 10.1.10.0/24, for example 172.18.1.121 and 10.1.10.121

     

    Because you have only configure the default gateway on MAPI network, and leave the field blank on the replication network adapters.

    So you need to add an route for each replication network adapters.

    Primary site:

    Netsh interface ip add route 192.168.2.0 /24 “ReplicationA”  192.168.1.2

    192.168.1.2 is an interface on the router

     

    DR site:

    Netsh interface ip add route 192.168.1.0 /24 “ReplicationA”  192.168.2.2

    192.168.2.2 is an interface on the router

     

    Of course, you need to add routes on each router.

    At first, please make sure you can ping 192.168.2.2 from 192.168.1.2 on the router.





    • Edited by Jerome Xiong Wednesday, July 20, 2011 1:15 AM
    • Marked as answer by SGryzbowski Sunday, July 31, 2011 1:28 PM
    Monday, July 18, 2011 7:10 AM
  • Hi,

     

    As I understand, the VMware hosted by the machine which sit in your internal network.

    If I misunderstand you, please let me know.

    In this way, I don’t think you have any need to use three subnets, you don’t need add another network adapter on mailbox server in the primary site. I even think one site is enough. Both the physical mailbox servers and the virtual mailbox server within 172.18.1.0 /24 subnet.

    You just need to enable replication for the MAPI network.

    [PS]C:\Set-DatabaseAvailabilityGroupNetwork –Identity DAG\DAGNetwork –ReplicationEnable $True

    • Proposed as answer by Jerome Xiong Monday, July 25, 2011 2:30 AM
    • Marked as answer by SGryzbowski Sunday, July 31, 2011 1:28 PM
    Wednesday, July 20, 2011 1:37 AM
  • Run this command:

    Get-DatabaseAvailabilityGroupNetwork -Identity DAGName

    All the network which is enabled replication will take part in replication.

    As i last post, Exchange randomly selects a replication network from the group of replication networks to use for log shipping. Per my knowledge, you can't find out which network is used for replication.


    • Marked as answer by SGryzbowski Sunday, July 31, 2011 1:28 PM
    Thursday, July 28, 2011 1:50 AM
  • I think it won’t cause any issue.

    • Marked as answer by SGryzbowski Sunday, July 31, 2011 1:28 PM
    Friday, July 29, 2011 1:16 AM

All replies

  • >Are the server virtual servers?

    Yes.  VMware platform.

    anything?

    Thank you.

    Thursday, July 14, 2011 3:55 PM
  • Hi,
    The IP Address Cluster Resource will not come online, until you move the Cluster Group to your DR Site.
    In other words, only one of IP Addresses will be online at any given time.
    To test your configuration,  move the Cluster Group to the DR Site. It can be done my running: Cluster Group "Cluster Group" /moveto:DRSERVER

    :Martina

    Thursday, July 14, 2011 3:56 PM
  • Agree with Matrina, At any specific time, the cluster for the DAG will use only one of the assigned IP addresses. Windows Failover Clustering registers this IP address in DNS when the cluster IP address and Network Name resources are brought online.
    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    Thursday, July 14, 2011 4:05 PM
  • Hi,

     

     

    I assume  the  MAPI network in the DR is 192.168.2.0/24.

    So let me summary the network settings.

    Primary site:

    MAPI Network: 172.18.1.0/24

    Replication Network: 192.168.1.0 /24

     

    DR site

    MAPI Network: 10.1.10.0/24

    Replication Network:  192.168.2.0/24

     

    So you need to add one IP address from 172.18.1.0/24 and 10.1.10.0/24, for example 172.18.1.121 and 10.1.10.121

     

    Because you have only configure the default gateway on MAPI network, and leave the field blank on the replication network adapters.

    So you need to add an route for each replication network adapters.

    Primary site:

    Netsh interface ip add route 192.168.2.0 /24 “ReplicationA”  192.168.1.2

    192.168.1.2 is an interface on the router

     

    DR site:

    Netsh interface ip add route 192.168.1.0 /24 “ReplicationA”  192.168.2.2

    192.168.2.2 is an interface on the router

     

    Of course, you need to add routes on each router.

    At first, please make sure you can ping 192.168.2.2 from 192.168.1.2 on the router.





    • Edited by Jerome Xiong Wednesday, July 20, 2011 1:15 AM
    • Marked as answer by SGryzbowski Sunday, July 31, 2011 1:28 PM
    Monday, July 18, 2011 7:10 AM
  • Hi Jerome,

    Thanks for your great help.

    >Primary site:

    Netsh interface ip add route 192.168.2.0 /24 “ReplicationA”  192.168.1.2

    192.168.1.2 is an interface on the router

     

    >Primary site:

    Netsh interface ip add route 192.168.1.0 /24 “ReplicationA”  192.168.2.2

    192.168.2.2 is an interface on the router

     _______________

    Are two netsh for the primary site?  What about the DR site?  Do I need to do

    "netsh"?

     

    Thank you.

    Monday, July 18, 2011 3:52 PM
  • Hi SGryZBOWSKI,

     

    Sorry for the wrong writing.

    The below command should run on the mailbox server in DR site.

    Netsh interface ip add route 192.168.1.0 /24 “ReplicationA” 192.168.2.2

    192.168.2.2 is an interface on the router

    Tuesday, July 19, 2011 1:16 AM
  • Hi Jerome,

    Thanks for your help.

    I talked it to the network guy and he mentioned it's very difficult to set up routing between two replication network in the Production site and DR site since the replication network between two MBX servers at the production site are created through VMware internal network switch)

    That means that the DAG member at the DR site has only one IP 10.1.10.0/24 (no user at DR site and only for the disaster happens at the production site) and 10.1.10.0 will be used for replication too.

    Any drawback on this setup?

    {We have the one DAG (DAG1) set up in the production site which includes two MBX servers; mapi network is 172.18.1.0/24 and replication network is 192.168.1.0/24 between these two servers;     one DAG member in th DR site with network sublet 10.1.10.0/24}

    Thank you.

     

    Tuesday, July 19, 2011 3:10 PM
  • Hi,

     

    As I understand, the VMware hosted by the machine which sit in your internal network.

    If I misunderstand you, please let me know.

    In this way, I don’t think you have any need to use three subnets, you don’t need add another network adapter on mailbox server in the primary site. I even think one site is enough. Both the physical mailbox servers and the virtual mailbox server within 172.18.1.0 /24 subnet.

    You just need to enable replication for the MAPI network.

    [PS]C:\Set-DatabaseAvailabilityGroupNetwork –Identity DAG\DAGNetwork –ReplicationEnable $True

    • Proposed as answer by Jerome Xiong Monday, July 25, 2011 2:30 AM
    • Marked as answer by SGryzbowski Sunday, July 31, 2011 1:28 PM
    Wednesday, July 20, 2011 1:37 AM
  • Hi Jerome,

    >As I understand, the VMware hosted by the machine which sit in your internal network.

     

    Yes.

     

    If I check the DAG networks in the EMC<,it shows that

    DAG01-MAPI Network  172.18.0.0/16   replication enabled

    DAG01-REplication Network    192.168.30.0/24  replicaeion enabled.

    DAGNetwork01      10.1.12.0/24 replication enabled

     

    I can just disable the replication network without causing too much problems?  Will there be any

    performance issue since MAPI and REplication use the same network (1200 users)?

     

    Thank you.

     

     

     

     

    Friday, July 22, 2011 2:33 PM
  • As i know, most of Ethernet is Gbit network at present.

    So i think it is enough. It won't cause any issue.

    Monday, July 25, 2011 2:30 AM
  • Hi Jerome,

    Thanks for your continuing support.

    If I do not disable the replication network, will it cause any issue?

    here is my DAG networks now:

    I check the DAG networks in the EMC<,it shows that

    DAG01-MAPI Network  172.18.0.0/16   replication enabled

    DAG01-REplication Network    192.168.30.0/24  replicaeion enabled.

    DAGNetwork01      10.1.12.0/24 replication enabled

    _________________________-

    If I need to move mailbox from one MBX to another MBX, which NIC the moving process is

    going to use?

     

    Thank you.

    Monday, July 25, 2011 7:48 PM
  • Hi SGryzbowski,

    Quote: A DAG network is a collection of one or more subnets used for either replication traffic or MAPI traffic. Each DAG contains a maximum of one MAPI network and zero or more replication networks. In a single network adapter configuration, the network is used for both MAPI and replication traffic. Although a single network adapter and path is supported, we recommend that each DAG have a minimum of two DAG networks. In a two-network configuration, one network is typically dedicated for replication traffic, and the other network is used primarily for MAPI traffic. You can also add network adapters to each DAG member and configure additional DAG networks as replication networks

    Note: When using multiple replication networks, there's no way to specify an order of precedence for network use. Exchange randomly selects a replication network from the group of replication networks to use for log shipping.

    More information:

    Managing Database Availability Groups

    Tuesday, July 26, 2011 1:16 AM
  • Hi Jerome,

    Thank you for your time to help me.

    Is there a way to find out which network DB replication is using?

    Thank you.

    Wednesday, July 27, 2011 4:14 PM
  • Run this command:

    Get-DatabaseAvailabilityGroupNetwork -Identity DAGName

    All the network which is enabled replication will take part in replication.

    As i last post, Exchange randomly selects a replication network from the group of replication networks to use for log shipping. Per my knowledge, you can't find out which network is used for replication.


    • Marked as answer by SGryzbowski Sunday, July 31, 2011 1:28 PM
    Thursday, July 28, 2011 1:50 AM
  • Hi Jerome,

    Thank you for your time and continuing support.

    If I do not disable replication network between two MBX servers in production site, does my below DAG network cause any issue?

    __________________________________

    here is my DAG networks now:

    I check the DAG networks in the EMC<,it shows that

    DAG01-MAPI Network  172.18.0.0/16   replication enabled          

    DAG01-REplication Network    192.168.30.0/24  replicaeion enabled. 

     (MBX1 and MBX2 have two NICs  production site)

    DAGNetwork01      10.1.12.0/24 replication enabled  (DR site  one MBX only one NIC and only routing between 172.18.0.0/16 and 10.1.12.0/24)  ALL MBX servers are in one DAG

     

    Thank you.

    Thursday, July 28, 2011 2:36 PM
  • I think it won’t cause any issue.

    • Marked as answer by SGryzbowski Sunday, July 31, 2011 1:28 PM
    Friday, July 29, 2011 1:16 AM
  • Hi Jerome,

    Since this thread is answered already, sorry to bother you agian.

    If we need to seed database between two sites, will the above network design cause any issue?

     

    Thank you.

    Tuesday, August 2, 2011 6:07 PM
  • Of course not.
    Wednesday, August 3, 2011 1:10 AM