none
No incoming calls on Iphone after 30 minutes S4B

    Question

  • Hi,

     

    We have 500 users with Iphones in the organisation with IOS 10 (10.0.2 and 10.0.3) deployed, and all of them having the same issue: there are no inoming calls after you don't use the phone for a short time (like 15 till 30 minutes). If you then use the app (just open it) the calls come trough. After some minutes of inactivity the calls are only offered at the pc client and not the mobile.

    I have checked the settings on the Iphone (push notifications are on, voice settings are on cellular, background app refresh is on, all the other notifications are on).

    I have tested this with the Skype for Business client version: 6.14.0.224

    Also tested with : 6.12 versions and 6.11 versions.

    I have checked all the setting on the pc client, but there also tried different setting with no succes.

    Is there some configuration missing (phone / app functionality / server)? 


    Thanks for the help !

    Thursday, April 20, 2017 9:49 AM

All replies

  • Are they on their PC when they notice the calls not coming through? If so the PC is probably being listed as the active device for the user and calls are directed to that client. Are you able to recreate this issue if the user is not signed into a PC?

    -Don

    Thursday, April 20, 2017 10:35 PM
  • Hi,

    Although you have already checked settings but can you please clarify whether you have checked notification setting. From the Settings app, tap Notification Center and then select Skype for Business. Then select how you want notifications to be displayed. Also, I have not used that much SFB on iPhone but in Android's SFB settings, there is a option "Keep running in background" which we need to enable by marking a tick on it. So you can also check whether such option is visible in SFB iOS app.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. Thanks.

    Friday, April 21, 2017 5:53 AM
  • Hi 1984_sk,

    In order to narrow down this issue, please help us confirm the following questions:
    1.Did this issues also appear on the Android phone?
    2.Can you receive IM message after 15 to 30 minutes?
    3.Which product did you use for the reverse proxy?

    Based on my test, after 20 minutes, SFB mobile client still receive incoming calls as normal. (I have the same version as yours 6.14.0.224), please make sure your SFB mobile client is running in the background. For test purpose, please try to reset one of your IOS deceive then test if there is the same issue.

    For server side, try to check if there are any event IDs in your SFB server, if possible, please provide it for us to do further troubleshooting.


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 21, 2017 8:29 AM
    Moderator
  • Hi Don,

    I've tried this already. Even when they are not logged in the pc client app, it still doens't work.

    Tuesday, April 25, 2017 9:46 AM
  • This is turned on, so this is not the issue.
    Tuesday, April 25, 2017 9:47 AM
  • Hi Alice,

    1) Yess even on the Android, it doesn.t work.

    2) Yess I can receive IM after 30 minutes. After recieving IM Messages the phone is active, so people can get called on the mobile app.

    3) KEMP loadmaster. This is configured with the officials templates for Skype for Business.

    The app is running in the background, so people don't close the app.

    In event viewer we saw the following:

    - External-WebApp-Edge [HTTP side error:The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.]

    Further there were no weird things going on. Can I look for something strange?

    21 hours 48 minutes ago
  • This more looks like some thing is closing connection between client and server, You may need to keep a network capture running on RP and FE servers and repro the whole scenario.

    Track the connection made by phone to sign in and see if you observe any thing closing connection with phone or server side.

    Also if not already checked then make sure RP is relaying down requests to FE on 4443

    13 hours 39 minutes ago