none
Replication error RRS feed

  • Question

  • Ours is a SQL Server 2016 server. I have configured distribution successfully. Next, I right clicked on Local publications and it is throwing an error as follows:

    172.25.16.39 must be enabled as a Publisher before you can create a publication. 




    Kiran

    Tuesday, May 5, 2020 8:00 AM

Answers

  • Hi Kiran,

    I reproduced your problem in my environment. I set it up like this:
    On the SSMS, connect to a SQL Server instance using the IP address, and set it to Distributor.
    But right clicked on Local publications it is throwing an error as you showed.

    So i add the Publishers in Distributor Properties, but this time using the machine name(where this Server instance is located) to connect the server, then it works.

    So you can add the Publishers using the machine name,  or you directly connect to the Server by the machine name and configure the Replication.

    Best Regards,
    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, May 6, 2020 2:04 AM
  • Hi Kiran,
    It can be seen that this SQL Server instance is the default instance. For the default instance listening on port 1433, you can use only the IP address or computer name (servername) to connect.

    So are you remotely connecting to this SQL Server instance on the local SSMS?

    Currently you can use the IP address to connect to this instance, but you cannot use the computer name to connect. There may be a name resolution problem.

    First, in the command prompt window on the client computer, type ping, and then type the IP address of the computer that is running SQL Server.
    For example: ping 172.25.16.39

    If the ping to the IP address is successful, continue to type ping and then the name of the computer that is running SQL Server.
    For example: ping 969263-SQLCLUS2

    If this operation returns Destination host unreachable or Request timed out, type ipconfig / flushdns to clear the DNS (dynamic name resolution) cache. Then ping this computer name again to see if the operation is successful.

    Best Regards,
    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by juniorkiran Thursday, May 7, 2020 3:44 AM
    Thursday, May 7, 2020 1:48 AM

All replies

  • Hi Kiran,

    You need to enable the server 172.25.16.39 as a Publisher.  

    1.right click on Local Publications, and click the Distributor Properties


    2. add the Publishers

    Best Regards,
    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, May 5, 2020 9:52 AM
  • I did those steps but when I right clicked on Local publications it is throwing an error as follows:
    172.25.16.39 must be enabled as a Publisher before you can create a publication. 

    Kiran



    • Edited by juniorkiran Tuesday, May 5, 2020 10:47 AM Screenshot
    Tuesday, May 5, 2020 10:23 AM
  • Hi Kiran,

    I reproduced your problem in my environment. I set it up like this:
    On the SSMS, connect to a SQL Server instance using the IP address, and set it to Distributor.
    But right clicked on Local publications it is throwing an error as you showed.

    So i add the Publishers in Distributor Properties, but this time using the machine name(where this Server instance is located) to connect the server, then it works.

    So you can add the Publishers using the machine name,  or you directly connect to the Server by the machine name and configure the Replication.

    Best Regards,
    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, May 6, 2020 2:04 AM
  • How to find the machine name?

    Kiran

    Wednesday, May 6, 2020 3:34 AM
  • Hi Kiran,

    select @@SERVERNAME

    Best Regards,

    Cris



    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, May 6, 2020 4:03 AM
  • Hi Kiran,

    Was your issue resolved?

    Best Regards,

    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, May 6, 2020 7:32 AM
  • I ran @@servername and tried to connect to the instance but it is throwing error


    Kiran

    Wednesday, May 6, 2020 10:39 AM
  • Hi Kiran,
    It can be seen that this SQL Server instance is the default instance. For the default instance listening on port 1433, you can use only the IP address or computer name (servername) to connect.

    So are you remotely connecting to this SQL Server instance on the local SSMS?

    Currently you can use the IP address to connect to this instance, but you cannot use the computer name to connect. There may be a name resolution problem.

    First, in the command prompt window on the client computer, type ping, and then type the IP address of the computer that is running SQL Server.
    For example: ping 172.25.16.39

    If the ping to the IP address is successful, continue to type ping and then the name of the computer that is running SQL Server.
    For example: ping 969263-SQLCLUS2

    If this operation returns Destination host unreachable or Request timed out, type ipconfig / flushdns to clear the DNS (dynamic name resolution) cache. Then ping this computer name again to see if the operation is successful.

    Best Regards,
    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by juniorkiran Thursday, May 7, 2020 3:44 AM
    Thursday, May 7, 2020 1:48 AM