locked
I can't turn iSCSI DAG Network Replication Off RRS feed

  • Question

  • I have iSCSI for my on-prem Exchange 2013 servers for storage. Using either the ECP or PowerShell commands, when I set the DAG Replication Network to Manual and deselect Enable Replication, the check box comes back and selects itself within a few minutes.  I've used the steps documented on http://msexchangeguru.com/2012/01/02/disable-iscsi-dags/ which are the same as https://blogs.technet.microsoft.com/shekhar37k/2014/06/03/dag-network-shows-misconfigured-in-exchange-2013-server/, but the box <g class="gr_ gr_61 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" data-gr-id="61" id="61">keep</g> checking itself within a few minutes. I obviously DON'T want replication on my storage network.

    Has anybody else experienced this, and if so, how do I fix it?

    Many thanks.



    • Edited by VirCotto Thursday, May 4, 2017 4:30 PM
    Thursday, May 4, 2017 4:29 PM

All replies

  • Rename the DAG network for the iSCSI networks to something easily identifiable as an iSCSI network, and set it to be ignored.

    Set-DatabaseAvailabilityGroupNetwork -Identity <AutomaticallyGeneratedName> -Name "iSCSI 1" -IgnoreNetwork $True


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Friday, May 5, 2017 1:42 AM
  • I have performed this, but when I use "Set-DatabaseAvailabilityGroup DAGNAME –DiscoverNetworks" afterwards, the setting is reset.

    • Edited by VirCotto Friday, May 5, 2017 7:37 PM
    Friday, May 5, 2017 7:37 PM
  • Don't do that and turn off auto-discovery of networks.

    Set-DatabaseAvailabilityGroup -Identity DAGNAME -DiscoverNetworks $False

    https://technet.microsoft.com/en-us/library/dd297934(v=exchg.160).aspx


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!


    Friday, May 5, 2017 9:35 PM