locked
Exchange Replication Hung Up RRS feed

  • Question

  • Hi everyone,

    I had a weird issue the other day happen to my Exchange environment and wanted to run this past the community. I've never had this happen before to me.

    So Wednesday night, I got called saying no one was able to log into Outlook. I checked and sure enough, I couldn't either. When I logged into the Exchange box, I noticed that my DAG was saying all the Passive copies of my databases were in a disconnected and healthy state. My active copies were all saying Mounted except for two which had failed over to the passive node. All the databases disconnected and healthy state would not allow me to resume replication. I ended up having to restart the replication service on the passive box for the DAG to show all passive copies as Healthy and all active copies as Mounted. After moving the two databases back over to their active node, I could log into Outlook with no problem.

    It looks like I had a momentarily network disruption which resulted in Exchange kicking off the failover, but the failover never completed except for two databases. The event gave me two errors of 2153 and 4113.

    Error 2153

    Error 4113

    Besides establishing some monitoring to monitor the replication service, what are some best practices or steps I can do to prevent this from happening or at least make sure Exchange fails over properly and not hang?

    Thanks everyone!

    Friday, May 5, 2017 3:00 PM

All replies

  • Hi,

    We always need to make sure Network connection is working smoothly between DAG members. 

    What's the current version of exchange server? Get-ExchangeServer | FL Name,*admin*

    According to error 2153, generally that's replication network issue. 3 facts to remind first:

    1. DAGs have 2 defined networks: MAPI Network and Replication Network.
    2. Replication traffic (Log replication, Heartbeat traffic) goes through the Replication Network
    3. Exception: Database seeding or re-seeding always goes through the MAPI network.

    So try to disable replication on “Replication Network” and enable replication on “MAPI Network”. Then restart the MSExchange Replication service. Check the results in few days.


    Best Regards,

    Lynn-Li
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    Tuesday, May 9, 2017 5:52 AM
    Moderator
  • Please note that #3 is not correct

    Exception: Database seeding or re-seeding always goes through the MAPI network.

    We can control this using PowerShell.

    https://technet.microsoft.com/en-us/library/dd335201%28v=exchg.160%29.aspx?f=255&MSPPError=-2147217396

    In pre 2016 CU3 builds it is CI, that only uses MAPI.  2016 Cu3 introduced read from passive:

    https://blogs.technet.microsoft.com/rmilne/2016/09/20/exchange-2016-cu3-released/


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Saturday, May 13, 2017 1:31 PM