none
The term "New-MailboxExportRequest" is not recognized. RRS feed

  • Question

  • Hi,

    I'm trying to backup the mailboxes on my exchange server 2010 running on server 2008 R2 using the script from Steve Goodman (http://www.stevieg.org/2010/07/using-the-exchange-2010-sp1-mailbox-export-features-for-mass-exports-to-pst/)

    I followed every step that is described in the tutorial. But if I run the script I get: The term "New-MailboxExportRequest" is not recognized as the name of a cmdlet, function, script file, or operable program.

    The permissions for the folder are: exchange trusted subsystem, administrators Full control. I ran the command "New-ManagementRoleAssignment -Role "Mailbox Import Export" -User Administrator" in the powershell of exchange. I tried exporting a single mailbox to PST but I got the same error. Nothing seems to work.

    Does anyone know a solution? Help would be appreciated.

    Cheers

    Thursday, June 23, 2011 9:29 AM

Answers

  • Hi Sturme,

     

    I suggest you follow this document use New-MailboxExportRequest to export the mailbox, then check whether this issue will occur or not.

     

    New-MailboxExportRequest

    http://technet.microsoft.com/en-us/library/ff607299.aspx

     

    If you want to use the script from Steve Goodman, please paste the exact error you get (when you run it in Exchange Management Shell ).

     

    Thanks,


    Evan


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, June 27, 2011 9:35 AM
    Moderator

All replies

  • Hi,

    This command is only available in SP1 or newer. Did you install Exchange 2010 SP1?

    Leif

    • Marked as answer by Sturme Thursday, June 23, 2011 12:35 PM
    • Unmarked as answer by Sturme Thursday, June 23, 2011 12:35 PM
    Thursday, June 23, 2011 9:50 AM
  • Thx for the quick response,

     

    No I didn't had SP1 installed. Now that I've done the installation of SP1 for exchange I run the script and it gives me this error:

    There is no available servers running the Microsoft Exchange Mailbox Replication service.


    Any thoughts?

     

    Cheers

     



    Thursday, June 23, 2011 11:16 AM
  • Hi,

    That service is normally running on the CAS servers - please check that the service is started.

    Leif

    Thursday, June 23, 2011 11:35 AM
  • Yes the service is running.

    I just installed Update Rollup 3 for Exchange Server 2010 (KB981401), but did didn't solve the problem.

    I have 4 users that I what to back up via a PSTFile, 3 mailboxes (2 users and discover search mailbox) don't work but administrator mailbox does work.

     

    I'm stuck, dont know wath to do next..

    Help would be appreciated.

     

     



    Thursday, June 23, 2011 11:40 AM
  • Hi Sturme,

     

    I suggest you follow this document use New-MailboxExportRequest to export the mailbox, then check whether this issue will occur or not.

     

    New-MailboxExportRequest

    http://technet.microsoft.com/en-us/library/ff607299.aspx

     

    If you want to use the script from Steve Goodman, please paste the exact error you get (when you run it in Exchange Management Shell ).

     

    Thanks,


    Evan


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, June 27, 2011 9:35 AM
    Moderator
  • I am having a similiar issue but it is telling me the following:

    "The Term 'New-MailboxExportRequest' is not recognized as the name of a cmdlet, function, script file, or operable program

     

    What am I missing? We have everything up to date on the server with regards to updates.

     

    Can someone please help?


    Jessica Cochran
    Monday, August 29, 2011 2:25 PM
  • Hi Jessica,

    Did you come right with this? I have looked and can't find an answer to this... We have Exchange 2010 SP1 /w rollup 5 installed and still can't run this command from the Exchange Management Shell...

    "The term 'New-MailboxExportRequest' is not recognized as the name of a cmdlet"

    Any assistance would be greatly appreciated.

    Kind regards,
    granitewilli 

    Monday, October 24, 2011 6:34 AM
  • Hi All...

    After some further investigation, I have found that in order to run the 'New-MailboxExportRequest' command, you need to run the following first:

    New-ManagementRoleAssignment –Role “Mailbox Import Export” –User "DOMAIN\USER"

    (replace "DOMAIN" with your domain and "USER" with your user that resides within your domain for which you would like to allow this export)

    Thereafter the 'New-MailboxExportRequest' command worked perfectly for me.

    New-MailboxExportRequest -Mailbox USER -FilePath "\\SERVER\SHARE\USER.pst"

    Hope this helps others looking for the solution more than the previous entries :)

    Kind regards,
    granitewilli 


    • Proposed as answer by granitewilli Monday, October 24, 2011 7:31 AM
    • Edited by granitewilli Monday, October 24, 2011 7:31 AM omitted closing bracket
    Monday, October 24, 2011 7:31 AM
  • Hi All...

    After some further investigation, I have found that in order to run the 'New-MailboxExportRequest' command, you need to run the following first:

    New-ManagementRoleAssignment –Role “Mailbox Import Export” –User "DOMAIN\USER"

    (replace "DOMAIN" with your domain and "USER" with your user that resides within your domain for which you would like to allow this export)

    Thereafter the 'New-MailboxExportRequest' command worked perfectly for me.

    New-MailboxExportRequest -Mailbox USER -FilePath "\\SERVER\SHARE\USER.pst"

    Hope this helps others looking for the solution more than the previous entries :)

    Kind regards,
    granitewilli 


    Just a side note: After you add the role assignment you will first have to exit out of the Exchange Management Shell and then get back in before running the New-MailboxExportRequest.  The cause is that roles are loaded when the Management Shell is loaded - if the rights didn't already exist they will not be loaded and you will receive the error that the cmdlet is not recognized.  Once you exit out and restart the exchange management shell the command should be recognized 
    -Pete
    • Proposed as answer by codys_357 Tuesday, June 11, 2013 8:18 PM
    Tuesday, December 13, 2011 9:00 PM
  • Pete. Thank you for the side note! This was driving me mad.
    Thursday, July 26, 2012 4:00 AM
  • What granitewilli suggested worked! ...and thanks for the note Pete - worked only after restarted the shell! Couldn't figure out why I was still getting the error!
    Friday, August 3, 2012 5:51 PM
  • Awesome. Thanks for that. Worked perfectly.
    Wednesday, November 28, 2012 6:53 PM
  • Just Restarted the power shell and Worked. Thanks.
    Thursday, January 3, 2013 3:21 PM
  • This side not it important even I was bit concerned, but now I can run cmdlet New-MailboxExportRequest Thanks.
    Sunday, June 23, 2013 11:43 AM
  • HI All,

    I also had the same issue, but I fixed this on this way..

    1: Open EMS type this command: New-ManagementRoleAssignment -Role "Mailbox Import Export" -User domain\AdminUser  (replace the domain and admin user)

    2: Close the EMS.

    3: Re-open EMS and export the pst file eg..

     (New-MailboxExportRequest -Mailbox "Secedit" -FilePath "\\sharelocation\secedit.pst")  (here secedit is username)

    Cheers!

    Sanjay

    Wednesday, July 10, 2013 3:18 PM
  • HI All,

    I also had the same issue, but I fixed this on this way..

    1: Open EMS type this command: New-ManagementRoleAssignment -Role "Mailbox Import Export" -User domain\AdminUser  (replace the domain and admin user)

    2: Close the EMS.

    3: Re-open EMS and export the pst file eg..

     (New-MailboxExportRequest -Mailbox "Secedit" -FilePath "\\sharelocation\secedit.pst")  (here secedit is username)

    Cheers!

    Sanjay

    This fixed my problem.  Thank you for posting this.   (after setting the mailbox role I had to exit powershell and reopen EMS for the Get-mailboxexportrequest to be recognized)

    • Proposed as answer by Berns333 Tuesday, August 2, 2016 2:05 AM
    Wednesday, September 25, 2013 8:29 PM
  • For Exchange 2013 you must first enter this before the commands are available.

    Add-pssnapin
    Microsoft.Exchange.Management.Powershell.SnapIn

    You can see which are available thru this command:

    get-pssnapin -registered

    Thursday, November 21, 2013 8:38 PM
  • granitewilli, PopePeter

    The posted resolutions worked perfect. Thanks for spending the time posting assistance.

    Thursday, January 23, 2014 5:41 PM
  • Fixed  "running as administrator" the Exchange Management Shell 
    Thursday, August 14, 2014 3:03 AM
  • thanks to you both granitewilli and pete. did the trick, assigned rights, exited out, back in, export worked sucessfully
    Friday, June 19, 2015 2:18 PM
  • Fantastic, this saved me a lot of work.

    Moses Hull of Alexant Systems

    Friday, July 31, 2015 9:55 PM
  • One additional step helped me...close and reopen the Exchange Management Shell after running the New-ManagementRoleAssignment command (the New-MailboxExportRequest command wasn't recognized till I did this).

    Hope this extra step helps! 

    Wednesday, March 23, 2016 4:34 PM
  • This is the real answer. Thank you very much!
    Wednesday, March 30, 2016 2:24 PM
  • Most helpful comment in the thread - Exit Shell and restart.  Thanks!  :-)
    Thursday, December 22, 2016 7:36 PM
  • I was frustrated as well...  I also had discovered that I had to log out and log back in for the permissions to take affect.

    thank you again for this...

    Stan...

    Thursday, January 19, 2017 9:34 PM
  • Thanks granitewilli AND the add of Pete on exiting out and back in.  moved me onto exporting files quick.  Doug
    Friday, May 11, 2018 5:39 PM
  • its working....
    Monday, November 5, 2018 10:03 AM