none
Mapped drive disconnected, but icon remains

    Question

  • I've a PC that had a network drive mapped to "X:". The drive has become disconnected and I am both unable to reconnect it or to remove the "Disconnected Network Drive (X:)" icon from Windows Explorer.

    If I run the "net use" command, the drive does not show up (other mapped drives do).

    If I run a command to connect the drive, "net use X: \\cifs01\UserData\Transcription", the system responds with "System error 85 has occurred. The local device name is already in use."

    If I run a command to disconnect the drive, "net use X: /delete", the system response with "The network connection could not be found."

    I've looked around in the registry. There are no entries in HKCU\Network. I found an entry related to it in HKEY_USERS\.DEFAULT\Network, but I'm not certain what deleting that key would do (hence I'm not going to do anything until I find out).

    Can someone provide a bit of guidance, please?

    Thanks.

    Tuesday, August 19, 2014 4:29 PM

Answers

  • Hi  Snow Critter,

    Have you tried with a command line to delete the mapped drive? Run the command line Window and try the command below:

    net use /del z: ,  or, net use /del *:

    Z means the drive letter, * means the whole mapped drive.

    Regards


    Wade Liu
    TechNet Community Support


    Wednesday, September 03, 2014 7:57 AM

All replies

  • Hi  Snow Critter,

    According to your description, this situation happens when a non-administrative user attempts to reconnect to a shared network drive that the user has already used, system error 85 ("Local device name already in use") may be generated. This behavior is caused by a setting of 1 in the following registry value:

    HKLM\System\CurrentControlSet\Control\SessionManager\ProtectionMode

    If the setting is 1, the problem occurs. If you change the setting to 0 and reboot the server, the problem disappears.

    To fix this issue, Change the entry for HKLM\System\CurrentControlSet\Control\SessionManager\ProtectionMode from 1 to 0.

    You can also find the detailed information at:

    http://support.microsoft.com/kb/253821/en-us

    Regards


    Wade Liu
    TechNet Community Support


    Thursday, August 21, 2014 8:44 AM
  • Thanks for the response!

    I looked for the registry key that you mentioned on the PC in question and found that it doesn't exist. Additionally, the error occurs for any and all users - even those with administrative privileges.

    Can I add this key? If so, what type of key is it (REG_BINARY, REG_DWORD, etc)?

    Thursday, August 21, 2014 12:17 PM
  • Hi  Snow Critter,

    Check the key as it is in the screenshot below, it is in the right pane:

    The key is related to net use session manager, if you fail to remove the Disconnected Network Drive (X:), this normally because a connection that is in use by a session, in this case, you can boot your computer in safe mode to remove this, and add it again after restarting your computer in a normal mode, to boot in safe mode:

    1.Restart the computer.

    2.Press and hold the F8 key as your computer restarts. You need to press F8 before the Windows logo appears.

    3.On the Advanced Boot Options screen, use the arrow keys to highlight the safe mode option you want, and then press Enter. For more information about options.

    You can also follow this for detail:

    http://windows.microsoft.com/en-us/windows/start-computer-safe-mode#start-computer-safe-mode=windows-7

    Regards


    Wade Liu
    TechNet Community Support

    Saturday, August 23, 2014 11:38 PM
  • Ah, there it is!

    I rebooted the system in Safe Mode and noticed that the drive in question no longer appeared in Windows Explorer.

    I edited the registry and removed the HKLM\System\CurrentControlSet\Control\SessionManager\ProtectionMode key. I restarted the computer and logged-in as a normal user. The "Disconnected Network Drive" icon was still there (and I still can't get rid of it). I also tried logging-in as a user with administrative permissions - still no joy.

    I put the registry key back in place with a value of zero (0).

    Thanks for all the help so far. I'm not ready to give up on this yet.

    Monday, August 25, 2014 12:45 PM
  • Hi  Snow Critter,

    Try a clean boot to solve this, a clean boot is performed to start Windows by using a minimal set of drivers and startup programs:

    1.Log on to the computer by using an account that has administrator rights.

    2.Click Start, type msconfig.exe in the Start Search box, and then press Enter to start the System Configuration utility.

    3.On the General tab, click the Selective startup option, and then click to clear the Load startup items check box.

    4.On the Services tab, click to select the Hide all Microsoft services check box, and then click Disable all.

    5.Click OK, and then click Restart.

    Or you can also follow the link below to do this:

    http://support.microsoft.com/kb/929135/en-us

    Regards


    Wade Liu
    TechNet Community Support

    Tuesday, August 26, 2014 1:55 AM
  • I performed a clean boot as described in the knowledge base article, but the "Disconnected Network Drive" icon is still there and I still can't get rid of it.

    Tuesday, August 26, 2014 12:26 PM
  • Hi Snow Critter,

    Because in a normal mode it may be in use by some other applications or services. Since in Safe Mode, the mapped drive connection in question no longer appeared in Windows Explorer. The "Disconnected Network Drive" icon can be deleted or get rid of in safe mode.

    Regards


    Wade Liu
    TechNet Community Support

    Thursday, August 28, 2014 8:49 AM
  • But the "Disconnected Network Drive" icon doesn't appear when running in Safe Mode, so there's nothing to delete. I started the PC in "Safe Mode with Networking" and logged-in. I opened Windows Explorer and the "Disconnected Network Drive" icon was not there. Just for giggles, I opened a command window and entered the "net use" command. It responded that there were no entries in the list.

    I restarted the PC in normal mode and logged-in as an administrator. I opened Windows Explorer and, sure enough, the "Disconnected Network Drive" icon was there. I opened a command window and entered the "net use" command and it responded that there were no entries in the list. I also ran the "net use X: \\cifs01\UserData\SharedFolder" command to try to reconnect the drive. The command responded that the mapping was already in use. It can't be both, but it sure seems to be.

    Thursday, August 28, 2014 8:12 PM
  • Hi  SnowCritter,

    Try to delete it from the registry keys.

    Find the Registry Key by typing “regedit” in the Windows Command Line. Once in the Registry Editor, use the folder tree on the left hand side to browse to: " HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices", In this key you will find all of the settings for your mapped network drives, delete drive letter. Right-click the key for the drive you no longer want and click Delete.

    Any other problem, you can post it back.

    Regards


    Wade Liu
    TechNet Community Support

    Sunday, August 31, 2014 3:09 AM
  • Thanks for the info.

    I looked in HKLM\System\MountedDevices - the drive in question is not shown (but neither is a drive that actually *is* mounted).

    Looks like this is something I may just have to "live with" (but I'd still love to get rid of it).

    Tuesday, September 02, 2014 1:07 PM
  • Hi  Snow Critter,

    Have you tried with a command line to delete the mapped drive? Run the command line Window and try the command below:

    net use /del z: ,  or, net use /del *:

    Z means the drive letter, * means the whole mapped drive.

    Regards


    Wade Liu
    TechNet Community Support


    Wednesday, September 03, 2014 7:57 AM
  • It was one of the first things I tried - didn't work (see my initial post).
    Tuesday, September 09, 2014 12:12 PM
  • Look for the mount here.  Delete it and then reboot.  It should be gone.

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2]

    • Edited by GTS-NJ Tuesday, September 09, 2014 2:56 PM
    Tuesday, September 09, 2014 2:55 PM
  • The drive in question isn't listed in the "..\MountPoints2" keys.
    Tuesday, September 09, 2014 3:22 PM