Standard TCP/IP Port missing from drop down "Create a new port and add a new printer"


  • Somehow someone was on my print server and made some changes or added some software.  I found that the "HP Universal Print Monitor" was my only other choice besides Local Port when I went to add a new printer on my 2012 print server "Standard TCP/IP Port" was gone.  I ended removing this from the registry (see below) as I could not find any other way to uninstall it.  After this was removed I did reboot and I can still add a normal Standard TCP/IP Port under print management in the ports section but this option is gone in the drop down when you add a printer under printers. 

    Any idea how to get this option back into the drop down list?


    Saturday, January 3, 2015 3:09 PM


All replies

  • If you are looking to add Standard TCP/IP Port into the monitor entry, go ahead.

    I would actually export the key from a working machine and import on this one.

    tcpmon.dll, tcpmib.dll, and tcpmonui.dll need to reside in the \windows\system32 directory.

    Alan Morris formerly with Windows Printing Team

    Monday, January 5, 2015 3:29 AM
  • Thanks for the reply, I actually still do have the TCP/IP entry under the Monitors folder in the registry and have all of the correct .dll's under system32 directory. 

    I am still able to add a standard TCP/IP port on the print server but need to from the ports section of Print Management and cannot add a new TCP/IP port from the "add printer" Network Printer Installation Wizard as the Standard TCP/IP Port option is not available in the "Create a new port and add a new printer".  I currently only have Local Port and HP Universal Print Monitor as choices.

    Monday, January 5, 2015 2:23 PM
  • I followed these instructions and everything is correct and still do not have the tcp/ip option

    Restore missing Standard TCP/IP Port type for Printer
    Filed under:  Tips n Tricks — Rahul Patel @ 5:01 pm

    If the TCP/IP port option is missing you need to re-add it.

    First, make sure that the following files are in C:\Windows\System32\:


    If they are missing, you will need to copy them there from either the i386 directory (if you have one) or from the original install CD.

    Then, copy the following lines to NOTEPAD and save the file to your desktop as “printer.reg

    Windows Registry Editor Version 5.00

          [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP Port]

          [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP Port\Ports]

    Once it’s saved to your desktop, double-click printer.reg and say “OK” to the warning that you will be adding the keys to your registry.

    Reboot the Server and the TCP/IP port option should be back.

    Monday, January 5, 2015 2:28 PM
  • Is this all local or are you using remote management?

    Alan Morris formerly with Windows Printing Team

    Monday, January 5, 2015 6:59 PM
  • This print server is on a cluster so it is a VM so I am using remote desktop to get it.
    Wednesday, January 7, 2015 2:29 PM
  • In the Network Add Printer Wizard, (printui /ip)  one selects

    Add a TCP/IP or Web Services Printer by IP address or hostname

    to add Standard TCP/IP Ports.

    Type of Device  TCP/IP Device in the drop down

      It's never been listed when selecting

    Create a new port and add a new printer:

    Alan Morris formerly with Windows Printing Team

    Thursday, January 8, 2015 3:16 AM
  • This is what I get and yes it was listed from the initial build but I think some HP software somehow removed it and added itself.

    Friday, January 9, 2015 2:04 PM