none
Lync Server Deployment Error - Activation failed RRS feed

  • Question

  • Hi,

    I try to setup Lync Server the first time as STD server on a Virt machine.

    The setup shall contain DC, Exch2010UM, Lync-STD,Lync-Monitoring, Sharepoint2010,2x Client on Win7

    all server run on W2008R2 (german)

    the first steps went fine, but finally at the end of Step 2 Ssetup Lync Server Components I got an error that the activation of the server was not successful.

    output windows is:

    Disabling unused roles...Executing PowerShell command: Disable-CSComputer -Confirm:$false -Verbose -Report "C:\Users\ocs\AppData\Local\Temp\Disable-CSComputer-[2010_10_03][10_08_25].html"Checking prerequisites for roles...Checking prerequisite SupportedOS...prerequisite satisfied.Checking prerequisite SupportedOSNoDC...prerequisite satisfied.Checking prerequisite NoUnsupportedSqlRtcLocal...prerequisite satisfied.Checking prerequisite NoUnsupportedSqlRtc...prerequisite satisfied.Checking prerequisite WMIEnabled...prerequisite satisfied.Checking prerequisite NoOtherVersionInstalled...prerequisite satisfied.Checking prerequisite PowerShell2...prerequisite satisfied.Checking prerequisite SupportedServerOS...prerequisite satisfied.Checking prerequisite IIS...prerequisite satisfied.Checking prerequisite IIS7Features...prerequisite satisfied.Checking prerequisite SqlExpressRtcLocal...prerequisite satisfied.Checking prerequisite VCredist...prerequisite satisfied.Checking prerequisite SqlNativeClient...prerequisite satisfied.Checking prerequisite SqlBackcompat...prerequisite satisfied.Checking prerequisite UcmaRedist...prerequisite satisfied.Checking prerequisite SqlExpressRtc...prerequisite satisfied.Checking prerequisite RewriteModule...prerequisite satisfied.Checking prerequisite JSharp...prerequisite satisfied.Checking prerequisite Wmf2008...prerequisite satisfied.Checking prerequisite Wmf2008R2...prerequisite satisfied.Checking prerequisite SpeechPlatformRuntime...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_ca-ES_Herena...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_da-DK_Helle...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_de-DE_Hedda...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_en-AU_Hayley...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_en-CA_Heather...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_en-GB_Hazel...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_en-IN_Heera...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_en-US_Helen...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_es-ES_Helena...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_es-MX_Hilda...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_fi-FI_Heidi...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_fr-CA_Harmonie...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_fr-FR_Hortense...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_it-IT_Lucia...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_ja-JP_Haruka...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_ko-KR_Heami...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_nb-NO_Hulda...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_nl-NL_Hanna...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_pl-PL_Paulina...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_pt-BR_Heloisa...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_pt-PT_Helia...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_ru-RU_Elena...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_sv-SE_Hedvig...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_zh-CN_HuiHui...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_zh-HK_HunYee...prerequisite satisfied.Checking prerequisite MSSpeech_TTS_zh-TW_HanHan...prerequisite satisfied.Checking prerequisite MSSpeech_SR_ca-ES_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_da-DK_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_de-DE_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_en-AU_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_en-CA_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_en-GB_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_en-IN_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_en-US_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_es-ES_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_es-MX_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_fi-FI_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_fr-CA_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_fr-FR_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_it-IT_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_ja-JP_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_ko-KR_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_nb-NO_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_nl-NL_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_pl-PL_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_pt-BR_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_pt-PT_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_ru-RU_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_sv-SE_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_zh-CN_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_zh-HK_TELE...prerequisite satisfied.Checking prerequisite MSSpeech_SR_zh-TW_TELE...prerequisite satisfied.Checking prerequisite UcmaWorkflowRuntime...prerequisite satisfied.Installing any collocated databases...Executing PowerShell command: Install-CSDatabase -Confirm:$false -Verbose -LocalDatabases -Report "C:\Users\ocs\AppData\Local\Temp\Install-CSDatabase-[2010_10_03][10_08_27].html"Enabling new roles...Executing PowerShell command: Enable-CSComputer -Confirm:$false -Verbose -Report "C:\Users\ocs\AppData\Local\Temp\Enable-CSComputer-[2010_10_03][10_09_46].html"Activation failed.,Microsoft.Rtc.Management.Deployment.ActivateMachineCmdlet

    In the log file I got follwing information

     

    I also tried to reboot the machine, without change. As I think to have all settings as required I have no real idea left.

    Hopefully someone of you can help.

    Thanks for your help

    Regards,
    Jan

     

     GOT IT!!! The bloody Firewall was turned off :-(

    â–º Install databases

         

    03.10.2010 10:08:26

     

    Success

    â”” â–¼ Enable new roles

         

    03.10.2010 10:09:46

     

    Failed

    â””

     

    Error: Activation failed.,Microsoft.Rtc.Management.Deployment.ActivateMachineCmdlet

    â–¼ Details

    â”” Type: PowerShellException

    â”” â–¼ Stack Trace

    â””

    bei Microsoft.Rtc.Internal.Tools.Bootstrapper.BootstrapperTask.HandlePowerShellErrors(Collection`1 errors)
    bei Microsoft.Rtc.Internal.Tools.Bootstrapper.BootstrapperTask.ActivateNewRoles()
    bei Microsoft.Rtc.Management.Internal.Utilities.LogWriter.InvokeAndLog(Action action)

    Sunday, October 3, 2010 8:54 AM

All replies

  • So are you all set? 
    Mark King | MCTS:UC Voice | MCSE: Messaging | MCITP:Enterprise Messaging | CCNA | www.unplugthepbx.com
    Sunday, October 3, 2010 3:09 PM
  • I have the same problem, how do you solve it??

     

    Thursday, October 28, 2010 5:48 PM
  • My Lync 2010 contains corrupted file MSSpeech_TTS_zh-TW_HanHan.msi I resolved the problem: 1. Extracted Lync 2010 RC install files on HDD 2. Donwloaded file MSSpeech_TTS_zh-TW_HanHan.msi from Microsoft Speech Platform - Server Runtime Languages http://www.microsoft.com/downloads/en/details.aspx?FamilyID=e16641db-b20c-4bb5-ab22-f382eb4f22f3 3. Replaced MSSpeech_TTS_zh-TW_HanHan.msi
    Wednesday, November 3, 2010 10:35 PM

  • I encountered the same issue previously with Lync 2010 RC. A complete re-download of the ISO did the trick although it certainly took longer than the approach you took. More here.

    Thanks for sharing.

     


    TechNet Forum Moderator (Unified Communications) - http://www.leedesmond.com
    Thursday, November 4, 2010 12:41 AM
    Moderator
  •  

    I dug further into the Microsoft Lync Server 2010 Deployment Log and found:

    Error: The service name "RTCATS" is already in use.

    I used the 'sc delete RTCATS' command to delete it and then reran setup successfully.

    -----

    http://blog.danovich.com.au

    • Proposed as answer by Jeffrey74 Wednesday, September 14, 2011 1:30 PM
    Friday, November 26, 2010 2:50 AM
  • I had this problem with MSSpeech_SR_en-US_TELE and what I did to fix it was just uninstall that particular language pack from programs and features (they are all listed in there) then re-run setup. It installed it successfully after that so something must have happened when it originally installed it (windows installer has always been dodgy). I would guess this would work with other packs as well, can anyone confirm this?
    • Proposed as answer by Matt S Jones Thursday, April 7, 2011 5:36 PM
    Tuesday, December 7, 2010 11:07 PM
  • Hello,

    I had the same problem of activation with the final version and solved removing the 3 following services (that were not started).

    D:\Setup\amd64>sc delete rtccaa
    [SC] DeleteService SUCCESS

    D:\Setup\amd64>sc delete rtcccs
    [SC] DeleteService SUCCESS

    D:\Setup\amd64>sc delete rtcacd
    [SC] DeleteService SUCCESS

    All the remaining of installation was fine after these deletions.

    Bye.


    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (68 MCPs) http://base.faqexchange.info
    Monday, January 10, 2011 9:42 PM
  • I had the MSSpeech_SR_en-US_TELE...installing...failure code 1638 and used this solution.  It worked perfectly, thanks!

    Sunday, March 6, 2011 1:18 PM
  • Had the same problem. Replacing the executables' that were failing with the ones downloaded from the Microsoft download site -

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=47ffd4e5-e682-4228-8058-dd895252a3c3

    Solved the problem for me.

    Thanks

     


    Akash Bambal Senior Software Engineer
    Friday, March 25, 2011 4:29 AM
  • Same issue.... same result, thanks all for the posts
    Friday, August 19, 2011 10:41 PM
  • I tried uninstalling this then downloading manually via a search, but it didnt like it your solution was the fix, uninstall the language pack then click back on the Lync Installer then next and it installed ok.

    Thanks.

    Tuesday, December 20, 2011 3:59 PM
  • Worked like a charm for my 2015 setup...
    Thursday, October 11, 2018 6:54 AM