none
Display online status option grayed out

    Question

  • I apologize if this is the wrong forum for this question but...

    We're using Windows 7, the Office 2007 Suite and Communicator 2007 R2, and the following options are grayed out under Tools > Options > Other in Outlook

    1. Display online status next to a person name
    2. Display online status in the To and CC fields only when mouse pointer restats on a person name

    (http://office.microsoft.com/en-gb/outlook-help/use-instant-messaging-services-with-outlook-HP001233551.aspx#BM3)

    I have a feeling this might be controlled by a GPO, but then thought it might be something on the server or perhaps the communicator client itself.

    Any ideas on the best method of approach for figuring this one out?

    Wednesday, June 30, 2010 7:50 PM

All replies

  • This is normally something that would be controlled by a GPO. I suggest using the RSoP tool to see if you can identify the policy first. if it is not in there then let us know.

    Matt.


    Matt Nixon | http://unifiedmatt.blogspot.com
    Wednesday, June 30, 2010 11:53 PM
  • Thanks for the response Matt!
    In re-reading my post I realized I wasn't clear in what we were trying to achieve
    1. Check 'Display online status next to a person name' by default and allow users to toggle this option.
    2. Uncheck 'Display online status in the To and Cc fields only when mouse pointer rests on a person name' by default and allow users to toggle this option.
    3. At no time should any or both features be disabled/grayed out.
    I remember running into a similar, if not the same, problem within the last year.
    • When a machine (laptop/desktop) is in cached mode, both options are available so that a person can check or uncheck either box.
    • When a machine (laptop/desktop) is not in cached mode, the options are linked and its either on or off.
    My workstation (desktop) is not in cached mode and the 'Display online status next to a person name' option is not grayed out so I can toggle it if need be.  However, when that option is checked, the sub option 'Display online status in the To and Cc fields only when mouse pointer rests on a person name' option is force checked and grayed out so I can't control that feature.
    • If I set HKCU\Software\Microsoft\Office\12.0\common\PersonaMenu\EnablePresence=0 it unchecks 'Display online status next to a person name' but when rechecked, the sub option is force checked and cannot be toggled.  Likewise, if I set EnablePresence=1, it checks 'Display online status next to a person name' and the sub option, which cannot be toggled.
    • If I set HKCU\Software\Microsoft\Office\12.0\Outlook\IM\PersonaMenu\Enabled=0, it turns off/disables both options under 'Person Names'; both are grayed out and cannot be managed.
    I've not found anything in any of our GPO's that would suggest we've enabled/disabled something to cause this 'anomaly' but I'm still looking.
    This happens to both Windows XP (running Office 2007 SP2 and Communicator 2007) and Windows 7 (running Office 2007 SP2 and Communicator 2007 R2).
    Thursday, July 01, 2010 1:29 PM
  • Update: I edited the MSP we used to deploy our customized installation of Outlook and went to
    • Features > Modify user settings > MSO Outlook 2007 > Tools | Options... > Other > Person Names
    I changed  'Display online status on a person name' from Not Configured to Enabled and left 'Turn off Enable the Person Names Smart Tag' option alone (meaning set to Not Configured) but that didn't help.

    Under the following location, there are multiple Instant Messaging Integration options, but nothing that seems to specifically address this issue
    • Features > Modify user settings > MSO 2007 system > Instant Messaging Integration
    I don't see any other options in the OCT to configure or otherwise adjust that setting in such a way to make it work.
    Thursday, July 01, 2010 4:20 PM
  • So when you modified your package did you test it on a fresh machine? Just wondering if there are any residual settings that impacted your test.


    Matt Nixon | http://unifiedmatt.blogspot.com
    Thursday, July 01, 2010 11:44 PM
  • Fresh as in new Windows 7 installation, no.

    I removed the existing installation, rebooted, removed the user profiles (file system and registry), and reinstalled.  I am seeing the updates I've made to the MSP.

    This issue exists outside of Windows 7 our XP machines also exhibit this behavior with a different .MSP created years ago when we migrated to Office 2007 from 2003.

    Friday, July 02, 2010 2:51 PM
  • Can I suggest one more test. What happens if you use a vanilla install of Office?
    Matt Nixon | http://unifiedmatt.blogspot.com
    Tuesday, July 06, 2010 12:08 AM
  • Hi JuliusPIV

    Do you use outlook as cach mode or online mode?
    Please use cach mode and make a test.

    Regards!
    Gavin
    Tuesday, July 06, 2010 8:23 AM
    Moderator
  • Hi again all and Happy Fourth of July to those that celebrate it.

    Gavin-Zhang: We don't enable cached mode on Deskstops; only the laptops.  Which means only our laptop users will be able to toggle the settings.  If I enable cached mode on my test machine, the options are available. If I disable cached mode, the options are no longer available.  Why is that?

    Matt: I'll try with a vanilla installation of 7 and Office 2007 and join it to the domain to see what happens.  I've got a few other deliverables I need to focus on so I won't be able to do that in the immediate future.

    Thanks again all.

    Tuesday, July 06, 2010 7:41 PM
  • i applied this patch

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;969694

    and it worked like a charm.. :-)

     

    Thursday, January 27, 2011 2:15 PM
  • that didnt help me

    any other idea please

    Thank you

    • Proposed as answer by Viti80Y Wednesday, March 30, 2011 4:44 AM
    • Unproposed as answer by Viti80Y Wednesday, March 30, 2011 4:50 AM
    Wednesday, March 09, 2011 5:01 PM
  • For MS Outlook 2007 create the following registry entry:

    in HKCU\Software\Microsoft\Office\12.0\Outlook\IM

    (Reg_DWORD): SetOnlineStatusLevel = 3

    The above entry can have a value of 0-3

    This allows for Outlook to show Email Recipients Office Communicator Presence and its status. By default, presence information is displayed everywhere except in the To and CC fields. With this setting, configured to level of 3, you do not need to enable any other setting in order to have presence information displayed.

    If you are aware of MS Group Policy Preferences (GPP) - use this to deploy the above registry entry, as that works perfectly, assuming GPP functions in your environment.

    Hope it helps.

     

    • Proposed as answer by Viti80Y Wednesday, March 30, 2011 4:51 AM
    • Unproposed as answer by JuliusPIV Wednesday, April 04, 2012 7:10 PM
    Wednesday, March 30, 2011 4:50 AM
  • The above entry can have a value of 0-3, what is values mean? I meet the same problem, rebuild outlook profile, now I can check Display online status option.

    Monday, March 26, 2012 8:22 AM
  • This solved me the problem:

    http://www.sebastian-grewing.de/

    To enable “Display online status next to a person name” :
    HKCU\Software\Microsoft\Office\12.0\common\PersonaMenu\Enabled=1

    To enable display online status in the To and CC fields:
    HKCU\Software\Microsoft\Office\12.0\Outlook\IM\EnablePresence=1

    Tuesday, March 27, 2012 8:44 AM
  • For MS Outlook 2007 create the following registry entry:

    in HKCU\Software\Microsoft\Office\12.0\Outlook\IM

    (Reg_DWORD): SetOnlineStatusLevel = 3

    The above entry can have a value of 0-3

    This allows for Outlook to show Email Recipients Office Communicator Presence and its status. By default, presence information is displayed everywhere except in the To and CC fields. With this setting, configured to level of 3, you do not need to enable any other setting in order to have presence information displayed.

    If you are aware of MS Group Policy Preferences (GPP) - use this to deploy the above registry entry, as that works perfectly, assuming GPP functions in your environment.

    Hope it helps.

    This solved me the problem:
    http://www.sebastian-grewing.de/
    To enable “Display online status next to a person name” :
    HKCU\Software\Microsoft\Office\12.0\common\PersonaMenu\Enabled=1
    To enable display online status in the To and CC fields:
    HKCU\Software\Microsoft\Office\12.0\Outlook\IM\EnablePresence=1

    Hi all - thanks for the responses on this!

    Our SetOnlineStatusLevel is already set to 3 and EnablePresence is set to 2, versus 1.  (Having trouble at the moment locating documentation that covers the difference between 1 & 2.)

    I created the PersonaMenu\Enabled dword value, set it to 1, and restarted Outlook - no change.  I then set EnablePresence to 1, restarted Outlook - no change. 

    Friday, March 30, 2012 7:33 PM
  • This solved me the problem:

    http://www.sebastian-grewing.de/

    To enable “Display online status next to a person name” :
    HKCU\Software\Microsoft\Office\12.0\common\PersonaMenu\Enabled=1

    To enable display online status in the To and CC fields:
    HKCU\Software\Microsoft\Office\12.0\Outlook\IM\EnablePresence=1

    Are you in cached mode?
    Friday, March 30, 2012 7:33 PM
  • I found changing the account to cached Exchange mode did the trick.

    Steve.

    • Proposed as answer by Steve Ricks Thursday, June 27, 2013 3:05 PM
    Thursday, June 27, 2013 3:04 PM