Error Code 1231 Unconnective Network Problem RRS feed

All replies

  • It's probably also worth mentioning that Vista does connect to the network, calling it the 'Network #', and during that second or two, I can get all the numbers in ipconfig, but very soon after, Vista changes the 'Network #' to 'Unidentified Network', and all the numbers in ipconfig are lost.
    Monday, July 2, 2007 2:09 AM
  • Have you tried de-selecting TCP IP V6 from TCP/IP setting under the lan adapter as I've seen it cause probs before.  It seems to favour V6 over V4 for some reason which I believe is causing the problem so if you only have V4 protocol available it will most likely fix your troubles.


    P.S. I'm not sure if it is just my own router but I also find that I sometimes need to perform 'ipconfig /renew' in prompt window to discover the correct DNS.


    I fix many computers each day, it's my job...  so If this doesn't fix your prob then I'd really like to know cos it hasn't failed me yet Smile

    Thursday, July 12, 2007 11:25 AM
  • Thanks for the help, but it's a little late lol.

    Just to help you, and anyone else having this problem:

    Yes, I have tried doing that, as well as a whole bunch of other stuff.

    I have fixed the problem.

    At first, the problem was originally solved by upgrading the router firmware of the Xincom Twin Wan XC-DPG502 to Ver 2.2, released February 2007 (I believe), updated from V. 2.1O released back in May 2005.

    However, that only solved the problem until next restart, at which point I went back into the router settings, and for Vista, you need to make sure the "LAN Any IP" is disabled (not checked). That should solve the router problem with Vista.

    Thursday, July 12, 2007 8:23 PM

    >and for Vista, you need to make sure the "LAN Any IP" is disabled (not checked).


    Mhmmm, would you be so kind and say where can I find it? TIA!



    Sunday, August 3, 2008 12:01 PM

    Lol wow you're SO lucky I was subscribed to this thread still Stick out tongue

    Uhm, I have a Xincom XC-DPG502 router, and for me, it was in your local gateway (for me it's, could be, and then it was in  "Basic Configuration" and in "LAN & DHCP", and then in "Optional Settings" in there, and it's right beside "DHCP Server" which was enabled, and still is. (I'm still on my Vista Ultimate)

    I'm going away for the next week incase you reply, but good luck!


    Sunday, August 3, 2008 3:55 PM
  • Hello,

    I had the same issue on a Vista Business 64 machine. Turns out in my case the problem was with Comodo Firewall. Once I uninstalled it, everything worked fine again. Best of luck.
    Friday, May 1, 2009 1:40 AM
  • I am having the same problem. Internet was working a few days ago. No new softwares installed. Defender and other antivirus turned off.
    1) I am able to connect to the internet in Safe mode
    2) While issuing ipconfig /all, I see the "media disconnected message" and the ipaddress is the default ""
    3) If I issue ipconfig /release, i get an error saying "No operation can be performed on Local Area Connection while it has its media disconnected".
    4) Tried reinstalling the drivers but it doesnt help. And I dont think its a problem with the drivers as there are no issues in Safe Mode.
    5) I also tried resetting using netsh.

    I have seen the same issue in many forums still being open. Any advice would really help. I dont want to restore my machine to factory settings.
    • Proposed as answer by scjwomg Monday, June 15, 2009 2:29 PM
    Friday, May 8, 2009 6:14 AM
  • This has already been mentioned, but it did work for me.  First, I disabled ipv6.  I then ran the netsh command to reset my IP stuff.  Just a warning though, I think this will only apply to this problem if you are using static IPs.

    Here is the netsh comman:

    netsh interface ip set address name="Local Area Connection" static
                                                                                                       ip address  subnet mask  gateway
    • Proposed as answer by Prashan1993 Monday, October 14, 2019 12:26 PM
    Monday, June 15, 2009 2:32 PM
  • Hi

    I had the same problem that you have mentioned. It occured to me, when i was trying to connect to an Unsecured WLAN. I was connected and was getting an Auto Config IP address. All I did was, tried renewing the ip with "ipconfig /renew". And that worked out for me. I hope you should have tried this. If not, Please try it.
    Sunday, September 20, 2009 7:16 PM
  • About 6 weeks ago, I started to get intermittent failure of my ethernet on my Vista (Business, running for about 1yr) PC.  The other desktop and laptop, both running XP didn't seem to have any problems.  At first a restart seemed to cure the problem and it was only once every three days or so, annoying but not disastorous.  It gradually got more frequent until the Vista PC would not connect at all and would not even ping the router.  I trawled the forums, did resets on the comms, reloaded drivers, installed a new NIC (wired)   All to no avail.  I did a restore to a couple of weeks back with no difference, then in desparation ran full diagnostics - those failed with a disc access error about half way through, but on a reboot suddenly it worked again; the other XP PCs had been working quite happily all this time.  This lasted for a week and then the system went completly dead and none of the other PCs had a connection.  I ended up with a 1231 error and then this thread.  Having tried all the suggestions with no effect, I eventually a bought a new router.  This last weekend  I ditched eveything and reloaded Vista from scratch.  Having mostly got back to where I was with updates etc. the system is still functional with the original integrated NIC.  I do now however have IP6 turned off.  I haven't been back to try the old router yet - too much catching up to do - but I have this feeling that there is something in Vista which went astray.  No way to prove it, but my own experience and the comments on the forums suggest to me a strong bias to that conculsion. 

    I would be interested to know if anyone else has taken the drastic step of a reinstallation and found the problem fixed.

    One definite problem these days is that if you don't have an internet connection it is very difficult to implement a solution.  If I'd have had only had one computer, I would definitely be up the proverbial creek.  It would also suggest that it is not sensible to have all one OS.  In addition if the basic operating system does not even have a pdf reader on board, it can also be difficult to look at installation instructions!
    Tuesday, November 17, 2009 5:55 PM
  • I’m beginning to despise computers more and more, especially when people think (and maybe do understand it) that they can help discover a solution, but they confuse their explanations which are so arcane that they’re very difficult to understand. Sometimes, then they also use abbreviations as if they’re text-messaging and trying to save space. Maybe they’re trying to impress somebody or themselves. Anyway, your explanation was well written and closely describes my recent experiences and, frankly, I’m bewildered at how I found it at all. I’ve googled everywhere over the past two weeks and have been unsuccessful. I "upgraded" a pair of P3s with an aim at connecting faster with the Internet and my home network. Everything worked great for a few months when connections gradually began to deteriorate until there was nothing. I tried all the things you mention, also unsuccessfully, and have resorted to returning one of my new PCs for repair. Its integrated NIC worked erratically until it finally didn’t work at all. I tried pinging it and received an error code, 1231, which led me to your discussion. (By the way, my other PC which is nearly identical to the malfunctioning one works just fine, but I’m waiting for that to change!) I set up an old P3 (with XP) as a replacement so that I could print stuff on my network, and noticed that it works fine, albeit slow, using all the same cables, connections, routers, and so forth. I’m not a techy and have very limited knowledge, but I wanted to thank you for your effort you made to try and help others who might have experienced the same problem. Eventually, I hope to figure out what happened and my next target for scrutiny is IP6 and the stability/continuity of Vista in general. But I feel that I’m looking for a needle in the proverbial haystack. Thanks again.

    Sunday, January 10, 2010 10:17 PM
  • I thought I would share the result of my experience with this same issue.

    Nothing posted in this forum was anywhere close to how I fixed my issue. Our problem was actually hardware. A while back, we had a lightning storm. Since then (as I never thought that would be the issue) this computer has failed to connect. All other 30+ computers on our domain had no problem at all.

    Eventually, I went to the utility closet and switched this computer's Cat5 line to another port on the 24 port switch, and Bam, it worked.

    This is after having the exact same issue with the error code 1231 and 1232 when trying to ping the firewall router. The computer was acting like it was connecting just fine, but in the end, failed to communicate with the firewall and server, otherwise any and every network resource.

    Hope this helps someone else figure out that it's a hardware issue.



    Wednesday, September 15, 2010 1:50 PM
  • I'd suggest just double checking your IP settings. When I ran into this error, I had a machine that had the correct IP and Subnet Mask, and DNS settings, but no default gateway configured. Correcting the default gateway resolved it.
    Tuesday, January 4, 2011 11:13 PM
  • Error code 1231: Solving the problem with network settings: Try to remove the "unnecessary protocols" in the network settings and remove the tick from those "unnecessary protocols", that are not removed, such as: IP 6.
    Tuesday, February 1, 2011 10:49 AM
  • This happened to our Vista PC yesterday when I added a blackberry to our Wireless Network.

    Because we have a Linux box that needs a static IP address (I need to ssh from a windows box using putty etc) I decided to bind all the other devices to keep things tidy.  It seems that the Blackberry trashed the configuration somewhere and the PC that got pushed off the network was our (only) Vista machine.  No idea why but there you go.

    Anyway, I reset everything on the router and rebooted it and problem solved - everything is getting a dynamic IPv4 address from the DHCP server on the router and I've re-bound the Linux box to the IP address it had before.

    We've a Draytek Vigor 2820, this is a bit above most peoples spec. We got it because our ISP was fast but a bit unstable - but my wife likes her email address! - so we went for dual ISPs and this was the cheapest router that need a good job of running both in parallel + I'm a Linux novice so having a more configurable router meant I didn't have to figure out how to do it in Linux which would have caused too many grey hairs.

    Anyway, if you don't have this router don't worry, just reset everything and reboot (and assign the passwords etc - a bit of work but it should clear everything up).  For those SMEs with 'big' routers, check your IP routing tables and see if you CAN'T see the Vista box.

    Hope this helps, I'm sure this isn't the only reason for that kind of failure.

    Thursday, June 16, 2011 7:57 PM
  • Thank you for the thought. Had been working fine all morning but had a storm come through last night. Must of damaged something that decided to quit all of a sudden. Switched it to a different port and away it went. Top-down, bottom-up, seems I always start at the wrong end ... lol.
    Thursday, July 28, 2011 9:04 PM
  • I ran into this problem while working on a MOAC lab for my server 2008 class. We had two servers each with two NICs. Server1 had static IP’s of and Server2 had static IP’s of and When I would ping from Server1 or from Server2 I would get the error code. To solve the problem I enabled the Routing and Remote Access role on the servers and configured them for the LAN. Problem solved for me.

    Friday, February 17, 2012 3:31 PM
  • In my case, the error message was caused by a blank Default Gateway in a server's network settings.
    Wednesday, April 3, 2013 6:07 PM