Error '0x80073701' while trying to install Containers Windows feature RRS feed

  • Question

  • Dear Community,

    I'm facing an issue trying to install Windows Docker, more specifically its containers feature, to a Windows 2016 server.

    I tried installing Docker using the following set of commands on Powershell ran as Admin:

    Install-Module DockerMsftProvider -Force

    cd C:\Users\s7qzqx\AppData\Local\Temp\DockerMsftProvider
    Start-BitsTransfer -Source https://dockermsft.blob.core.windows.net/dockercontainer/docker-19-03-5.zip -Destination docker-19-03-5.zip
    Get-FileHash -Path docker-19-03-5.zip -Algorithm SHA256
    Install-Package -Name docker -ProviderName DockerMsftProvider -Verbose

    And then restarting the server. The reason why I used the 3 commands in the middle is because the package couldn't be found and therefore installed.

    Anyway, that seemed to work and I'm now able to check Docker version using 'docker --version' command.

    The only thing that failed is adding the containers feature, which gives the following error:

    WARNING: A restart is required to enable the containers feature. Please restart your machine.

    Install-package : The request do add or remove features on the specified server failed.

    Installation of one or more roles, role services, or features failed.

    The referenced assembly could not be found. Error: 0x80073701

    At line:1 char:1

    + Install-Package -Name docker -ProviderName DockerMsftProvider -Verbos ...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo            : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:String) [Install-Package], Exception

    + FullyQualifiedErrorId : DISMAPI_Error__Failed_To_Enable_Updates,Microsoft.Windows.ServerManager.Commands.AddWindowsFeatureCommand,Microsoft.Powershell.PackageManagement.Cmdlets.InstallPackage

    (I can't insert images because my account is not verified for some reason)

    The same error happens even after restarting the machine and running this command: 'Install-WindowsFeature -Name Containers'.

    I found online that it might have to do with some registry entries in "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect" that were created and orphaned and that the solution would be to delete them, but personally I'm afraid to delete Windows registry entries without fully knowing what I'm doing.

    Do you know if there's a precise way to know what to delete and what to not touch, or if there's any other solution/workaround to fix this error and complete Docker's installation?

    Thanks a lot in advance,


    Thursday, July 2, 2020 9:05 AM

All replies

  • Please post Docker questions to the Docker forum.  They will help you understand how to install and configure Docker.  Docker is not a part of Windows Server or PowerShell.


    Thursday, July 2, 2020 10:32 PM
  • Hi,
    Regarding Docker based issue, I suggest you refer to experts from the following forum to get professional support: 
    Please let us know if you would like further assistance.
    Best wishes,
    Young Yang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 3, 2020 2:52 AM
  • Hi,
    As this thread has been quiet for a while, so here is a quick question.Was your issue resolved? 
    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.
    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.
    If no, please reply and tell us the current situation in order to provide further help.
    Best Regards,
    Yang Yang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 14, 2020 1:56 AM
  • Hi,

    I ended up fixing the problem by following this solution:

    https://social.technet.microsoft.com/Forums/lync/en-US/753ce3c1-577f-4f45-9a38-23c4fade5c2d/installing-roles-and-features-error-0x80073701?forum=ws2016 (answer by Venom83)

    The topic can be closed.



    Tuesday, August 4, 2020 10:54 AM
  • The solution for most is to reinstall the operating system.  You can perform an ‘in-place upgrade’ which means putting in a DVD or USB stick that contains Windows installation and running the setup again.  You will have to reinstall your programs but you will not loose your data files.

    According to several posts/blogs/articles like THIS one, the alternate solution is to set all of the language settings in CONTROL PANEL > REGION to be the same or to edit the registry to remove languages that do not match yours.  Take note that these have not worked for me and I end up performing an inplace upgrade.

    If you still want to play to avoid reinstalling the OS, the registry key that others point to is:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect
    Tuesday, August 4, 2020 1:36 PM