locked
FSW failed to arbitrate for the file share... RRS feed

  • Question

  • Hi,

    Two node DAG, Exchange 2010.

    Everyday at the same time, this event is logged:

    File share witness resource 'File Share Witness (\\witness.domain.tld\DAG1.domain.tld)' failed to arbitrate for the file share '\\witness.domain.tld\DAG1.domain.tld'. Please ensure that file share '\\witness.domain.tld\DAG1.domain.tld' exists and is accessible by the cluster.

    Then

    Cluster resource 'File Share Witness (\\witness.domain.tld\DAG1.domain.tld)' in clustered service or application 'Cluster Group' failed.

    and then:

    The Cluster service is shutting down because quorum was lost. This could be due to the loss of network connectivity between some or all nodes in the cluster, or a failover of the witness disk.
    Run the Validate a Configuration wizard to check your network configuration. If the condition persists, check for hardware or software errors related to the network adapter. Also check for failures in any other network components to which the node is connected such as hubs, switches, or bridges.

    Both nodes doesn't lose connectivity with FSW. Being that this happens at the same hour and minute everyday I am thinking some scheduled task that is loading the server maybe and slowing the network so heartbeat is compromised?

    this is all assumptions. What do you think? Many thanks.

    Thursday, November 10, 2016 2:07 PM

All replies

  • It could be a scheduled task or something like some process that causes a network disturbance that causes Windows Clustering to be unable to contact the witness server for a brief period of time.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Friday, November 11, 2016 12:48 AM
  • Hi,

    As above mentioned, it might be caused by schedule task interfere, thus try to run below command in PowerShell to list schedule task, then match the time for this issue:
    Get-ScheduledTask | Get-ScheduledTaskInfo | FT TaskName,NextRunTime 

    Also, check the cluster schedule: Get-ClusteredScheduledTask


    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Saturday, November 12, 2016 2:45 AM
    Moderator
  • Hi,

    Well, It happened at another time of the day, and I checked scheduled tasks, so what was my first suspicion it seems is not.

    How can I tweak the cluster to be more adaptable to network conditions?

    CrossSubnetDelay property of cluster has something to do with this? right?

    Thanks

    Sunday, November 13, 2016 9:33 PM
  • Hi,

    Thank you for your update.

    Do you run a multi-site DAG over subnets?

    Try to adjust the default heartbeat settings by the following commands:
    1. If cluster nodes are in same subnet:
    cluster /prop SameSubnetDelay=2000 (The default value is 1000 milliseconds, we could set it to 2000 milliseconds.)
    cluster /prop SameSubnetThreshold=10 (The default value is 5, we could set it to 10.)

    2. If your cluster nodes are on separate subnets:
    cluster /prop CrossSubnetDelay=2000
    cluster /prop CrossSubnetThreshold=10

    More details it, please refer to Tuning Failover Cluster Network Thresholds.

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 14, 2016 12:30 PM
    Moderator