locked
Lync Server 2010 - Transfer call from Lync Response Group to Exchange Auto Attendant RRS feed

  • Question

  • Hi All,

    I've installed Lync server 2010 and have enterprise voice work fine. I've setup an interactive response group to handle incoming calls and direct them to different groups of users. I've also setup exchange UM and configured Lync and Exchange to work together and have enabled some users for UM.

    What I'm struggling to do is configure the interactive response group with an option so that it will transfer incoming calls to the exchange subscriber access number so that users can call it from their mobiles when on the road.

    Details: Lync server 2010, exchange 2007 sp3, internal numbers are 7***, we have one site with one domain.

    Can anyone help with this please?

     

    Thursday, March 31, 2011 9:17 AM

Answers

  • I do this extensively in my environment, did you make sure to grant the RGS access to the Dial Plan (it needs to have access to dial out to the Exchange AA)

    Get-CsApplicationEndpoint sip:<RGS_SIP_Address>| Grant-CsVoicePolicy -PolicyName <VOICE_POLICY_NAME>

     

    Eddie

    • Proposed as answer by pcmmitham Wednesday, December 21, 2011 9:41 PM
    • Marked as answer by JRWhitehead Tuesday, January 3, 2012 9:43 AM
    Wednesday, December 21, 2011 9:08 PM

All replies

  • Bump
    Friday, April 1, 2011 2:09 PM
  • What number you assigned to SA?

     

    Drago


    http://ocsdude.blogspot.com
    Friday, April 1, 2011 2:56 PM
  • The SA number is 7188.

    The SA has been created as a contact in AD by the OcsUmUtil.exe tool and I'm able to call the SA from a lync client.

    Sunday, April 3, 2011 9:57 PM
  • Using non E.164 format is bad, bad idea. Do not mix UM extension with Pilot number. Try changing the SA number to full E.164 i.e. +1425555xxxx and then set the RGS option to forward to THIS number…

    At least, make it +7188 and have a rule in the dial plan to normalize 7188 to +7188

     

    Drago


    http://ocsdude.blogspot.com
    Sunday, April 3, 2011 10:06 PM
  • Hi Drago,

    Apologies for not being clear, the nuber is +7188 and I've created a dial plan normalization rule to add the + to any 7*** numbers.

    We currently have one external number on our test SIP line which goes to our IP PBX then to our Lync SE server. (sorry if my terminology is incorrect as voice routing is not my speciality)

    So with the above in mind we don't have full E.164 number for the SA.

    Monday, April 4, 2011 2:09 PM
  • Tricky, indeed. J

    SA is an application contact. While it has sip-uri and tel:xxxx, it cannot participate in a RGS group.

    I am curious how others here handle this situation. If transfer to +7188 fails (it is interesting why), have you tried to forward to “SIP address” instead and use the sip-uri of the SA?

    This is – when a queue expires…

     

    Drago


    http://ocsdude.blogspot.com
    Monday, April 4, 2011 3:25 PM
  • Yes I've tried to forward to SIP address in the queue timeout setting and amusingly that times out too!

    Also I've tried to add the SA application contact to a distribution group then add this distribution group to a response group and configure a queue to use this response group. Then in the IRG set an option to call this queue. This times out,

    Like you I'm interested in how other people have handled this issue..

     

    Monday, April 4, 2011 4:21 PM
  • Can anyone else let me know how they've set up Lync Interactive RG with an option to call their Exchange SA?
    Wednesday, April 6, 2011 4:28 PM
  • Yes anyone have a good configuration for this? My impression so far is that the Lync Response Groups have better user-friendly interaction for the following type of workflow...

     

    1) start with a nice audio greeting, which allows user to press key mappings that point to queues.

    But what if one of those options is to forward the caller to an Exchange Auto Attendant in order to then dial the extension of a user (one of many users, can't use RG for that)?

    It's weird, the office hours/holiday fields have many options such as Forward to SIP URI / Forward to telephone number - but the actual user response actions don't have those very useful options.

    Does anyone have a good example of how to configure the overall "Auto Attendant" experience for incoming callers that would handle the following...

    1) users get initial customized greeting audio message

    2) users receive audio instruction of which buttons to press (can be part of the message in # 1)

    3) users press a number ( say 1 through 4 or greater if possible), or say a keyword for each number (such as Support, Sales, etc) to get directed to the right place

    4) that "right place" can be a Lync Hunt Group, OR an Exchange system attendant/auto attendant OR another extension such as for the conferencing service, etc

     

    Friday, April 29, 2011 8:38 PM
  • Good day ladies and gentlemen’s!

    I have working configuration where interactive response group  have   “Response 4”   to a queue with “Enable Queue Overflow”  enabled.  “Maximum number of call” set to 0 and call action is “forward to sip address”. Corresponding group is empty.   Sip address belong to Exchange SA.   Incoming call transferring to SA after choosing “Response 4”  without  any delay.

     

    • Proposed as answer by Tim_MCP Saturday, June 4, 2011 11:12 PM
    Thursday, May 12, 2011 8:30 AM
  • Are you reffering to OCS or Lync? If later, how did you bypass the 10 seconds lock?

     

    Thanks,

    Drago


    http://www.lynclog.com
    • Edited by Drago Totev Thursday, May 12, 2011 12:33 PM
    Thursday, May 12, 2011 11:37 AM
  • Lync and Exchange 2010. 10 sec lock happen when  Queue timeout is enabled. I didn’t find any possibility to set it less then 10sec and its not so comfortable to wait for timeout. So, Queue timeout just disabled. Point is that you can set maximum number of call to zero then overflow enabled. It didn’t work when group connected to Queue not empty. So, 1 incoming call > 0, its mean  overflow -> call to sip:autoattendant@somewhere.local

    • Proposed as answer by Ilich_75 Friday, May 13, 2011 8:12 AM
    Thursday, May 12, 2011 12:26 PM
  • Simple, yet enginious. Great catch!

     

    Drago


    http://www.lynclog.com
    Thursday, May 12, 2011 12:33 PM
  • Lync and Exchange 2010. 10 sec lock happen when  Queue timeout is enabled. I didn’t find any possibility to set it less then 10sec and its not so comfortable to wait for timeout. So, Queue timeout just disabled. Point is that you can set maximum number of call to zero then overflow enabled. It didn’t work when group connected to Queue not empty. So, 1 incoming call > 0, its mean  overflow -> call to sip:autoattendant@somewhere.local 


    Thank you! i was looking to do the same thing but with the Exchange AA, so a caller hits option 9 to get the company directory, but dident want to wait the 10 seconds. now when someone hits 9 goes right to the company lookup/attendant instantly!!!

     

    Thanks again!

    Saturday, June 4, 2011 11:12 PM
  • Has anyone actually got this working? such a basic feature of most PBX's but it doesnt work in Lync!!  I've tried the above. I have my RG set t osend option 3 to the "directory" queue.  that Que has no one in it, enable Queue overflow 0 max calls and forward to the SIP address of my AA,  but all it ever does is hang up on me when I try to go to "option 3" from an external connection.  my other options work,  just not this one!
    Wednesday, December 21, 2011 6:06 PM
  • The queue mist have at least one group as a member, and the group must have at least one user as member (not that this user will ever be bothered when this option is selected.

     

    Drago


    http://www.lynclog.com
    • Proposed as answer by alifambler Wednesday, February 29, 2012 4:54 PM
    Wednesday, December 21, 2011 6:41 PM
  • Drago,

     

    Thank you,  but I have tried that to no effect.  when I press 3,  I get nothing for 10 seconds or so and then it disconnects.  Would be truly nice if MS would document (fix) such a basic PBX feature so that it worked in Lync! 

     

     

    Wednesday, December 21, 2011 8:58 PM
  • I do this extensively in my environment, did you make sure to grant the RGS access to the Dial Plan (it needs to have access to dial out to the Exchange AA)

    Get-CsApplicationEndpoint sip:<RGS_SIP_Address>| Grant-CsVoicePolicy -PolicyName <VOICE_POLICY_NAME>

     

    Eddie

    • Proposed as answer by pcmmitham Wednesday, December 21, 2011 9:41 PM
    • Marked as answer by JRWhitehead Tuesday, January 3, 2012 9:43 AM
    Wednesday, December 21, 2011 9:08 PM
  • I agree - RGS is becoming more and more valuable (if not vital) part of EV and enhancing the functionality is necessary. I hope the PG is scanning the forums for feedback and ideas. The approach Eddie1 suggest is interesting. Please tell us your observations if you decide to go this route...

     

    Drago


    http://www.lynclog.com
    Wednesday, December 21, 2011 9:29 PM
  • Drago,

     

    For us,  this feature is a major road block to Lync being "Enterprise Ready"  without it,  it's not useful as a phone system.  I'm working on the approach eddie1 suggested.  I helps a bit,  now I get music for a few seconds before being disconnected!! 

     

    Wednesday, December 21, 2011 9:42 PM
  • Give me an hour to replicate in my lab.

     

    Drago

     


    http://www.lynclog.com
    Wednesday, December 21, 2011 9:44 PM
  • All right. I re-created the test case and worked as expected. Drop me an email: temp2 at lynclog.com

     

    Drago


    http://www.lynclog.com
    Thursday, December 22, 2011 12:48 AM
  • Thank you Ilich_75 and Drago!!

    The combination of a zero call overflow queue and requiring 1 group in the queue and 1 member of the group was exactly what I needed to fix the Response Group disconnecting calls instead of transferring to the Exhange UM System Attendant, providing IVR access to our directory. 

    Great tip!!!

    Wednesday, February 29, 2012 5:04 PM
  • Hi Eddie and All,

    Trying to set this up for a current deployment.

    I have created a Group (Informal, 20secs Parallel) referencing a AD distribution group, I've tried the group with 0 members and populated with members. I then have a corresponding Queue referencing the group. Enable queue overflow is enabled with 0 Max number of calls. I've tried "Call action" to forward to SIP address, Telephone Number and Voice Mail this being in the format - sip:+4412345678@domainname.co.uk.

    In the interactive response group I have a response set to forward calls to the above configured queue. Nothing happens.

    I looked at the above command and found the response group was not associated with a voice policy. Tried this to the Global policy, however received the error: Grant-CSVoicePolicy : Policy "Global" is not a user policy. You can assign only a user policy to a specific user.

    I then created a new USER voice policy and assign this to the RGS service. This was then confirmed with the command: Get-CSApplicationEndpoint | ft displayname, voicepolicy.

    The response groups wont even forward a call to a sip address.

    After all this nothing is working. Nor is anything passing to voice mail via the queues themselves so if a user does not answer a incoming call the call just times out. I suspect the two issues are related. Any pointers on what I might be doing wrong??

    Cheers,

    Matt.


    MEllis

    Wednesday, March 6, 2013 10:14 AM
  • Hi All,

    My issue was resolve by unchecking the "Enable Refer Support" option within Trunk configuration.

    http://blogs.technet.com/b/wesglock/archive/2011/01/17/default-setting-of-supporting-sip-refer-and-using-an-unsupported-gateway-with-lync-2010.aspx

    Cheers.


    MEllis

    Monday, March 25, 2013 5:22 PM