none
Microsoft Lync 2010 external redirection RRS feed

  • Question

  • Hi

    I've installed Lync 2010 and internally everything works fine. When you join a meeting the URL i correct and everything works.

    When i send an email to an external user and he or she tries to logon to the meeting they get

    "The URL is incorrect"

    I can see that external users are redirected to the local servername?

    In the email they have to logon to meet.domain.com but when they logon they are redirected to servername.domain.local?

    Any idea how to fix that??

    /Michael




    • Edited by mba28 Monday, October 10, 2011 1:32 PM
    Monday, October 10, 2011 1:31 PM

Answers

  • Hi Michael,

    That URL is pulled from your pool settings for external web services.

    Open topology builder, right click on the front end pool and choose properties, and you’ll see an internal URL and external URL.

    Make sure that external URL is set to the public address.

    In addition, please refer to this post. Hope helps.

    Thursday, October 13, 2011 7:13 AM
    Moderator

All replies

  • Open topology builder, right click on the front end pool and choose properties, and you’ll see an internal URL and external URL. Is it correct?

    no chance the internal users are doing exactly the same thing?
    all DNS records are correct?


    +Say thanks and observe basic forum courtesy:
    +If this post answered your question, Mark As Answer
    +If this post was helpful, Vote as Helpful

    http://windowspbx.blogspot.com
    Monday, October 10, 2011 1:54 PM
  • As Matt suggested, configure your External URL in LYNC "External Web Service URL". Please note that you need to publish this URL using an ISA/TMG (Reverse Proxy)

    Thamara.

    Tuesday, October 11, 2011 4:19 AM
  • Hi

    My server have an external IP where i have pointed MEET - ADMIN - DIALIN to.

    I only have 1 server and when i look at the topology it should be configured the right way.

    Clients are able to logon from home without VPN.

    When people click the link in the email the are directed to meet.domain.com and then the website redirects them to i-lync.msa.local :(

    I can see that it is both External and Internal users that are redirected to this site.

    Can't i just change the redirection from i-lync.msa.local to meet.domain.com :)

    Do i really need a TMG to get this to work? If yes where can I find a white paper to see the installation off the TMG for Lync. I don't know the TMG.

    Michael

     

     

     

    Michael

    Tuesday, October 11, 2011 7:21 AM
  • From the machine the external user is attempting to connect from, can you ping meet.domain.com etc and see what this resolves to? 

    This sounds like a DNS issue of some kind (either DNS server or local - HOSTS file?), because in all scenarios users should be joining a meeting using the meeting URL only.


    Justin Morris | Consultant | Modality Systems
    Blog - www.justin-morris.net
    Twitter: @jm_deluxe
    If this post has been useful please click the green arrow to the left or click "Propose as answer"

    Tuesday, October 11, 2011 10:58 AM
  • People can join meet.domain.com, but just after they are redirected to localservername.localdomain.local.

    When people are at home they are able to use their lync clients so i thing that the DNS is working as it should.

    Tuesday, October 11, 2011 11:09 AM
  • If possible, can you try this using a different browser (other than IE?). Just trying to rule out/isolate applications here.

    Justin Morris | Consultant | Modality Systems
    Blog - www.justin-morris.net
    Twitter: @jm_deluxe
    If this post has been useful please click the green arrow to the left or click "Propose as answer"

    Wednesday, October 12, 2011 5:04 AM
  • Hi Michael,

    That URL is pulled from your pool settings for external web services.

    Open topology builder, right click on the front end pool and choose properties, and you’ll see an internal URL and external URL.

    Make sure that external URL is set to the public address.

    In addition, please refer to this post. Hope helps.

    Thursday, October 13, 2011 7:13 AM
    Moderator
    • Edited by rt3465345 Friday, October 14, 2011 8:46 AM
    Friday, October 14, 2011 8:43 AM
  • Hi,

    I had the same issue as you. It turned out because I didn't have a reverse proxy in place. See my topic about this issue with a link on how to get around it.

    http://social.technet.microsoft.com/Forums/en-US/ocsclients/thread/e400d46e-4ba7-47cb-9f24-088b0ea0a62a

    Also make sure you have your certificate in place.

    Monday, October 24, 2011 9:41 PM