none
Skype for business access edge service not running RRS feed

  • Question

  • Hi All,

    I encounter issue with my Skype for Business Edge Server. I noticed the Skype for Business Server Access Edge Service could not run and showing service-specific error %%-10008124857. I already run out of ideas and have done the following;

    1. Change Certificate using Internal Certificate/Change Back to External. Issue still the same.

    2. Export/Import Topology to Skype Edge Server. Issue still the same.

    3. IP conflict checking OK. Issue still the same.

    4. Federation Service Disable/Enable. Issue still the same

    5. CS ManagementStoreReplication OK. Issue still the same.

    6. Skype Updates / Patch. Issue still the same.

    Any suggestion on how to fix this issue?

    Saturday, November 28, 2015 11:50 AM

Answers

  • Hi,

    If all the configuration and certificates correct.

    As you said It was working fine earlier and suddenly stop working no related events in event log.

    It will be difficult to troubleshoot, since service not running, why don't you uninstall the applications and bootstrap the server again. It will be faster way to fix the issue, if it application corruption.

    Another suggestion is issue two (edge internal and external certificates) new certs from internal CA which trusted by Edge server (or Add root certificate), and see is it fixing the issue. That will help to validate if there any issue with present certificates, such as CRL check failure or etc..  


    Malinda Perer | MCSM - Chatter Communication | MCM - Lync 2010 and OCS 2007 | http://malinblog.com/ | https://sg.linkedin.com/in/malindap

    Monday, November 30, 2015 9:15 AM

All replies

  • Hi,

    Did you validate the Edge External interface IP addresses against the information in the topology?


    Malinda Perer|MCSM - Chatter Communication | MCM - Lync 2010 and OCS 2007 | http://malinblog.com/ | https://sg.linkedin.com/in/malindap

    Saturday, November 28, 2015 12:57 PM

  • Hello LRMCP,

    Assuming that you added Edge server and published topology correctly and installed S4B Business server. You said that certificate checked (internal / external) but same issue. However I strongly recommend to check certificate one more time because most of time certificate causing service start issue, check root certificate as well.

    Second thing you can check event viewer and see what error event logged related to Edge access service.

    You can follow below article for details Edge server installation process.

    http://communicationsknowledge.blogspot.com/2015/09/microsoft-lync-server-2013-to-skype-for_20.html


    Regards Balu Ilag MCSA, MCITP

    Sunday, November 29, 2015 6:01 AM
  • Hi Malinda,

    It was working fine and previously running, when suddenly this issue occur. Internal IP's are NAT's by FW to External IPs, so I think there's no issue on it.

    Regards,

    LRMCP


    • Edited by LRMCP Monday, November 30, 2015 8:21 AM Name
    Monday, November 30, 2015 8:21 AM
  • Hi Balu,

    Thanks. We used the same method when doing the S4B upgrade. I thought it was certificate issue, but it's not, because the service is actually running even after the upgrade. Event IDs are all related to service-specific error %%-10008124857. Tried to search about these event id but could not get much information about it.

    Regards,

    LRMCP

    Monday, November 30, 2015 8:49 AM
  • Hi,

    If all the configuration and certificates correct.

    As you said It was working fine earlier and suddenly stop working no related events in event log.

    It will be difficult to troubleshoot, since service not running, why don't you uninstall the applications and bootstrap the server again. It will be faster way to fix the issue, if it application corruption.

    Another suggestion is issue two (edge internal and external certificates) new certs from internal CA which trusted by Edge server (or Add root certificate), and see is it fixing the issue. That will help to validate if there any issue with present certificates, such as CRL check failure or etc..  


    Malinda Perer | MCSM - Chatter Communication | MCM - Lync 2010 and OCS 2007 | http://malinblog.com/ | https://sg.linkedin.com/in/malindap

    Monday, November 30, 2015 9:15 AM