none
Exchange Connection Error in external Lync Client RRS feed

  • Question

  • getting a Exchange Connection Error in the Lync Client installed on an external PC.  Unable to access the address book to search for contacts.  Other users do not get this error and are able to search the address book.

    I found a technet article that suggested that I make sure that the sip address in my outlook profile needs to be the same as my Lync address.  I do have Outlook 2010 installed on the computer, but it is configured with my home email and not my work email.  Could this be what is causing the problem?  If so, is there a way to get the address book to work on an external Lync Client on a computer with Outlook 2010 installed with a different email?

    Monday, March 26, 2012 3:45 PM

All replies

  • Hi.

    1. Did you published the lync Server external URL via a reverse proxy?

    2. Check this for EWS configuration: http://technet.microsoft.com/en-us/library/bb201695.aspx

    3. Check this solution: http://blog.metasplo.it/2011/10/lync-2010-reports-lync-cannot-connect.html


    If answer is helpful, please mark as answer or hit the green arrow on the left.

    • Proposed as answer by Alexey Filatov Tuesday, March 27, 2012 4:24 AM
    • Unproposed as answer by cbany Wednesday, March 28, 2012 2:02 PM
    Tuesday, March 27, 2012 4:24 AM
  • Hi,cbany,

    Did this happen to only one external user or all external users?

    Did you check the following KB artcile by any chance?(Although it's for Lync online,some troubleshooting methods are also available)

    http://support.microsoft.com/kb/2436962

    Also please try to check the configuration information in external Lync client to verify EWS status.

    B/R

    Sharon


    Sharon Shen

    TechNet Community Support

    ************************************************************************************************************************

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.

    Wednesday, March 28, 2012 1:48 PM
    Moderator
  • it's not happening with everyone.  The article you mentioned is the one I referred to in my original post.  It refers to a solution of making sure that your default outlook profile matches the log in for Lync.  However that is a flawed solution as my default profile is different because my Lync uses a work email and my outlook profile uses a personal email.  The whole point of having Lync available through edge is so that you can connect from a non work computer.  What I need to know is if there is a way to get the address book to work without the default outlook profile matching Lync.

    I also checked the EWS status and it is not populating so that may be part of the problem.  I set the external URL on our exchange server and verified that autodiscover is in our exchange cert, but it still isn't populating.  I need to do some further research on that part.

    thanks

    Wednesday, March 28, 2012 2:02 PM
  • Hi,cbany,

    EWS must the cause.Would you please run Get-EWSVirtualDirectory |fl and Get-WebServicesVirtualDirectory |fl and post the results here for troubleshooting.

    Also please verify that your autodiscover record is created correctly.

    B/R

    Sharon


    Sharon Shen

    TechNet Community Support

    ************************************************************************************************************************

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.

    Monday, April 2, 2012 10:18 AM
    Moderator