DPM 2019 Agent not installing on Windows Server Core 2019 RRS feed

  • Question

  • When I attempt to install the DPM agent from the DPM 2019 console to a target machine running Windows Server 2019 Core, I get the following:

    Installing from the DPM 2019 Console:
    1) Agent Status: Installing: 98% before it disappears from the Production Servers window.
    2) Under Monitoring -> Warning, "Agent Operation Failed".  Under Details:

    Agent operation failed. (ID 370)
    The agent operation failed because an error occurred while running the installation program on [server name].  (ID 313 Details: Fatal error during installation (0x80070643)).

    Installing manually by copying the "AMD64" folder containing the DPMAgentInstaller_x64.exe file to the root of the offending core server's system drive and launching the exe itself (no switches or arguments):

    1) Extracting files, no problems here.
    2) Accept license agreement.
    3) Preparing to install: 1 seconds.  Green bar moves from left to right until it reaches about the 95% mark, then it moves from right to left (rolling back the installation). 
    4) "DPMAgentInstaller failed with errorcode =0x80070643, error says: Fatal error during installation. 

    Check log files in [WINDIR]Temp\MSDPM*.LOG
    Press Enter key to close the window. 

    This happens on EVERY Windows Server Core 2019 server we have.  If it happened only on one server, then I would chalk it up to some anomaly on the core server itself.  I combed the above referenced logs in both sets of error messages and nothing really stuck out (I'll attach the logs upon request if you really think it will help troubleshoot, but I'm really thinking it's something specific to Server Core 2019). 

    This does NOT happen on any Windows Server 2019 with Desktop Experience server or any Windows Server 2016 server (regardless of whether it's core or GUI). 

    Any ideas?

    Monday, October 21, 2019 4:12 PM

All replies

  • Hi,

    The logs would probably be helpful, could you attach it to OneDrive and post it here?

    Do you have the Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.61030 installed on your Windows Server Core servers?

    I just performed a test in my lab on a cleanly installed Windows Server Core 2019 and successfully installed the DPM 2019 agent manually.

    • The DPM 2019 server has the Windows Firewall disabled.
    • Remote Management is enabled on the Windows Server Core server.
    • No group policies applied.

    This is the command I used:

    NET USE Z: "C:\Program Files\Microsoft System Center\DPM\DPM\ProtectionAgents\RA\\amd64"

    Then I attached the agent from the DPM 2019 console.

    Best regards,

    Blog: LinkedIn:

    Monday, October 21, 2019 4:40 PM
  • Thanks for the quick reply, Leon!

    I just installed Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.61030, restarted the machine in question, and tried the install again manually--same result. 

    Logs are attached here:!ApckUSDjBWXpoxBp-WHLmQoSuaZu?e=RC9KkF

    I tried both with and without the firewall enabled as well.  Remote Management is enabled.

    Monday, October 21, 2019 5:00 PM

    I just spun up a fresh Server 2019 Core VM, joined it to our domain, and tried installing the Agent--that was successful!

    So it sounds like the issue could be one of a few things:

    a) These Core servers were upgraded from Server 2016 to 2019 (some of them may have been upgraded from as far back as 2012 R2 or even 2008 R2 to 2016 and most recently to 2019)

    b) Multiple versions of Visual C++--many of them for previous versions of System Center Agents (SCCM, SCOM, SCDPM) dating back to 2012 R2, upgraded to 2016, then to 2019 (SCCM being an exception because it's on "Current Branch" now).  However, I have uninstalled the DPM agent on these core servers before installing 2019 as a troubleshooting step as well...

    Either way, I hope the logs indicate why these installs are failing on existing core servers.
    Monday, October 21, 2019 5:41 PM
  • The upgrade from previous versions of Windows Server (especially older than 2012 R2) "could" be a reason why the DPM agent installation is failing, there might be some registry leftovers that might cause some issues.

    Multiple versions of Microsoft Visual C++ Redistributable is very likely to be the issue, especially from previous versions of DPM and other System Center products.

    I did notice in the installation log something about upgrading the DPM agent, which sounds like an older DPM agent has been installed which might cause issues.

    Property(S): Upgrade_Confirmation = A lower version of this product has been detected on your system. Would you like to upgrade your existing installation?

    Blog: LinkedIn:

    Monday, October 21, 2019 6:01 PM
  • Ok, I uninstalled all System Center products from the server in question and removed every relevant trace of "Data Protection Manager" and "DPM" from the registry (obviously had to be careful about the latter, since the "DPM" string can match a lot of things that aren't relevant).

    Also uninstalled every Visual C++ product and then rebooted.

    Anyway, after doing all that, I reran the installer.  Same error...Grrrr...
    Monday, October 21, 2019 6:58 PM
  • There might still be small leftovers lying around somewhere, difficult to say.

    Reinstalling is no option? Might save a lot of time.

    The DPMAgentInstaller_x64.exe actually contains a lot of files, it also contains the prerequisites that are needed for the DPM agent:

    You can for example open it with 7-Zip and extract the files and check that you have the prerequisites installed.

    Blog: LinkedIn:

    Monday, October 21, 2019 7:12 PM
  • Hi,

    Just checking to see if you have any update on your issue?

    If your issue was resolved, may I ask you to mark all the answers that helped you? This way it will also help others in the future who face the same challenge. Many thanks in advance!

    Best regards,

    Blog: LinkedIn:

    Wednesday, December 11, 2019 9:40 PM
  • We ended up having to reinstall the OS on the affected machines. 
    Wednesday, December 11, 2019 10:54 PM