none
Exchange Server 2016 MailTips exceptions some domain ? RRS feed

  • Question

  • Hi All,

    I have setting MailTips it work when sending to outside all external domain
    This is default message before sending "The following recipient is outside your organization:xxxx.@xxx.com"

    But I need exceptions some external domain how to setting ?

    Saiya,

    Monday, November 4, 2019 10:01 AM

All replies

  • Hi All,

    I have setting MailTips it work when sending to outside all external domain
    This is default message before sending "The following recipient is outside your organization:xxxx.@xxx.com"

    But I need exceptions some external domain how to setting ?

    Saiya,

    Only if you setup the remote domain specifically and set it to internal

    https://docs.microsoft.com/en-us/exchange/clients-and-mobile-in-exchange-online/mailtips/mailtips-over-organization-relationships

    Monday, November 4, 2019 1:07 PM
    Moderator
  • Hi ssaikaew99,

    You can exclude the domain here in this

    {($_.PrimarySMTPAddress -notlike "*@domain.com")}

    Then run this after setting domain exclude 

    $excludes=Get-Mailbox -ResultSize Unlimited | Where-Object {($_.PrimarySMTPAddress -notlike "*@domain.com")}
    Foreach($mbx in $excludes){
    Set-Mailbox $mbx.alias -MailTip "xxx"
    }

    Regards,

    Beverly Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, November 5, 2019 9:57 AM
  • Hi All,

    I have setting MailTips it work when sending to outside all external domain
    This is default message before sending "The following recipient is outside your organization:xxxx.@xxx.com"

    But I need exceptions some external domain how to setting ?

    Saiya,

    Only if you setup the remote domain specifically and set it to internal

    https://docs.microsoft.com/en-us/exchange/clients-and-mobile-in-exchange-online/mailtips/mailtips-over-organization-relationships

    Thank you
    I try & test many steps by follow docs but no work!

    Thursday, November 7, 2019 12:51 AM
  • Hi ssaikaew99,

    You can exclude the domain here in this

    {($_.PrimarySMTPAddress -notlike "*@domain.com")}

    Then run this after setting domain exclude 

    $excludes=Get-Mailbox -ResultSize Unlimited | Where-Object {($_.PrimarySMTPAddress -notlike "*@domain.com")}
    Foreach($mbx in $excludes){
    Set-Mailbox $mbx.alias -MailTip "xxx"
    }

    Regards,

    Beverly Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thanks you
    No GUI only command ?
    After follow above command how to check it work or not ?
    Thursday, November 7, 2019 12:52 AM
  • Hi ssaikaew99,

    You can send a test email to a external user in the specific domains to see if the MailTip stills shows above the recipients address. 

    If you need further help, please provide more detailed information, so that we can give more appropriate suggestions.

    Regards,

    Beverly Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, November 12, 2019 9:27 AM
  • Hi, I'm here to confirm with you if your issue has been resolved. If the problem is successfully solved, you can share your solution and mark them or the helpful reply as answer, this will make answer searching in the forum easier and be beneficial to other community members as well.

    Regards,

    Beverly Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, November 18, 2019 1:52 AM
  • Hi, I'm here to confirm with you if your issue has been resolved. If the problem is successfully solved, you can share your solution and mark them or the helpful reply as answer, this will make answer searching in the forum easier and be beneficial to other community members as well.

    Regards,

    Beverly Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Hi Gao,
    The problem has not been resolved...
    Thank you so much!
    Tuesday, November 26, 2019 9:06 AM
  • Hi, I'm here to confirm with you if your issue has been resolved. If the problem is successfully solved, you can share your solution and mark them or the helpful reply as answer, this will make answer searching in the forum easier and be beneficial to other community members as well.

    Regards,

    Beverly Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Hi Gao,
    The problem has not been resolved...
    Thank you so much!

    See my comment from above. What you trying to do is not really practical:

    Only if you setup the remote domain specifically and set it to internal

    https://docs.microsoft.com/en-us/exchange/clients-and-mobile-in-exchange-online/mailtips/mailtips-over-organization-relationships

    Tuesday, November 26, 2019 12:55 PM
    Moderator
  • Hi ssaikaew99,

    If the problem is successfully solved, you can share your solution and mark them or the helpful reply as answer, this will make answer searching in the forum easier and be beneficial to other community members as well.

    Have you tried the following commands to set those domains to internal as Andy suggested? This is a efficient resolution.

    New-RemoteDomain -DomainName *.contoso.com -Name Contoso
    Set-RemoteDomain -Identity Contoso -IsInternal $true

    Regards,

    Beverly Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, November 27, 2019 2:13 AM