none
Requested registry access is not allowed when opening Infopath Forms on Sharepoint 2013

    Question

  • Hello Technet Community.

    I hope this will help anybody out there that experienced this problem after patching Sharepoint 2013.

    I have a distributed 3-tier Sharepoint 2013 environment. All of a sudden, after the last round of patched released on 7-Jul-2014, opening Infopath forms would throw a "something went wrong" error.

    Looking at the ULS logs, you would see the error "Requested registry access is not allowed.".

    I have looked at tons of posts on different blogs, and all pointed out that you need to grant "read" permissions to the application pool user (in my case a service account in AD) to the registry key (and subkeys):

    HLKM/Software/Office Server/15.0

    That indeed works, but it is not the proper way to do it. You should grant "read" permissions to this local group:

    WSS_WPG

    And special permissions to this local group:

    WSS_ADMIN_WPG

    Here is a snapshot of the special permissions needed

    By the way, the WSS_PWG local group contains the app pool service account.

    I do not know why patching Sharepoint removed these permissions from the registry keys, but oh well...

    Anyway, Sharepoint is now happy and Infopath forms work as expected.

    Claudio

    Thursday, July 10, 2014 2:08 PM

All replies

  • Check if your service account or infopath service account has access to server and specially registry

    http://blogs.technet.com/b/spsforum/archive/2011/11/02/quick-solution-5-requested-registry-access-is-not-allowed.aspx

    To solve the issue, please follow these steps:

    1. Use the Process Monitor to monitor the registry, once you get the following ACCESS DENIED message(You can filter the result with “Result contains Access Denied”):  

      Date & Time:      <date time>

      Event Class:        Registry

      Operation: RegOpenKey

      Result:  ACCESS DENIED

      Path:     HKLM\SOFTWARE\Microsoft\Office Server\14.0

      TID:        2020

      Duration:             0.0000297

      Desired Access:                Read

    2. Open Registry Editor (Start > Run, type regedit)
    3. Open key: HKLM\SOFTWARE\Microsoft\Office Server\14.0(got from Process Monitor from step 1)
    4. Assign the SharePoint Timer Service account the Read permission to this key

    One can open registry using regedit command. In Registery editor go to 

    HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\15\Secure\FarmAdmin

    Check central  administration app pool Identity  have permission on FarmAdmin. Permission can be check on right clicking FarmAdmin --> Permissions.


    If this helped you resolve your issue, please mark it Answered

    Friday, July 11, 2014 6:54 AM
  • That is not the proper way to do it.

    Please read the original post.

    • Proposed as answer by BlueSky2010 Monday, December 14, 2015 2:23 AM
    Thursday, March 5, 2015 9:39 PM
  • Yup this did the trick! Thank you!
    Monday, April 6, 2015 10:12 PM
  • Thanks Audiolomb - amazing this is not documented on the install instruction on s the CU! I tried to apply SP2013 July 2015 CU and received this same error in the ULS logs which lead me here. Thanks for the post.
    Monday, August 17, 2015 2:09 AM
  • Thank you very much Audiolomb.  The January 2016 CU was installed yesterday on our farm and we were getting the "Requested registry access is not allowed" error.  I followed your instructions and then did an IISRESET and it resolved the issue.
    Friday, January 22, 2016 2:23 PM
  • There are a lot of other keys that can potentially messed up, but there is another option. When you run the PSCONFIG command after the CU install, include "-cmd secureresources".

    This automatically sets the appropriate permissions on all of the requisite registry keys. Make sure you do the iisreset afterwards, and everything should be OK

    Monday, September 19, 2016 10:48 PM
  • Thank you for posting this, it saved me a lot of time! It's a shame Microsoft don't put this info on their CU pages for Sharepoint!

    Thanks!

    Tuesday, November 22, 2016 10:42 AM