none
Lync Online vs Exchange 2013 On Premise

    Question

  • We have Lync 2013 Online and Exchange 2013 SP1/Outlook 2013 SP1 on premise.   All work well with RPC over HTTP.

    We are trying to get MAPI over HTTP (Outlook 2013 SP1 / Exchange 2013 SP1).  But it seems that the MAPI over HTTP no longer respects the Internet Explorer Bypass Proxy List.  Therefore the Outlook client tries to connect to the on-premise Exchange Server CAS via the proxy server.  Outlook 2013 Connection status shows DISCONNECTED and AUTHN FAILED.

    To reconnect Outlook we can either;

    1.  Turn off the Proxy Server in IE (Outlook then connects but we cannot browse the web).

    2.  Remove the Microsoft Online Services assistant (again Outlook then connects, but Lync does not).

    To troubleshoot this we've used the Process Monitor and can see Outlook actively reading the registry key (HKCU\software\microsoft\windows\currentversion\internet settings\proxyoverride).  Problem is it doesn't appear to use them.

    Has anyone else seen this behaviour with MAPI over HTTP and the Online Services Sign In Assistant (MSOIDCLI)? 

    
    
    
    
    
    
    
    
    
    
    
    
    
    Friday, April 25, 2014 8:32 AM

All replies

  • We have the same problem. Outlook 2013 SP1 ignores our proxy bypass list and tries to connect via proxy and fails with authn error.

    Microsoft Online Services assistant isn't installed.

    Any ideas?

    Wednesday, May 21, 2014 7:12 PM
  • Markus,

      We're still looking at the issue.  I'm encourged that we're not the only ones with the issue!

      It's not at all clear.  When we initially removed the Online Sign In Assistant we managed to get a client working.  But when we came back a few days later to investigate in more detail, we found that the same client did not work again.  So it looks like the issue is NOT related to MSOIDCLI.

      It does appear that the Outlook client reads the by-pass proxy list but then ignores it.   Either that or our proxy exceptions don't match - though we've tried all combinations, including FQDN of the servers and the IP's. If we turn off the proxy server in IE then Outlook will connect using MAPI over HTTP successfully.

      To be honest we decided to wait a couple of weeks to see if anyone else had the issue rather than fight our way through Microsoft support.  We did have a case open with the Microsoft Lync Online team but that got nowhere very quick.  We will raise a ticket now and post back.

    Matt

    Thursday, May 22, 2014 6:22 AM
  • Hi Matt,

    thanks for your reply. we also tried all combinations without success. only disabling the proxy system wide relsoves the issue. So we can read mails OR browse the web.

    Another issue we discovered with mapi over http is that the online archives of shared mailboxes aren't automapped in Outlook anymore, althoug the proxy is diabled and the users have full access permissions for the mailbox.

    So we also decided to disable MAPI over HTTP and wait for Microsoft to fix.


    Thursday, May 22, 2014 12:53 PM
  • Markus,

      Microsoft Support called us back.  After passing us from the Exchange team to the TMG team (even though the traffic shouldn't have been at the TMG in the first place) and back to the Exchange team again we have been given what they believe is an undocumented resolution to this issue.

      You need to include ALL of your CAS servers in the exception list in the following format.

    <IP ADDRESS>;<NETBIOS NAME>;<FQDN>

    e.g

    10.0.0.1;mailserver1;mailserver1.tailspintoys.com

    Many thanks,

    Matt Moss

    Friday, May 23, 2014 10:42 AM
  • This is a known issue with MAPI/HTTP at this moment. Outlook Team is investigating it for a root cause & possible fix. No ETA is available at this time. I will update this post when we have an update.

    Issue: If an Outlook 2013 SP1+ user has 'Bypass proxy server for local addresses' setting enabled in Internet Explorer (Internet Options | Connections | LAN Settings), then Outlook does not connect over MAPI/HTTP to a mailbox on Exchange 2013 SP1+ server. This issue does not happen connecting over RPC/HTTP in the same setup.

    I see another known issue mentioned here thus wanted to quickly confirm that as well. Another known issue with MAPI/HTTP is as described below. This issue has been fixed and fix is planned to be deployed in Office 365/Exchange Online soon & is currently planned to be included with E2013 SP1 CU6 (tentative).

    Issue: User1 has full access to User2’s mailbox, User2 also has an Archive mailbox. Using Outlook 2013 SP1+ User1 connects over MAPI/HTTP to Exchange 2013 SP1+. User2’s Primary mailbox is then accessible to User1 in his Outlook thru Auto-mapping, but User1 cannot see User2’s Archive mailbox. If User1 connects over RPC/HTTP, he does not see this issue.


    Sr. Program Manager, Product Quality, Exchange Client Access Server

    Wednesday, June 4, 2014 4:18 PM
  • Hi Amir,

    do you know if the proxy bypass issue is fixed in cu6? Or maybe there is an outlook bugfix?

    In kb 2982759 i saw that the archive mailbox access issue is fixed, but i didn't find anything about the proxy issue.

    Thanks, Markus

    Wednesday, August 27, 2014 10:29 PM