Unable Send test email from Telnet


  • Hi Expert,

    I am using Office 365 product. So my current issue is I want to send test mail using Telnet and the error appear 530 5.7.1 Client was not authenticated. I have ePortal system and configured Email notification. After configuration done I try send test mail from ePortal. The error appeard "504 Unrecognized authentication type". The best way I try troubleshoot this issue is using telnet command. By telnet command I also got the error as below,  

    Below is the result of telnet:


    220 Microsoft ESMTP MAIL Service ready at Fri, 23 Mar 2012
    06:56:33 +0000
    250 Hello []
    530 5.7.1 Client was not authenticated

    Connection to host lost.

    I dont have any Exchange server in premise. All in cloud. I understand that if I want send the email using telnet, i need configure the receive connector in Exchange Server. I am not sure is it any command can I use to setup/configure receive connector for Office 365 to allow anonymous users to send email. I'm using Windows Server 2008 R2 for Domain Controller inside my premise.

    Please advice. 



    Friday, March 23, 2012 7:26 AM

All replies

  • Hi CatchTylerDurden,

    In Office 365 you can send emails only if you first authenticate, use port 587 and TLS encryption. You must keep that in mind when you configure your ePortal system.


    Friday, March 23, 2012 2:44 PM
  • if ePortal is leveraging TelNet, it will not work with TelNet unless you have a version that employs the STARTTLS and STOPTLS commands.

    Monday, March 26, 2012 7:50 PM