none
Connecting via ActiveSync with Nokia devices and Mail for Exchange RRS feed

  • General discussion

  • The iPhone has gotten a little bit of press lately ;) but I wanted to give everybody a heads up on how to connect Nokia E Series and N Series devices.  I have tested this on both the E71 and E63.

    1)  Download Mail For Exchange from the Nokia website http://www.businesssoftware.nokia.com/mail_for_exchange_downloads.php and install it to your device

    2)  To configure your profile enter your email address, user name (same as email), password, domain (leave blank) and select your internet provider.

    3)  It will then startup and then take you to configure your profile.  Enter red001.mail.microsoftonline.com as the Exchange Server and select "Yes" for secure connection.

    4)  Enter your synchronization settings as you wish and presto, you are ready to go!


    Thanks to Kevin Wang for the url from a different post.
    Friday, February 20, 2009 1:44 AM

All replies

  • Cool. Using your instructions I actually get "Invalid password" as the response. I opened a support ticket for my 30 day trial and the instructions received through that were on the level of "oh it works and all MfE settings are different and depends on your phone" which was kind of annoying. The documentation has only instructions for Windows Mobile 6.5.

    Anyway server red001.mail.microsoftonline.com does not seem to work for any of the user ids in EMEA.. are there others I could try instead?

    The same applies actually for Entourage 2008 as well. I cannot get it to work using the instructions in the documentation. Also a support ticket open on that but no reply so far.



    Kaj
    • Edited by kajtzu Sunday, March 8, 2009 3:54 PM fix typo
    Sunday, March 8, 2009 3:51 PM
  • In EMEA red002.mail.emea.microsoftonline.com seems to be the address I'm looking for. Some creative thinking was required.

    It would be nice if the MS people on this list made the MfE instructions official in the documentation and/or documented what servers one is supposed to use with it.


    :-)

    Sunday, March 8, 2009 4:07 PM

  • The documentation at http://technet.microsoft.com/en-us/library/cc842602.aspx - and the url it refers to with "URLs for Microsoft Online Services" - state that the correct format would be "https://mail.emea.microsoftonline.com/exchange/someone@defaultdomain" but that doesn't seem to work.

    A search for interesting issues with Entourage and Exchange turned up the following article http://support.microsoft.com/default.aspx/kb/931350 which states that there should not be any protocol prepended to the URL. Doesn't seem to work either. As I got MfE working with red002 I tried, on a hunch, the same for Entourage and magically things started to work.

    So in case anyone else stumbles on Exchange 2008 and connection issues with Exchange Hosted EMEA (BPOS), the exchange server URL needs to be

    "red002.mail.emea.microsoftonline.com/exchange/someone@defaultemaildomain" without the quotes.

    Please fix your documentation and send me a t-shirt for doing your testing and proofreading for free ;-)


    Kaj
    Sunday, March 8, 2009 8:26 PM
  • Glad you figured it out for EMEA.  Yeah, I had to piece it all togther as well as there was no good documentation.  At least others should now (hopefully) find these posts.
    Monday, March 9, 2009 6:27 AM
  • For completeness, I think substituting red003.mail.apac.microsoftonline.com in the examples above will make MfE and Entourage work in APAC.

    :)
    • Edited by kajtzu Monday, March 9, 2009 6:54 PM fix language
    Monday, March 9, 2009 6:53 PM
  • Did you try using the virtual FQDN of "mail.apac.microsoftonline.com" as apposed to hardcoding it to a specific node?
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Monday, March 9, 2009 9:14 PM
  • Jeff,


    That doesn't work. Please refer to http://blogs.technet.com/msonline/archive/2009/03/13/connecting-your-mac-to-microsoft-online-services-international-release.aspx


    Kaj
    Sunday, March 15, 2009 2:29 PM
  • You will find that many of the problems with MfE and BPOS can be traced to the version of MfE being used.
    .
    I spent an hour or more trying to follow the instructions above on a new E71 (in the United Kingdom) with no success.
    I then used the same credential pattern on my older E51 on which I had previously installed MfE over 18months ago, it worked instantly.
    .
    If I get a spare momment I will look up the install versions but I know for a fact that my E51 is <2.0 while my E71 has >2.0. Both installs were from the in built Nokia download application link.
    .
    If you can get an older version from the Nokia website then I think that is worth a go.
    .
    Oliver
    Tuesday, March 24, 2009 5:16 PM
  •  At least others should now (hopefully) find these posts.

    I did :) thanks for the help.
    Tuesday, May 12, 2009 10:42 AM
  • Could not get it to work so i too opened a support case and got the following reply.

    https://red002.mail.emea.microsoftonline.com worked for me :)


    1. Navigate to http://www.businesssoftware.nokia.com/mail_for_exchange_downloads.php

    2. Select your Region and Phone Model

    3. Select the Mail for Exchange .SISX package

    4. Follow the download instructions

    Note: May take several minutes to download

    6. You will be prompted to Install Mail for Exchange

    For more information about Mail for Exchange, please read the documentation provided from Steps 1 and 2 for your Phone Model.

    To launch Mail for Exchange to configure Exchange Online:

    If prompted to create a new profile, skip to step 5

    1. Navigate to your device Menu

    2. Select the MFE folder

    3. Select Mail for Exchange

    4. If not prompted to create a new profile, select Options > Create Profile

    5. Enter your E-Mail address

    6. Enter anything for the Domain, at first profile creation this is required, however this will need to be blank later

    7. Enter your Username (i.e. user@contoso.com)

    Note: this is what you use to access your Microsoft Online Services

    8. Enter your Password

    9. Enter the Access point, this would be your wireless carrier

    10. Select OK

    11. Enter the correct option for the Exchange Server from list below:

    Mobile Device URLs
    Your mobile device URL is determined by the storage location of your Microsoft Online Services data. To connect to Microsoft Exchange Online, your cellular service plan must support Windows Mobile.

    Asia Pacific (APAC)
    https://red003.mail.apac.microsoftonline.com

    Europe, the Middle East, and Africa (EMEA)
    https://red002.mail.emea.microsoftonline.com

    North America
    https://red001.mail.microsoftonline.com

    12. Navigate to the Credentials screen and make the Domain field blank.

    a. This is after the Connection screen

    13. Select Options then Save

    Additionally, although this is for a different model, you may find the following blog helpful:

    Nokia E61 Mail For Exchange - ActiveSync.
    http://www.e-series.org/archives/54

    Tuesday, May 12, 2009 11:57 AM
  • Could not get it to work so i too opened a support case and got the following reply.

    https://red002.mail.emea.microsoftonline.com worked for me :)


    1. Navigate to http://www.businesssoftware.nokia.com/mail_for_exchange_downloads.php

    2. Select your Region and Phone Model

    3. Select the Mail for Exchange .SISX package

    4. Follow the download instructions

    Note: May take several minutes to download

    6. You will be prompted to Install Mail for Exchange

    For more information about Mail for Exchange, please read the documentation provided from Steps 1 and 2 for your Phone Model.

    To launch Mail for Exchange to configure Exchange Online:

    If prompted to create a new profile, skip to step 5

    1. Navigate to your device Menu

    2. Select the MFE folder

    3. Select Mail for Exchange

    4. If not prompted to create a new profile, select Options > Create Profile

    5. Enter your E-Mail address

    6. Enter anything for the Domain, at first profile creation this is required, however this will need to be blank later

    7. Enter your Username (i.e. user@contoso.com)

    Note: this is what you use to access your Microsoft Online Services

    8. Enter your Password

    9. Enter the Access point, this would be your wireless carrier

    10. Select OK

    11. Enter the correct option for the Exchange Server from list below:

    Mobile Device URLs
    Your mobile device URL is determined by the storage location of your Microsoft Online Services data. To connect to Microsoft Exchange Online, your cellular service plan must support Windows Mobile.

    Asia Pacific (APAC)
    https://red003.mail.apac.microsoftonline.com

    Europe, the Middle East, and Africa (EMEA)
    https://red002.mail.emea.microsoftonline.com

    North America
    https://red001.mail.microsoftonline.com

    12. Navigate to the Credentials screen and make the Domain field blank.

    a. This is after the Connection screen

    13. Select Options then Save

    Additionally, although this is for a different model, you may find the following blog helpful:

    Nokia E61 Mail For Exchange - ActiveSync.
    http://www.e-series.org/archives/54


    registered to say this post is made of 100% win, thanks!!
    Wednesday, May 20, 2009 7:32 PM
  • I have until now been using a Nokia E51 with MfE v2.03 with our in-house Exchange 2007 server (behind an ISA2006 server) - the only major headache I had with this configuration was with the "Heartbeat" value (when syncing was set to "Always On") - basically, whatever you set it to, it reduced itself to 1 every time. This means the battery life was terrible because (as far as I can tell) it was opening a new connection every minute. I couldn't find any way to fix this...

    I thought this would work as it should (ie the Heartbeat stays around 7-10) with the MS Online service but in my testing period I've experienced exactly the same problem again, so I really can't use "Always On" as I would like, it drains the battery in less than 2 days with no other use, much quicker if you actually use the phone!!

    Has anyone else found or realised this? I noticed that on a colleague's Nokia (which happens to be an E71) with the latest MfE client, the "Heartbeat" value is strangely missing from the Sync Schedule screen (you only see on mine when its set to "Always On").

    I take it that ISA server is messing this up somehow, as I assume MS are using ISA somewhere in the Online service?
    Wednesday, May 27, 2009 4:58 PM
  • hi, this didn't work for me.... I am not sure if I have MS online service, I am not expert at this.... I just seem to have the normal MS Exchange, but this is set-up to work for Mobile.... Hope you can help. I have been having so many problems trying to do this and am tempted to bin this phone and get a blackberry :( the model is e71.

    Thanks!
    Thursday, September 17, 2009 10:15 AM
  • obrigado pelo Post..

    funcionou thank´s

     

    Naylor Braga
    Friday, February 4, 2011 6:11 PM
  • I think nokia has stopped "mail for exchange"

    is there any alternate solution from Nokia for this?

     

    Monday, July 4, 2011 11:38 AM