none
I can't create an alert at Folder or Document Set level: Access Denied RRS feed

  • Question

  • Hi,

    I would like have user groups at Folder or Document Set level with permission to create alerts but SPO let the users fill in the form and then prevent them from creating the alert, below my environment.

    I have a site and a subsite and two custom Permission Level, a Reader and an Alert.

    Reader has the following PermissionKind enum: 

    • "ViewListItems"
    • "OpenItems"
    • "ViewVersions"
    • "ViewFormPages"
    • "ViewPages"
    • "UseRemoteAPIs"
    • "UseClientIntegration"
    • "Open".

    Alert too plus these:

    • "ManageAlerts"
    • "CreateAlerts"
    • "BrowseDirectories"
    • "CreateSSCSite"
    • "BrowseUserInfo"

    I've broken the inheritance between site and subsite and remove all groups I don't need from subsite, all groups in subsite has Permission Level Reader.

    In subsite I have some Libraries, between them inheritance is not broken and so I have the subsite groups in Libraries always with Permission Level Reader.

    In Libraries there are Folders or Document Set and inheritance is broken: every Folders and every Document Set has a group with Permission Level Alert but... when a user belonging to this group try to create an alert he (or she) can fill the form in but can't create the alert because a pop up says "Sorry, you don't have the access" and shows a button to require the access.

    What's wrong with it? Why can users fill the form in but not create the alert?

    And then: if a user clicks on button to require the access and the admin accepts then user get Permission Level directly and not through a group, in fact on Site Permissions page user is shown in the list of groups.

    Any advice? Thanks in advance?

    Tuesday, September 24, 2019 11:18 PM

Answers

  • Maybe I've just solved the mistery: to make it work I have to set the same Permission Level "Alert" the group in subsite\Document Library and in the Folder or Document Set, so users belonging to the group can fill in the form and create the alert.

    The denied by pop up doesn't help, coluld someone please give me an explanation?

    Thanks in advance.

    • Marked as answer by EmaLac Wednesday, September 25, 2019 12:00 AM
    Wednesday, September 25, 2019 12:00 AM
  • Hi,

    First, congratulations on solving this issue and thanks for sharing your solution.

    Second, to answer your question:

    Users will need Alert permission in the document library to create an alert on the folders inside.

    Relatively, if the users have Alert permission on a folder, they will be able to create an alert on documents inside the folder without error.

    Best regards,

    Chelsea Wu



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by EmaLac Wednesday, September 25, 2019 6:45 AM
    Wednesday, September 25, 2019 6:41 AM

All replies

  • Maybe I've just solved the mistery: to make it work I have to set the same Permission Level "Alert" the group in subsite\Document Library and in the Folder or Document Set, so users belonging to the group can fill in the form and create the alert.

    The denied by pop up doesn't help, coluld someone please give me an explanation?

    Thanks in advance.

    • Marked as answer by EmaLac Wednesday, September 25, 2019 12:00 AM
    Wednesday, September 25, 2019 12:00 AM
  • Hi,

    First, congratulations on solving this issue and thanks for sharing your solution.

    Second, to answer your question:

    Users will need Alert permission in the document library to create an alert on the folders inside.

    Relatively, if the users have Alert permission on a folder, they will be able to create an alert on documents inside the folder without error.

    Best regards,

    Chelsea Wu



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by EmaLac Wednesday, September 25, 2019 6:45 AM
    Wednesday, September 25, 2019 6:41 AM
  • Thanks for your answer, now it's clear for me but I keep on thinking it would be better don't allow users to see the popup with the form.

    Thanks a lot again.

    Wednesday, September 25, 2019 6:48 AM
  • Hi,

    I’m glad that the information is helpful to you.

    In addition, the only OOB solution to disable this popup is to make Alert me button unavailable to users. For example, if you are using classic experience, the "Set alert on this library" option will be greyed out and not clickable. 

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, September 30, 2019 2:13 AM
  • Hi,

    yes I know, in fact I've just disabled that button for another group but in this case I need to let some users create an alert giving to them less permissions I can.

    Your answers are very helpful for me, thanks again.

    Monday, September 30, 2019 8:10 AM