locked
ExchangeOnline prep: IDFix works, but something keeps re-adding old attribute with invalid characters back RRS feed

  • Question

  • We are hoping to start Exchange2010 online migrations in next 2 weeks.  I have cleaned up over 1000 accounts with IDfix, but still have 150 with proxy address character errors in IDFix because they have parenthesis.  IDFix is able to edit and fix the issue on the user accounts(I check the attribute and everything looks good), but the next day the accounts show up again and this time that have both the fixed proxyaddresses attribute without parenthesis, and recreated the incorrect proxyaddresses attribute with parenthesis.  Our email setup is extremely simple and not sure what is adding back in the incorrect values.  It might even work and just give cosmetic dir/azure sync errors, but I would like to try and fix this properly.

    If anyone has any ideas what is recreating the old proxyaddresses value with invalid charachters in it, please let me know.  My guess at this point is an Exchange 2010 policy, but let me know if anyone has any ideas.


    Dave



    Friday, July 24, 2020 8:00 PM

All replies

  • We are hoping to start Exchange2010 online migrations in next 2 weeks.  I have cleaned up over 1000 accounts with IDfix, but still have 150 with proxy address character errors in IDFix because they have parenthesis.  IDFix is able to edit and fix the issue on the user accounts(I check the attribute and everything looks good), but the next day the accounts show up again and this time that have both the fixed proxyaddresses attribute without parenthesis, and recreated the incorrect proxyaddresses attribute with parenthesis.  Our email setup is extremely simple and not sure what is adding back in the incorrect values.  It might even work and just give cosmetic dir/azure sync errors, but I would like to try and fix this properly.

    If anyone has any ideas what is recreating the old proxyaddresses value with invalid charachters in it, please let me know.  My guess at this point is an Exchange 2010 policy, but let me know if anyone has any ideas.


    Dave



    Look at your Email Address Policies and see if they are setting something.

    https://practical365.com/exchange-server/exchange-server-2010-email-address-policies/

    Friday, July 24, 2020 8:43 PM
  • Thanks for that response. - I was wondering the same, but no email address policies are getting applied.  

    I just noticed something.  The only people in that user list are the ones that we have already added into Azure AD Connect(1.4.18) to sync their accounts to Azure.  We have not made any changes to these accounts, but my guess is Azure Sync is bringing back these characters that the latest version of IDFix(2.2.0) is then reporting as problems.  We have not migrated any mailboxes yet, but I checked and am not seeing any issues in the Sync Service Manager for Azure connect, so I am guessing these account problem character alerts from IDFix are incorrect? 

    This version of Azure Connect is a few months old so I am going to update it, but if anyone has any ideas on this, let me know.



    Dave



    Monday, July 27, 2020 3:07 PM
  • Hi,

    Could you please provide the complete error information or any screenshots about your issue above?

    Synced account is added one X500 address automatically

    Please also check whether the below links are related to your problem

    How the proxyAddresses attribute is populated in Azure AD

    One or more objects don't sync when using Azure Active Directory Sync tool

    This Microsoft Online: Exchange Online Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Regards,

    Joyce Shen


    Microsoft Online: Exchange Online will be migrating to a new home on Microsoft Q&A! We invite you to post new questions in the new forum.

    For more information, please refer to the sticky post.

    Wednesday, July 29, 2020 8:24 AM
  • Hi,

    Is there any update about your issue?

    This Microsoft Online: Exchange Online Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Regards,

    Joyce Shen


    Microsoft Online: Exchange Online will be migrating to a new home on Microsoft Q&A! We invite you to post new questions in the new forum.

    For more information, please refer to the sticky post.

    Monday, August 3, 2020 1:18 AM