none
STATUS_WAIT_2 0x80070002 error when using Windows 7 style backup in Windows 10 RRS feed

  • Question

  • I am getting a "STATUS_WAIT_2 0x80070002" error immediately after pressing the "Save settings and run backup" button.  No files are saved as the backup aborts before the backup starts   The computer I am using was upgraded from Window 7 to Windows 10.  I have the latest updates for Windows 10.  So far I have been unable to find any discussion for this scenario.
    Tuesday, January 9, 2018 7:49 PM

All replies

  • Hi,

    I noticed the error message, do you have any anti-virus program installed?

    I suggest you to follow the methods below and check if it helps.

    Method 1: SFC Scan

    System File Checker is a utility in Windows that allows users to scan for corruptions in Windows system files and restore corrupted files. Run the System File Checker (SFC) scan to fix any corrupted files. Follow these steps:

    https://support.microsoft.com/kb/929833?wa=wsignin1.0

    Method 2: Deployment Image Service and Management Tool command (DISM)

    By running this command we can retrieve or modify information within an image. To run the DISM command please follow the below steps:

    Press “Windows Logo” + “X” keys on the keyboard and select “Command Prompt (Admin)” from the list.

    Type “Dism.exe /online /cleanup-image /restorehealth” and press “Enter”.

    Wait for the command to execute which might take around 30 minutes.

    After the command is executed, restart the computer and check if the issue persist.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 11, 2018 2:55 AM
    Moderator
  • I ran both sfc and dism.  Both gave no indication of any error.  I turned off my anti-virus and tried the backup again with the same results  - the Status_Wait_2 error. (I have tried both sfc and dism before without any success).  I also have a computer which came with Windows 10 installed and successfully ran the same Windows 7 style backup on it successfully.  The computer which I am having the trouble running the Window 7 style backup was upgraded from Windows 7 to Windows 10. Both computers have the same anti-virus software so that doesn't appear to be the issue (also I tried it with the antivirus turned off and it still didn't work).

    I was able to successfully run the backup when it was a Windows 7 machine.  From my research, I suspect that in upgrading from Windows 7 to Windows 10 something was missed and that is causing the problems using the Windows 7 style backup.  Others with this problem seem to all be on machines upgraded from Window 7.

    Friday, January 12, 2018 3:26 AM
  • Hi,

    We haven’t heard from you for a couple of days, have you solved the problem?  

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 17, 2018 6:54 AM
    Moderator
  • Hi,

    See my reply above.  I tried your suggestions and have the same results - the same STATUS_WAIT_2 error.

    Thursday, January 18, 2018 1:19 AM
  • I haven't heard anything on this in about three weeks.  Do you have any more suggestions as the one given above did not work?  The problem described in Backup error 0x80070002 using Windows 10  may be related to this problem.  While there are details of the problem missing, I have had a very similar, maybe same, problem with the other Windows 7 systems that were upgraded to Windows 10.  On these systems I would go though the steps of setting up the backup, click on the "Save settings and run backup" button.  The backup would immediately abort with the "File not found - error 0x8007002".  No file name was given, no files were saved, and the backup settings were not saved.  In all my attempts to get the Windows 7 style back-up to work on a system upgraded to Windows 10, I have never gotten it to work.
    Tuesday, February 6, 2018 8:20 PM
  • Please try the following steps and check the result.

    In Control Panel, open Backup and Restore.

    In the Backup section, click Change settings. In the Set up backup dialog box, click Next.

    In the What do you want to back up dialog box, click Let me choose, and then click Next.

    Expand Data Files, expand <your user name> Libraries.

    Expand Additional Locations, and then click to clear the AppData folder, Contacts, and Searches check boxes.

    Expand Computer, expand the item for your system drive (for example, expand Local Disk (C:)), Expand Users, expand <your user name>, and then click to select the AppData, Contacts, and Searches check boxes if they exist. Click Next, and then click Save settings and exit.

    In Backup and Restore, click Back up now to perform a new backup. The backup operation should complete without errors.

    If the problem still persists, I suppose that there might be something wrong with your system, you may need to perform a clean install.


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, February 28, 2018 8:12 AM
    Moderator
  • I've tried your suggestion and the results are the same.  I agree that there is probably something wrong with my system.  I suspect that something in upgrading from Windows 7 to Windows 10 is causing the problem.  Doing a clean install is not an option as I can't save my files and recovering all my apps is problematic.  Also I can't have my system down for the length of time needed to do a clean install.  Maybe what I need to do is to get a non Microsoft backup program that works.
    Thursday, March 1, 2018 7:25 PM
  • I'm in the same boat as Michael.  My upgraded desktop (from W7 to W10) no longer works.  My new W10 laptop and tablets use Windows 7 Backup AOK.  The hints noted above also do not help.  :(   Obviously something with the software in the recent updates for this "upgrade" architecture. Any new suggestions?  Download a Windows 7 Backup/Restore app from the Microsoft Store?
    Tuesday, March 6, 2018 10:04 PM
  • This error has nothing to to with upgrade from Win7 to win 10. I set up a laptop with a clean Windows 10 Version 1803 and got the same error.

    I used a new Backup USB disk. First time backup worked and i could reinstall my system from the image file. All seems working nicely. Then installed some programs like firefox, teamviewer - all oficial registered - and next backup failed.

    Then I saw some very ridicoulous - windows backup told me there are 45 GB of other files on Backup drive. But the backup drive was empty before and i sure not copied anything to it.

    I dont trust anymore now Windows backup until Microsoft solve such principle problems.


    • Edited by Uwe_CH Tuesday, June 19, 2018 12:20 AM
    • Proposed as answer by pbrad Thursday, July 26, 2018 12:44 PM
    • Unproposed as answer by pbrad Thursday, July 26, 2018 12:44 PM
    Tuesday, June 19, 2018 12:11 AM
  • I am trying to carry out a system image using the backup and restore option (Windows 7) from the control panel option and received the following error:

    Backup encountered a problem while backing up file C:\Users\defaultuser0\Contacts. Error:(STATUS_WAIT_2 (0x80070002))
    Backup encountered a problem while backing up file C:\Users\defaultuser0\Searches. Error:(STATUS_WAIT_2 (0x80070002))

    On further investigation I came across this:

    https://answers.microsoft.com/en-us/windows/forum/windows_10-update/what-is-errorstatuswait2-0x80070002-in-windows/6116f4cb-f8ca-4dd9-9742-35366c41b048

    Microsoft issued this:

    https://support.microsoft.com/en-us/help/4034825/features-that-are-removed-or-deprecated-in-windows-10-fall-creators-up

    Stating the System Image Backup (SIB) Solution would be deprecated in the Windows 10 Fall Creators update and they recommend that users use full-disk backup solutions from other vendors.

    Suggested solutions are Macrium Reflect (Free) or EASEUS TODO Backup Free. I just need this solution for one system and haven't tried either yet. I usually use Acronis a pay for solution.

    Hope this helps.

    Kind regards

    Brad
    Thursday, July 26, 2018 12:46 PM
  • This resolved my backup problem with the above error message.

    My system is not using a Win 7 upgraded but Win 10 from birth (currently flavour 1803).

    Thanks for the help.

    Thursday, October 4, 2018 7:31 PM
  • In the event anyone else runs into this, I figured I would post what worked for me.  After trying to capture a system image from the windows 10 OS I was getting the same error.  I tried another image capture program with a similar result.  I took the disk I was attempting to write the image to and formatted and re-partitioned it and then I was able to capture the system image.  Hope this can help someone.  
    Tuesday, March 5, 2019 7:34 PM
  • Thanks for this reply.
    I had the same problem in Windows 10. In my case, re-partitioning was part of the solution, since the Volume Shadow service kept crashing, which is necessary for the backup to work. 
    In my case, I had to set both the Volume Shadow and Windows Backup services to Automatic (as per one of the solutions here: https://answers.microsoft.com/en-us/windows/forum/all/system-image-backup-failed-with-error-the-backup/27e544a-ec52-4b31-8641-c1276f0cdbcc ), repartition&reformat (to get rid of the corrupted Shadow copies on my backup target that kept crashing the service) and reboot. Backup ran fine after that.

    Good luck to anyone else encountering this issue!

    Thursday, January 16, 2020 1:09 PM
  • For me what fixed this was creating the registry key

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsBackup

    Which did not exist for some reason.

    You can save this to a .reg file and run it to easily create the registry key:

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsBackup]

    • Proposed as answer by gerardr Friday, July 10, 2020 4:52 PM
    Wednesday, January 22, 2020 3:13 PM
  • Thank you!! After trying all the steps above, this was the only solution it worked for me.
    Friday, July 10, 2020 4:53 PM
  • I'm running clean install  10.0.19041.329

    Two files (one in system32 and one in user self) failed to backup for W7 backup and restore.  They do not exist in the filestore, so I'm not worried; but they have probably been erased during backup.  No idea why.

    Suggestion: STATUS_WAIT_2 (0x80070002) may occur with deleted files.

    Monday, July 13, 2020 8:50 AM