locked
Random Hardware Addresses for WiFi in Windows 10 Pro Doesn't Work and Kills the OS boot and networking when implemented RRS feed

  • Question

  • Hi,


    I originally posted this on 28DEC15 on the Community Forum and moved the query here this morning.


    I'm running Build 10586 of Windows 10 Professional for personal use.  Everything is current across the board whether implemented automatically by the OS or manually (e.g., also manually searching online for updated signed WHQL drivers via the Device Manager or simply checking the driver and update sites for the various programs and applications I use).  Or Build 1511 as it's called in the Update module.  Everything is current to this point in time.

    I am using Iolo System Mechanic Professional version 15.0.1.4 (current) for AV and anti-spyware protection.  I also use a VPN, but it hasn't been installed yet to get it out of the troubleshooting loop.  Normally, I use proprietary encryption on the drives, including my USBs, and try to keep things as leak free as possible, but... 

    Well, right now I haven't installed any of that yet since I just restored from a complete image of the OS RAID disk (4th cycle/attempt at the WiFi bug), and again, I don't want it coloring my perceptions of what might be going on.  The reason I stopped the build there was to leave the Windows installation as "normal" as possible without added layers of security.

    The hardware is a laptop.  MSI Titan GT80 2QE SLI, Intel i7 5950HQ @ 2.9GHz, Nvidia 980M SLI, 32GB DRAM, 1TB RAID0 SSD (Samsung EVO 850 x 2), 238GB RAID0 SSD (Toshiba's x 2), and 1TB Seagate SSHD rotating disk.  Fast, yes, but a finicky race horse it is.  Win10Pro almost makes it a gaming platform with pluses.

    Okay, so that's my baseline at the moment and for the last 4 tries to get a fix on the WiFi issue.  The internal WiFi installed is a Killer Network Manager with the Double Shot Pro capability, i.e. I can also plug in additional Ethernet bandwidth and it will balance it out for greater bandwidth.  But, again, it's running vanilla at the moment (just the WiFi) and from everything I can see Windows is calling the shots on the WiFi connection and parameters.

    When I go into Settings, Network & Internet, WiFi, Advanced Options, and Random Hardware Addresses I want to select "Change Daily" but every time I log off or restart I lose all WiFi connectivity.  Going into Safe Mode with Networking doesn't work either.  The selections in Settings for WiFi disappear whenever there is no connectivity in either Safe Mode.  So far my only recourse has been to restore from a recent image since nothing else seems  to work.

    Ditto for when I go into Settings, Network & Internet, WiFi, Manage WiFi Settings, and I want to turn on the Random Hardware Addresses.  Same result as described above.

    If I do both, which I've done twice, I've had to delete the OS RAID and start from scratch for an image restoral which can take hours, so lately I only try one or the other since that's only a 6-minute restoral.  And when I say it results in a total lockout no amount of clearing the BIOS, EC, etc. or even a prolonged shutdown will help.  None of the Windows tools helps, none of my utilities is doing much good except my recovery software and offline backups containers to get me back up and running.

    But I shouldn't have to resort to this, now should I <g class="gr_ gr_61 gr-alert gr_gramm gr_disable_anim_appear undefined Grammar only-del replaceWithoutSep" data-gr-id="61" id="61">just to</g> get the system to utilize random hardware addresses?

    For rescue USB's (using WinPE) I've tried to boot my Killer Network drivers, but <g class="gr_ gr_81 gr-alert gr_spell gr_disable_anim_appear undefined ContextualSpelling" data-gr-id="81" id="81">its</g> not working so far.  Same negative results for the USB keys I created for Windows 10 Home and Pro from the MS Store to see if I could "fix" the issue.  I didn't use the ADK/WAK 4 and don't care to at the moment since I'm no developer.  It would be nice to simply be able to "undo" my selections and things roll back to functionality in a simple Safe Mode environment after a reboot.

    One last thing.  I don't use Cortana and have most everything shut down as far as background processes go unless I am using it at the time and then it goes off when I am done.  I didn't think it would matter much, but does anybody think it's worth a try to let Windows run default with everything running amok?

    All I can add is that my WiFi router is the Linksys WRT 1900 ACS Dual-band router and I am running the 5GHz channel for the signal here.  It's up to date and the firmware is bug-free (no vigilante bug) and all the security settings work well with the Windows firewall and other Pro features.  I can go Ethernet mode but that's an easy fix most times.  It's just the Windows 10 Pro WiFi controls disappearing whenever I select "random hardware addresses" via either settings location as described above that's become an annoyance.

    So, what to do?  I've gone through all my notes and logs and removed everything else from the troubleshooting and isolation process and it falls right back into the Windows lap (so to speak).  So here I am since UEFI won't let me install OpenBSD or anything else like that to sidestep the issues so I guess I'll keep working with Win 10 Pro since I do like it a lot when it works.  Any suggestions?

    TIA.

    Best Regards,

    Phil


    Tuesday, January 5, 2016 7:22 AM

Answers

  • Well HP Andrews.

    Thanks for posting in TechNet.

    Here is my understanding after reading your detailed posts:

    You are currently having WIFI issues, whenever selecting the Random Hardware Addresses, WIFI will not work.

    Right?

    Would you mind to share us a screenshot, regarding the Random hardware address?

    I should say currently I didn't have the proper WIFI to manage with, the below is some suggestion you may take a try:

    1. Run the built-in Network Troubleshooter;

    2. Do not use any 3rd-party WIFI software to manage WIFI settings;

    I will try to check with some WIFI connected machines, will share the results soon.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Michael_LS Wednesday, January 13, 2016 10:52 AM
    • Marked as answer by Deason Wu Wednesday, January 20, 2016 8:48 AM
    Wednesday, January 6, 2016 9:05 AM
  • After 2.5 hrs, figured out the fix.

    Long story short:

    1) Boot to safe mode
    2) Open regedit
    3) Navigate to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WlanSvc\Interfaces
    4) Find the interface that contains the key: RandomMacState (for me, it was: {EDA8D522-F34B-49A5-8F13-AD4F59F9DD5F})
    5) Change RandomMacState from 01 00 00 00 to 00 00 00 00
    6) Reboot

    Naturally, I blogged about a more lengthy fix.  Can't post links yet, so do a search for:

    Fix Endless Reboot After Enabling Random Hardware Addresses for Wifi on Windows 10

    Oh, common denominator: Killer Networking Card.  I have one too.  Might be specific to that set of hardware / drivers.

    Hope I save someone else several hours of searching for a fix!

    • Marked as answer by Michael_LS Friday, January 22, 2016 2:05 AM
    Friday, January 22, 2016 12:49 AM

All replies

  • Well HP Andrews.

    Thanks for posting in TechNet.

    Here is my understanding after reading your detailed posts:

    You are currently having WIFI issues, whenever selecting the Random Hardware Addresses, WIFI will not work.

    Right?

    Would you mind to share us a screenshot, regarding the Random hardware address?

    I should say currently I didn't have the proper WIFI to manage with, the below is some suggestion you may take a try:

    1. Run the built-in Network Troubleshooter;

    2. Do not use any 3rd-party WIFI software to manage WIFI settings;

    I will try to check with some WIFI connected machines, will share the results soon.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Michael_LS Wednesday, January 13, 2016 10:52 AM
    • Marked as answer by Deason Wu Wednesday, January 20, 2016 8:48 AM
    Wednesday, January 6, 2016 9:05 AM
  • After 2.5 hrs, figured out the fix.

    Long story short:

    1) Boot to safe mode
    2) Open regedit
    3) Navigate to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WlanSvc\Interfaces
    4) Find the interface that contains the key: RandomMacState (for me, it was: {EDA8D522-F34B-49A5-8F13-AD4F59F9DD5F})
    5) Change RandomMacState from 01 00 00 00 to 00 00 00 00
    6) Reboot

    Naturally, I blogged about a more lengthy fix.  Can't post links yet, so do a search for:

    Fix Endless Reboot After Enabling Random Hardware Addresses for Wifi on Windows 10

    Oh, common denominator: Killer Networking Card.  I have one too.  Might be specific to that set of hardware / drivers.

    Hope I save someone else several hours of searching for a fix!

    • Marked as answer by Michael_LS Friday, January 22, 2016 2:05 AM
    Friday, January 22, 2016 12:49 AM