none
BMR-SS backup fails with error "the specified network name is no longer available" RRS feed

  • Question

  • We are running DPM 2012 SP1 on a Windows Server 2008 R2 system, backing up a Windows Server 2012 system that is a DC.  The agent version is 4.1.3417.0.  Both the DPM server and the DC are physical systems - brand new HP Proliant 360's.

    When creating the replicas for the 2012 server the first time, the backups work fine, and then for a day or so after that.  After a couple of days, the BMR-SS backups fail with the error "the specified network name is no longer available".   I can watch the backup happening in the Windows Server Backup console on the protected server - the BMR backup goes up to 99% and then fails.  BMR backups on all the other servers are working - we have a mix of Win2008R2 and Win2012. 

    Here is what I have tried:

    • I can connect to the UNC path on the backup server without a problem during and after the backup is happening. 
    • Tried reinstalling the DPM agent.
    • Tried backing up directly from the protected server to another server's network share, which worked.
    • I can copy multiple gigabyte files directly from the protected server to the DPM file share without a problem (the same one that DPM uses for the replica)
    • Tried turning off the SCEP real-time protection during the backup.

    Any help would be appreciated - thanks.


    KW

    Wednesday, October 9, 2013 3:32 PM

Answers

  • Hi,

    Make sure NIC drivers are up to date, and then try disabling TCP Chimney and RSS on both the DPM server and the protected server.

    From administrative command prompt run:

    netsh int tcp set global chimney=disabled
    netsh int tcp set global rss=disabled

    Also check properties of the network card and make sure hardware TCP Checksum offload and Receive Side Scaling are also disabled.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, October 9, 2013 5:05 PM
    Moderator

All replies

  • Hi,

    Make sure NIC drivers are up to date, and then try disabling TCP Chimney and RSS on both the DPM server and the protected server.

    From administrative command prompt run:

    netsh int tcp set global chimney=disabled
    netsh int tcp set global rss=disabled

    Also check properties of the network card and make sure hardware TCP Checksum offload and Receive Side Scaling are also disabled.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, October 9, 2013 5:05 PM
    Moderator
  • Disabling the chimney and rss settings seemed to fix it - I ran a consistency check, and it completed this time. That's strange that the default settings would cause problems between two basically identical systems.

    Thanks for your help!


    KW

    Wednesday, October 9, 2013 7:57 PM
  • Exactly same issue here. Unfortunately disabling TCP Chimney and RSS on both the DPM server and the protected server does not work. Other suggestions to try?  
    Monday, February 3, 2014 3:48 PM
  • Figured it out finally.

    1. The problem is only with protected Windows 2012R2 servers.
    2. After removing the protection and deleting the files you can create recovery points gain, but after a few days the error re-occurs.
    3. Checking on the protected server shows that WSB fails after system state is backed up. The job then fails because the connection to the share on the DPM is not available anymore.
    4. A manual WSB to a share on the DPM server runs without problems 

    That made me think that it might be a security issue

    The solution was to add the MACHINENAME of the protected Windows 2012 Server to the local administrators group on the DPM server.

     

    • Proposed as answer by sewellia Tuesday, February 4, 2014 2:03 PM
    • Unproposed as answer by sewellia Thursday, February 13, 2014 8:05 AM
    Tuesday, February 4, 2014 2:03 PM
  • No, The problem reoccurred after a few days. I am running SC DPM 2012 R2 and have only problems with bare metal protection of our 2012 R2 servers. No issues with Windows 2008R. Windows 2003 cannot be protected by design I found out :-(

    Any ideas on what to try more? Someone?

     
    Thursday, February 13, 2014 8:09 AM
  • No one else having this issue?
    Monday, February 17, 2014 2:59 PM
  • Thursday, February 27, 2014 11:25 AM
  • Hi Eugene

    Thank you for your suggestion

    I shrank the C drive and the backup ran successfully one time. After that I am back at the same problem. It must have sothing to do with Windows Server 2012 (r2). No problems on Windows Server 2008

     

    Thursday, February 27, 2014 12:31 PM
  • Have a look at these links (including a related KB):

    DPM 2012 R2 and Bare Metal Recovery/System State System Protection Hyper-V Generation 2 VM Support
    http://social.technet.microsoft.com/Forums/en-US/17b6f662-a639-4762-9619-3beff1bfb185/dpm-2012-r2-and-bare-metal-recoverysystem-state-system-protection-hyperv-generation-2-vm-support?forum=dpmhypervbackup

    System image backup fails after you upgrade to Windows
    8.1 and Windows Server 2012 R2

    http://support.microsoft.com/kb/2930294/en-us


    Boudewijn



    Boudewijn Plomp, BPMi Infrastructure & Security

    • Proposed as answer by sewellia Friday, April 11, 2014 9:02 PM
    • Unproposed as answer by sewellia Saturday, April 12, 2014 7:51 PM
    Friday, April 11, 2014 8:27 AM
  • llo Boudewijn

    I followed Boudewijn's suggestion. 

    The Windows 2012R2 servers had no recovery partition in disk C. I created one (400MB) following http://support.microsoft.com/kb/2930294/en-us and  DPM system restore worked. But just once. 

    So this is not the solution to the problem......

    Is no one else having issues with DPM bare metal protection of Windows 2012R2 servers? 


    • Edited by sewellia Saturday, April 12, 2014 7:56 PM
    Friday, April 11, 2014 9:01 PM
  • I am little step further.

    At this time I have installed almost every update from Windows Update for our servers running on Windows Server 2012 R2. Still no System State backup. But after installing the WSB (Windows Server Backup) feature I am now able to backup the System State for 90% of our servers. Except for our Domain Controllers, Certificate Authority and one other server.

    So apparently the WSB does something. It is not mentioned in the DPM requirements and the error description only states you should install WSB on Windows Server 2008, not about 2012 and 2012 R2.


    Boudewijn Plomp, BPMi Infrastructure & Security | Please remember, if you see a post that helped you please click "Vote as Helpful" and if it answered your question, please click "Mark as Answer".

    Tuesday, April 15, 2014 8:31 AM
  • Sewellia,

    I am having the same issue.  None of the suggestions posted here or in other forums have worked so far.  My backup gets to exactly 26% every time and then fails with the message "the specified network name is no longer available".  I am running DPM 2012 on Server 2008 R2.  I'm trying to backup a VM running Server 2012 R2.  I don't have a non-virtualized 2012 R2 box to test so I don't know if the problem is because it is a VM.  Short of a paid support call to Microsoft I am out of ideas.

    Wednesday, April 23, 2014 3:46 PM
  • I too am having this problem. It looks to me as though the temporary share that DPM creates on the DPM server during a backup is being terminated before the backup completes. Then you get the network name error - not a server name but the name of the share that DPM created.

    Is there a time-out setting that can terminate the share?


    prd

    Friday, July 11, 2014 1:59 PM

  • We have recently upgraded much of our Windows estate to Windows Server 2016 and as part of this work we also upgraded our DPM Server to DPM 2016 1801. Since doing so, the BMR/System State backups for Windows 2016 servers frequently fail. The BMR backups on our Windows 2008R2 servers continued to work without any problems. Looking through the backup/event logs we see the following logged when the backups fail:

    0x8078015B  Windows Backup encountered an error when accessing the remote shared folder
    0x80070079 The semaphore timeout period has expired

    I spent quite some time trying to find a solution to this problem, initially without a great deal of success. If I removed the server from the protection group in DPM, cleared the backup history, and then re-added the server, I would find that the BMR backups worked once or twice before failing consistently once again. If I ran Windows backup on the protected computer, backing up the BMR to local disk it would also work fine. The same BMR backup to a share on the DPM server also worked consistently. Further digging revealed that the DPM server presents a share to the protected computer for the duration of the backup. Testing revealed that the share was removed from the DPM server before the BMR backup completes, resulting in the backup failing. I attempted various configuration changes to try and resolve the problem, but none of these worked. For completeness, here is what I tried unsuccessfully:

    1. Creating/modifying the following registry keys on both the DPM server and the protected server
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\SPP\CreateTimeout and set decimal value to 3600000. To increase VSS timeout.
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VSS\Settings\IdleTimeout and set decimal value to 3600000. To increase VSS timeout.
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Disk\TimeOutValue and changed decimal value from 60 to 180.
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\TcpMaxDataRetransmissions with a decimal value of 5.
    2. Running “wbadmin delete catalog” on the protected server to clear the backup catalog.
    3. Checking for shadow copies and removing them on the protected server using the command “vssadmin list shadows”.
    4. Increasing the paging file to 16Gb from 2Gb on the DPM server.
    5. Attempting to throttle the bandwidth using the bandwidth throttling in DPM.
    6. Modifying the disk allocation to 100Gb for the backup within DPM.
    7. Running chkdsk /f on the protected server.
    8. Modifying the maximum size of storage allocated to volumes for shadow copies to have no limit at all.

    As I said, none of the above helped at all. What has finally led to us being consistently able to run BMR backups reliably on Windows 2016 servers was throttling the bandwidth between the protected server and the DPM server using a QoS profile on the protected server itself. I’ve read somewhere that the throttling built into DPM does not apply to BMR backups. I’m not sure whether that’s true, but trying that did not help us at all. It’s very simple to create a QoS profile in Windows 2016, and it’s not necessary to install any additional software, roles or features. To do so, simply carry out the following steps:

    1. Start “Local Group Policy Editor” by typing gpedit.msc on the protected computer.
    2. Browse to Local Computer Policy > Computer Configuration > Windows Settings > Policy-based QoS.
    3. Right click and select “Create New Policy”.
    4. Provide a name for the policy, uncheck “Specify DSCP Value” and set an outbound throttle rate (I used 100MBps successfully).
    5. Select “All applications” (though if your backup server provides other functions you may wish to restrict this just to the Windows Backup application.
    6. Select “Any source IP address” and enter the IP address of the backup server in the destination field.
    7. Select both the TCP and UDP protocols, and any source/destination port.
    8. The policy takes immediate effect without a requirement to reboot.

    Since applying this policy our BMR backups on Windows 2016 have worked reliably and consistently. Hopefully this is of help to others as well, as this can be quite a frustrating problem!

    Simon Edwins
    Senior IT Security Specialist
    Rothamsted Research

    Thursday, June 6, 2019 3:00 PM