none
Workstation service cannot start under Windows 2003 Server Enterprise x64

    General discussion

  • I have a Windows 2003 Server Enterprise X64 running SQLServer on a cluster and I have the next problem:

      When I try to restart the Workstation service, it fails to start and logs the next entries in the event log:
    Event ID: 5727 Source: Workstation
    Description: Could not load Rdbss device driver.
    ********************
    Event ID: 5727 Source: Workstation
    Description: Could not load RDR device driver.

       I haven't made any recent change to my server. I have compared the DLL files on c:\windows\system32\drivers with the other cluster node, and all files are the same.
     It doesn't seem to be related to clustering.

       After I reboot the server, all services come up fine, including the workstation service.

       But if I manually restart this service, it goes down but it refuses to start, giving the above errors.

      Any ideas on how to troublehsoot this ?
     Thanx for any help !
    • Changed type Wilson Jia Tuesday, November 10, 2009 1:43 AM Wait for customer response
    Tuesday, November 03, 2009 6:52 PM

All replies


  •   Yes, I have read the above article.
        No registry entries were missing. I ended up removing and reinstalling the Client for Microsoft Networks, and it seemed to be working at first.
      I rebooted the server again to check if the problem was fully gone, but it came back.
        So right now my server is in the same state, if I reboot it, Workstation service comes back up and running.
    But if I then manually stop it, it will refuse to start giving me Event ID 5727 again.

    Any more ideas ?
    Wednesday, November 04, 2009 7:26 PM
  • Hi Sumadartson,

     

    According to your description, I understand that Workstation Service fails to restart on your Windows 2003 Server.

     

    Based on my research, please check the below items on the sever.

     

    1.     Open the registry via the “regedit.exe” command, navigate to

    [HKLM\system\CurrentControlSet\services\RDBSS]

    -       image path - windows\system32\drivers\rdbss.sys

    -       start mode - 1

    2.     net start rdbss - check if get message - system error file not found

    3.     Searched for file rdbss.sys - could not find the file in windows\system32\drivers

    4.     Copied the file rdbss.sys from windows\servicepack\i386 to windows\system32\drivers

    5.     net start rdbss – success

    6.     Started workstation service – success

     

    Please try the above steps and let us know whether it addresses your issue.

     

    Best Regards,

    Wilson Jia


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, November 05, 2009 2:49 AM
  • Hi Wilson,

    Thank you for your response. I checked the registry key [HKLM\system\CurrentControlSet\services\RDBSS]
    and the values are:
      ImagePath -  system32\DRIVERS\rdbss.sys
       Start -  1

       When I type "net start rdbss" I get a "System error 2 has occurred. The system cannot fin the file specified"
    I search for file rdbss.sys, and it does exist in c:\windows\system32\drivers

       Since this is a cluster, I copied the rdbss.sys file from the other cluster node to this one, overwriting the original file, but I keep getting the same error.

      Why is the OS not finding the rdbss.sys file if it is on the correct path ??

    Friday, November 06, 2009 4:24 AM
  • Hi Sumadartson,

    Thank you for your quick response.

    Have you replaced the "rdbss.sys" files with windows\servicepack\i386\rdbss.sys? How it works?

    Best Regards,
    Wilson Jia 
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, November 06, 2009 6:35 AM
  • Hi Wilson,

    I have just tried that, replaced rdbss.sys with the one in C:\WINDOWS\ServicePackFiles\amd64 . This is an AMD box using Win 2003 x64.

     I keep getting the same error, cannot find the file specified.

       The strange thing is that when I reboot the server, all services including workstation come up fine.

      But if I restart this service manually, it won't start. 

       Anything else I might try ??
    Friday, November 06, 2009 6:48 AM
  • Hi Sumadartson,

     

    Sorry for the later reply.

     

    So possibly it's because that some system files were missing from the OS. Please refer to the following steps to repair it:

    1. Open Network Connections folder. Right-click Local Area Connections folder and select Properties. In the General page, uncheck the box before "Client for Microsoft Networks" and "File and Printer Sharing for Microsoft Networks" components.

    2. Put the original Windows Server 2003 CD into the CD-ROM drive, then run Command Prompt and type this command:

    Sfc /scannow

    3. After restart the server, go to the place of #1, check the box before those 2 components to reinstall them.

     

    If the problem continues, please disable Receive Side Scaling and TCP offload in the network adapter driver and perform a clean boot to see if the issue goes away.

     

    To Disable Receive Side Scaling and TCP offload, please refer to:

     

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;948496

     

    To perform a clean boot of system, please follow the steps:

     

    a)    Click "Start", go to "Run", and type "msconfig" in the open box to start the System Configuration Utility.

    b)    Click the "Services" tab, check the "Hide All Microsoft Services" box and click Disable All (if it is not gray).

    c)     Click the "Startup" tab, click "Disable All" and click "OK".


    Please try the above suggestions and let me know the results. I look forward to hearing from you.

     

    Best Regards,

    Wilson Jia

    Monday, November 09, 2009 6:55 AM