none
"You Don't Currently Have Permission to Access This Folder" RRS feed

  • Question

  • I am migrating a shared folder from 2008R2 to 2016 server. I am logged in to both servers as domain admin. The share I created on a 2016 server has the identical NTFS and Share permissions to the share on 2008. 

    When I try to access a folder locally on a 2016 box (D:\Share\Public) logged in as a domain admin I get "You Don't Currently Have Permission to Access This Folder" but if I click continue, my admin account is added to the NTFS perms tab and I am able to get in. I don't get this prompt on a 2008 server. 

    Also, if i open a command prompt logged in as domain admin to a 2016 server and try to cd to D:\Share\Public i get access denied, but if i try the same operation but open command prompt as administrator I am able to get inside the folder. 

    So i guess the question is what changed in 2016 that that the OS requires you to access folders from the elevated prompt while logged in as an admin ?

    Thanks 


    • Edited by net_tech Friday, September 27, 2019 11:21 AM
    Friday, September 20, 2019 2:59 PM

All replies

  • Hi,

    You can set your group policy as follows:  

    Under Computer Configuration --> Windows Settings --> Security Settings --> Local Policies --> Security Options,

    • User Account Control: Admin Approval Mode for the Built-in Administrator account - Disabled
    • User Account Control: Behaviour of the elevation prompt for administrators in Admin Approval Mode -  Elevate without prompting
    • User Account Control: Run all administrators in Admin Approval Mode - Disabled

    Then check the issue again.

    Best regards.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, September 23, 2019 10:04 AM
  • Thanks Vivi Ma

    Have all 3 GPO settings been introduced in Windows 2016 or they have been around since 2012 with different default settings? 

    Monday, September 23, 2019 10:56 AM
  • Hi, 

    That should not be the difference between Windows 2016 and 2012. 

    But you can check the GPO of the two machine, to see the difference. 

    These settings might help with your problem. 

    Best regards. 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 24, 2019 1:48 AM
  • Hi,
    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.
    Best Regards,

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 27, 2019 7:57 AM
  • Hi,

    If you meed any help, feel free to post in our forum. 

    Best regards. 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, September 30, 2019 8:28 AM
  • No, the suggested GPO changes didn't resolve the problem 
    Friday, November 22, 2019 4:41 PM