none
In Content Editor web part I show videos, but on page load the video becomes full screen on it's own, how to fix? Issue occurs in Edge browser only. RRS feed

  • Question

  • Hi there

    In a Content Editor web part I show embed videos from YouTube and Stream, but on page load the video becomes full screen on it's own and hide page content, and users have to press back button to see the page with all the web parts.

    Issue occurs in Edge browser only.

    How to fix please?

    Thanks.


    • Edited by ran009 Friday, August 16, 2019 9:03 PM
    Tuesday, August 13, 2019 11:56 PM

Answers

All replies

  • Which SharePoint: 2010, 2013, 2016, 2019, Online?

    Did you copy the "embed" code from YouTube? <iframe>....</iframe>

    Did you edit the web part and add the iframe code as HTML or did you use the Insert Ribbon, Video and Audio, Embed button?

    Here's a YouTube video on adding YouTube videos :-)   https://www.youtube.com/watch?v=hUdh2Icl6qo


    Mike Smith TechTrainingNotes.blogspot.com
    Books: SharePoint Calculated Columns and Validation Formulas
    @TechTrainNotes

    Wednesday, August 14, 2019 1:05 AM
  • Hi,

    Please check if the script you embed in the Content Editor web part contains string “allowfullscreen”. If it does, delete this string and see the result.

    You can also define the size of the embed video and see if it helps.

    You can post the script you use so that we can check it for you. The embed script you copy directly from video should look like:

    <iframe width="xxx" height="xxx" src="https://www.youtube.com/embed/TE9TpraPlrE" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

    Here’s your reference.

    Add video, audio, or images to a classic page.

    https://support.office.com/en-us/article/add-video-audio-or-images-to-a-classic-page-b5220c61-e56a-40fd-8754-d06a2e38b492

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, August 14, 2019 6:06 AM
  • Hi,

    I'm checking how it is going on with this issue.

    Please remember to update this thread if you have any progress.

    Thank you for your understanding.

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, August 16, 2019 7:22 AM
  • Hi Chelsea

    I still have the same issue, tried pretty much everything but Edge browser has this issue.

    Thanks.

    Friday, August 16, 2019 9:02 PM
  • Hi,

    Does this issue happen only in Edge browser? I have tested in my environment with Edge, but I cannot reproduce this issue.

    You can disable auto-play feature in Microsoft Edge via Settings > Advanced > Media autoplay and set it to "Limit" or "Block" and see if it helps.

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, August 19, 2019 5:10 AM
  • Hi Chelsea

    Yes this happens only in Edge.

    I have already disabled Auto Play. The issue is that the video automatically becomes full screen.

    Thanks.

    Tuesday, August 20, 2019 12:11 AM
  • Hi,

    I cannot reproduce this issue in my environment. I suggest you test in another machine and see if the same issue will occur.

    Since this issue is specific to Microsoft Edge, you can also do a reset or repair for Edge via Start > Settings > Apps > Apps & features > Microsoft Edge > Advanced options.

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, August 20, 2019 9:47 AM
  • Hi Chelsea

    So I just tried Repair and Rest both options and unfortunately none of them worked.

    It happens on several machines for several users (but there are a some users who do not notice this issue)

    Any thoughts will be welcome.

    Thanks so much!

    Tuesday, August 20, 2019 11:36 PM
  • Hi,

    You can check for potential Windows update for Microsoft Edge or media rendering on the issued machines. If this issue remains, I suggest you use IE or Chrome instead.

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Thursday, August 22, 2019 7:09 AM
  • Hi Chelsea

    I already have latest version. May be I should move this thread to Edge Browser support forum, do you know the URL for EDGE forum? 

    Thanks so much.

    Thursday, August 22, 2019 6:56 PM
  • Hi,

    You can make a post via this link:

    https://answers.microsoft.com/en-us/edge/forum/all/looking-for-forum-support-for-microsoft-edge/9f4cf7ac-1317-4795-9927-46536448acef

    Best regards,

    Chelsea Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by ran009 Monday, August 26, 2019 11:15 PM
    Friday, August 23, 2019 1:37 AM