none
IE 10 install failure "Neutral package installation failed"

    Question

  • Win7 x64 currently have IE9.  I have tried multiple fixes without success.  I can successfully install other windows updates, however the IE10 install fails with error details of "Code 9C59".  Below is the logs:

    00:00.219: Time Format in this log: MM:ss.mmm (minutes:seconds.milliseconds)
    00:00.250: Command line: "C:\Windows\SoftwareDistribution\Download\Install\WU-IE10-Windows7-x64.exe" /WU-SILENT
    00:00.266: INFO:    Setup installer for Internet Explorer: 10.0.9200.16521
    00:00.312: INFO:    Previous version of Internet Explorer: 9.0.8112.16470
    00:00.344: INFO:    Checking if iexplore.exe's current version is between 10.0.8100.0...
    00:00.359: INFO:    ...and 10.1.0.0...
    00:00.375: INFO:    Maximum version on which to run IEAK branding is: 10.1.0.0...
    00:00.390: INFO:    iexplore.exe version check success. Install can proceed.
    00:00.422: INFO:    Operating System: Windows Workstation: 6.1.7601 (Service Pack 1)
    00:00.437: INFO:    Trying to extract ID: SetupDownloadList.txt (0) as "SetupDownloadList.txt"
    00:00.468: INFO:    Trying to extract ID: HardwareBlockingList.xml (0) as "HardwareBlockingList.xml"
    00:00.484: INFO:    Trying to extract ID: 7006 (0) as "IE10-neutral.Extracted.cab"
    00:01.451: INFO:    Trying to extract ID: 5501 (1033) as "Spelling_en.msu"
    00:01.514: INFO:    Extracted Spelling dictionary for en to C:\Windows\TEMP\IE11BA6.tmp\Spelling_en.msu.
    00:01.514: INFO:    Trying to extract ID: 5502 (1033) as "Hyphenation_en.msu"
    00:01.592: INFO:    Extracted Hyphenation dictionary for en to C:\Windows\TEMP\IE11BA6.tmp\Hyphenation_en.msu.
    00:01.623: INFO:    Trying to extract ID: 7128 (1033) as "IE10-support.cab"
    00:09.329: ERROR:   No reboot policy cab file was not downloaded correctly. Default installation files will be used. Error: 0x800c0005 (2148270085) [(null)]
    00:09.392: INFO:    Launched program to check hardware: "C:\Windows\TEMP\IE11BA6.tmp\IE10-SUPPORT\IEXPLORE.EXE" /CheckHardware "C:\Windows\TEMP\IE11BA6.tmp\HardwareBlockingList.xml"
    00:09.579: INFO:    Hardware support check succeeded. Installation will continue.
    00:09.579: INFO:    Windows 7 operating system detected.
    00:09.594: INFO:    Service pack major: 1
    00:09.610: INFO:    Service pack minor: 0
    00:09.626: INFO:    Service pack name:  Service Pack 1
    00:09.688: INFO:    Version Check for (KB2670838) of C:\Windows\System32\api-ms-win-downlevel-user32-l1-1-0.dll: 6.2.9200.16492 >= 6.2.9200.16492 (True)
    00:09.704: INFO:    Version Check for (KB2639308) of C:\Windows\System32\Ntoskrnl.exe: 6.1.7601.18044 >= 6.1.7601.17727 (True)
    00:09.813: INFO:    Version Check for (KB2533623) of C:\Windows\System32\api-ms-win-security-base-l1-1-0.dll: 6.1.7601.18015 >= 6.1.7601.17617 (True)
    00:09.844: INFO:    Version Check for (KB2731771) of C:\Windows\System32\kernel32.dll: 6.1.7601.18015 >= 6.1.7601.17932 (True)
    00:09.875: INFO:    Checking for correct version of C:\Windows\Fonts\segoeui.ttf.
    00:09.891: INFO:    Version Check for (KB2786081) of C:\Windows\System32\taskhost.exe: 6.1.7601.18010 >= 6.1.7601.18010 (True)
    00:16.287: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE11BA6.tmp\IE-Spelling-en.cab
    00:16.302: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE11BA6.tmp\IE-Hyphenation-en.cab
    00:16.318: INFO:    Waiting for 0 prerequisite downloads.
    00:16.443: INFO:    The neutral pack was not successfully downloaded from the internet. Installation will continue using the extracted package.
    00:16.599: INFO:    No reboot logic message NrApiStart(0), lParam=0x00032900 returned 0x00000000.
    00:17.504: INFO:    No reboot logic message NrApiScan(1), lParam=0x00000001 returned 0x00000000.
    00:17.535: INFO:    No reboot logic message NrApiStartInstall(4), lParam=0x00000001 returned 0x00000014.
    00:17.550: INFO:    Installing with the extracted package. C:\Windows\TEMP\IE11BA6.tmp\IE10-neutral.Extracted.cab
    00:17.582: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE11BA6.tmp\IE10-neutral.Extracted.cab /quiet /norestart
    00:32.729: INFO:    Process exit code 0x00000002 (2) [The system cannot find the file specified. ]
    00:32.745: ERROR:   Neutral package installation failed (exit code = 0x00000002 (2)).
    00:32.761: INFO:    No reboot logic message NrApiInstallDone(7), lParam=0x00009c59 returned 0x00000000.
    00:32.776: INFO:    No reboot logic message NrApiStartFinish(11), lParam=0x00000000 returned 0x00000000.
    00:32.917: INFO:    No reboot logic message NrApiFinish(12), lParam=0x00000000 returned 0x00000016.
    00:32.932: INFO:    Waiting for Active Setup to complete.
    00:32.979: ERROR:   Couldn't create setup troubleshooting shortcut on the desktop. HRESULT: 0x80070002,
    00:32.995: INFO:    Setup exit code: 0x00009C59 (40025) - The neutral cab failed to install.
    00:33.119: INFO:    Scheduling upload to IE SQM server: http://sqm.microsoft.com/sqm/ie/sqmserver.dll
    00:38.236: ERROR:   SQM Upload failed while uploading "C:\Windows\system32\config\systemprofile\AppData\Local\Microsoft\Windows\Temporary Internet Files\SQM\iesqmdata_setup0.sqm" with error: 2147500036
    00:38.299: ERROR:   SQM Upload failed while uploading "C:\Windows\system32\config\systemprofile\AppData\Local\Microsoft\Windows\Temporary Internet Files\SQM\iesqmdata_setup1.sqm" with error: 2147500036
    00:38.330: ERROR:   SQM Upload failed while uploading "C:\Windows\system32\config\systemprofile\AppData\Local\Microsoft\Windows\Temporary Internet Files\SQM\iesqmdata_setup2.sqm" with error: 2147500036
    00:38.330: ERROR:   SQM Upload failed while uploading "C:\Windows\system32\config\systemprofile\AppData\Local\Microsoft\Windows\Temporary Internet Files\SQM\iesqmdata_setup3.sqm" with error: 2147500036
    00:38.361: ERROR:   SQM Upload failed while uploading "C:\Windows\system32\config\systemprofile\AppData\Local\Microsoft\Windows\Temporary Internet Files\SQM\iesqmdata_setup4.sqm" with error: 2147500036
    00:38.392: INFO:    Cleaning up temporary files in: C:\Windows\TEMP\IE11BA6.tmp
    00:38.470: INFO:    Unable to remove directory C:\Windows\TEMP\IE11BA6.tmp, marking for deletion on reboot.
    00:38.501: INFO:    Released Internet Explorer Installer Mutex

    Thursday, March 14, 2013 8:44 PM

All replies

  • Hi, check if this situation applies.. = no IE10.

    http://www.thewindowsclub.com/internet-explorer-10-does-not-install

    http://www.bit-tech.net/news/bits/2013/03/04/ie10-bug-hybrid-graphics/1

    Internet Explorer 10 does not install on Windows 7 computers with hybrid video cards

    Oops.



    D A Lawrie

    Friday, March 15, 2013 7:49 PM
  • My computer is a Dell Optiplex 7010 with a Intel HD Graphics 4000 graphic support.  So, it is not the hybrid graphic support issue.  Thanks.
    Friday, March 15, 2013 9:01 PM
  • Hi, one thing I noted (having tried to install IE10) was that I could not (now?) uninstall IE9- which I had installed at one point.

    Nor could I remove IE10 which was listed in 'Turn Windows Features on or off' in CPanel.

    (And of course it wasn't actually installed).

    Naturally I couldn't reinstall IE9 either- by any method. (MS Fixit, Control panel etc).

    And to add to that, I have an Nvidia graphics card on an HP laptop. Hmm.

    Seems to me a cleanup tool is needed.


    D A Lawrie

    Saturday, March 16, 2013 4:13 PM
  • I've also worked thru this list of prerequisites (after all, the IE10 installer does try to download sthg)

    http://support.microsoft.com/kb/2818833

    and 3 report 'already installed'

    2 report 'not applicable'

    I was careful to choose the x86 version in all cases.


    D A Lawrie

    Saturday, March 16, 2013 5:36 PM
  • Hi,

    Please check the issue referring to the methods in the following KB article:

    Troubleshooting a failed installation of Internet Explorer 10

    http://support.microsoft.com/kb/2820688

    In addition, please clear the %temp% folder and try again.

    Thanks.

    Nicholas Li
    TechNet Community Support

    Monday, March 18, 2013 8:06 AM
    Moderator
  • Similiar to dal987 after IE10 install failed, I tried to uninstall IE9 without success.  I am also seeing IE10 listed in the 'Turn Windows Features of or off'.  I have tried all the options in KB2820688 without success. 

    Monday, March 18, 2013 1:19 PM
  • I had the same issue, take a look in C:\Windows\Logs\CBS\cbs.log.  Search for "Failed to find file" and see what dependencies it cannot find. Should be something like:

     

    CBS    Failed to find file: amd64_microsoft-windows-ie-Vgx_31bf3856ad364e35_8.0.7601.21718_none_66a4fdea8f767c8d\VGX.dll [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]

     

    In my case it was \VGX.dll and vbscript.dll

     

     

     

    On my PC it was KB2764916 and KB2764913 that was missing. Both updates are depreciated but I decided to force install these updates and see what happens. After that, the installation ran without any issue and my IE10 is working

    If you want to try, download the updates from MS and run the following: (It runs fine on my system, but it may make your system insecure, unusable and unstable so do this at your own risk)

     

    expand -F:* C:\temp\Ie10\Windows6.1-KB2510531-x64.msu C:\temp\Ie10\kb2510531

    start /w %SystemRoot%\system32\pkgmgr.exe /ip /m:\temp\Ie10\kb2510531\Windows6.1-KB2510531-x64.cab

     

     

    expand -F:* C:\temp\Ie10\Windows6.1-KB2544521-x64.msu C:\temp\Ie10\KB2544521

    start /w %SystemRoot%\system32\pkgmgr.exe /ip /m:\temp\Ie10\KB2544521\Windows6.1-KB2544521-x64.cab

    (The downloaded KB’s must be in c:\temp\ie10 directory and make a folder called KB2510531 and one called KB2544521 in the c:\temp\ie10 folder, for above to run without any changes).

    If you try it let me know if it works…..

    Tuesday, March 26, 2013 9:21 AM
  • How you fix the missing vbscript.dll please?
    Tuesday, April 16, 2013 1:54 PM
  • For those that are seeing the "Neutral package installation failed" error, if you could gather and send some log files that would be great. One of our MVP's posted a .BAT file to automate this as much as possible. Here's the verbatim from her post on that:

    "Instructions for the end user would be to:

    • Copy GetLogs_local.bat to desktop
    • Run elevated
    • Send back the SetupFailureLogs folder that the script creates

    "http://sdrv.ms/11FIHrc  <<< download the bat file from there"

    If you could then zip up the folder that ends up on your desktop and send it to IE10PQ-at-microsoft-dot-com (change the -at- to @ and -dot- to.)

    Thanks and Regards

    Mark


    Mark Feetham Senior Program Manager Internet Explorer Product Quality


    Monday, April 29, 2013 6:22 PM
    Owner
  • Well, I sent Microsoft the zipped up scripts.  I will post more when I hear back from them.
    Friday, June 21, 2013 2:55 PM
  • In my case, I had "no update" switch on, which caused exact same errors. After removing this switch, things started rolling. Apperantly, even if you have all patches installed, which IE10 requires, it still seeks for some other stuff to sync with Microsoft...
    Wednesday, September 18, 2013 7:21 AM