none
OOF: Umlaute nicht richtig dargestellt

    Frage

  • Hallo zusammen

    ich habe ein komisches Phänomen mit ein paar Mailboxen. Bei diesen werden bei den Abwesenheitsmeldungen die Umlaute falsch dargestellt.  Ich habe dann den Artikel auf Franks Seite genau gelesen aber konnte keine Lösung finden:

    http://www.msxfaq.de/konzepte/oof.htm#oof__umlaute_und_zeichensatz_us_ASCII

    Folgendes habe ich bemerkt. Alle falschen Meldungen werden mit dem Content-Type: text/plain; charset="us-ascii" verschickt. Kann ich diesen Wert beeinflussen?

    Ich habe mittels Power Shell den Text aus einer "falschen" in eine "gute" Mailbox gespeichert aber bei der guten funktioniert der gleiche Text (HTML-Code) also kann es nicht am Text selber liegen. (Das gleiche habe ich umgekehrt gemacht und auch dort funktioniert es)

    $text = Get-MailboxAutoReplyConfiguration -Identity falsche_umlaute | select *
    set-MailboxAutoReplyConfiguration -identity richtige_umlaute -ExternalMessage $text.externalmessage

    Ich habe eine DAG mit 4 Exchange 2013CU9 die problematischen bzw. guten Mailboxen sind auf unterschiedlichen Server bzw. DB's zu finden. Es sind alles Mailboxen der gleichen Domain.

    Besten Dank schon mal fürs mitlesen.

    freundliche Grüsse

    Florian Winkelried

    Donnerstag, 31. März 2016 09:46

Antworten

  • ContentType                    : MimeText

    Ich würde hier den Standard Wert MimeHtmlText verwenden, damit Html Formatierungen erhalten bleiben.

    get-remotedomain | set-remotedomain -ContentType MimeHtmlText


    Georg


    Freitag, 1. April 2016 11:43

Alle Antworten

  • Wo werden die OOFs erstellt, per Outlook oder OWA?

    Bei OWA habe ich schon ähnliches gesehen, wenn der Text aus PDFs, Word und anderen Orten direkt kopiert wurde. Bei OWA immer die dortige Formatierung verwenden und zuerst die bestehende mit dem Radiergummi löschen.


    Georg

    Donnerstag, 31. März 2016 11:10
  • Hi Georg

    das komische ist ja das der gleiche Text bei einer Mailbox funktioniert und bei der anderen nicht. Die Texte wurden normal im Outlook erfasst ohne copy&paste.

    Donnerstag, 31. März 2016 11:43
  • Passiert den bei OWA des gleiche?

    Egal ob Abwesenheitsmeldungen gegen Extern oder intern?


    Georg

    Donnerstag, 31. März 2016 13:17
  • Wenn ich im OWA alles lösche und speichere und wieder aktiviere und den Text von Hand erfasse (freundliche Grüsse) dann wird das ü extern nicht als ü angezeigt sondern als "?". Intern sieht die Meldung gut aus. Bei einer anderen Mailbox problemlos.

    Donnerstag, 31. März 2016 14:44
  • Folgendes habe ich bemerkt. Alle falschen Meldungen werden mit dem Content-Type: text/plain; charset="us-ascii" verschickt. Kann ich diesen Wert beeinflussen?

    Wie ich lese wird bei einer text/plain immer us-asci verwendet, wobei z.B. natürlich keine üöä erkennt werden. Das richtige wäre hier UTF-8. Ich könnte mir eine Client Einstellung vorstellen. Wenn dies nicht beim Client liegt, könnte der Hund bei den Remote Domains begraben sein.

    Hast du schon mal die Outlook Optionen sowie Kontakt oder Mailuser Optionen überprüft?

    https://technet.microsoft.com/en-us/library/bb310794%28v=exchg.150%29.aspx?f=255&MSPPError=-2147217396

    Beispiel Outlook 2013:
    Optionen/Erweitert/Internationale Optionen
    Optionen/E-Mail/Nachrichtenformat

    Auch bei OWA könnte das Encoding angepasst werden:

    Set-OwaVirtualDirectory -identity "Owa (Default Web Site)" -OutboundCharset AlwaysUTF8

    Wie sieht die Konfiguration deiner Remote Domains aus?

    Get-RemoteDomain | fl name,ByteEncoderTypeFor7BitCharsets,ContentType,NonMimeCharacterSet,TNEFEnabled


    Georg

    Freitag, 1. April 2016 06:04
  • Hi Georg

    Get-RemoteDomain
    Name                           : Default
    ByteEncoderTypeFor7BitCharsets : Undefined
    ContentType                    : MimeText
    NonMimeCharacterSet            : iso-8859-1
    TNEFEnabled                    : False
    DomainName                     : *
    TargetDeliveryDomain           : False

    Beim OWA ist die Option OutboundCharset auf "Autodetect". Nach wie vor komisch dass das Verhalten auf Postfach Ebene unterschiedlich ist. Die Client Einstellungen und OWA habe ich ebenfalls verglichen und nichts gefunden.

    Freitag, 1. April 2016 09:37
  • ContentType                    : MimeText

    Ich würde hier den Standard Wert MimeHtmlText verwenden, damit Html Formatierungen erhalten bleiben.

    get-remotedomain | set-remotedomain -ContentType MimeHtmlText


    Georg


    Freitag, 1. April 2016 11:43
  • Hi Georg

    Vielen dank!  Das war es genau.

    get-remotedomain | set-remotedomain -ContentType MimeHtmlText

    Gruss
    Florian

    Montag, 4. April 2016 11:55