none
Wie relativer Link in Abbildungs- und Tabellenverzeichnis bei PDF? Office 2010 RRS feed

  • Frage

  • Hallo,

    ich habe folgenes Problem: Ich möchte ein Dokument (Word Office 2010) in ein PDF umwandeln.

    Wenn ich das mache, wandelt Word aber die Links der Abbildungs- und Tabellenverzeichnisse nicht um

    sondern speichert diese im PDF als absolute Links mit dem Verweis auf der Ursprungs DOCX-Dokument.

    Die Verweise außerhalb der Verzeichnisse (z.B. siehe Abb. 14) sind richtig angelegt.

    Das Inhaltsverzeichnis wird korrekt umgewandelt. Das Problem betrifft nur Abbildungs- und Tabellenverzeichnis.

    Wer hat einen Tip?

     

    Vielen Dank!

     

    Olaf

     

     

     

     


    • Bearbeitet OlafKoeln Sonntag, 18. September 2011 19:00
    Sonntag, 18. September 2011 08:58

Alle Antworten

  • Hallo OlafKoeln,

    wurde das Dokument durch Adobe PDF Printer oder durch einen anderen PDF-Drucker in PDF-Datei umgewandelt? Eigentlich kann die Umwandlung mit Built-In-Funktion von MS Word erfolgen. Also, bei "Speichern als" sollte der Daten-Typ als ".pdf" statt ".docx" eingesetzt werden. Damit sollte alles funktionieren.


    Wir hoffen, vielen Besuchern der TechNet Foren durch das Posten dieses Problems und einer möglichen Lösung weiterhelfen zu können.

    Viele Grüße,
    Kajorn Pathomkeerati
    TechNet Hotline für TechNet Online Deutschland

    Disclaimer:
    Bitte haben Sie Verständnis dafür, dass wir hier auf Rückfragen gar nicht oder nur sehr zeitverzögert antworten können.
    Bitte nutzen Sie für Rückfragen oder neue Fragen den telefonischen Weg über die TechNet Hotline:

    TechNet Hotline: Schnelle & kompetente Hilfe für IT-Pros: kostenfrei!

    Es gelten für die TechNet Hotline und dieses Posting diese Nutzungsbedingungen, Hinweise zu Markenzeichen sowie die allgemein gültigen Informationen zur Datensicherheit sowie die gesonderten Nutzungsbedingungen für die TechNet Hotline.
    Montag, 19. September 2011 20:05
    Moderator
  • Hallo Olaf,

     

    Hat die Antwort Dir weitergeholfen um das Problem zu lösen?

    Viele Grüße,

    Alex

    Mittwoch, 21. September 2011 08:58
  • Leider nein. Ich habe schon den integrierten PDF-Drucker bzw. die Speicheroption von Word 2010 genutzt.
    Mittwoch, 21. September 2011 17:59
  • Noch eine Ergänzung: der Fehler tritt auch auf, wenn ich die Datei als XPS speichere.
    Donnerstag, 22. September 2011 18:28
  • Noch eine Ergänzung: auch ein externen PDF-Maker erzeugt ein Dokument mit dem gleichen Fehler. DIe Ursache muß also eindeutig IM Word 2010 Dokument liegen. Habe die Abb. und Tab. Verzeichnisse auch schon neu erstellt, was aber nichts ändert.

    Samstag, 24. September 2011 12:36
  • Hallo OlafKoeln,

     

    kannst du vielleicht der Inhalt dem Doku in ein neues Doku kopieren (STRG + A) und danach als PDF speichern? Besteht jetzt das Problem weiterhin?

    Hast du Microsoft Office SP1 installiert?

     

    Bitte schau mal hier auch:

    Microsoft TechNet US: Word 2010: Save to PDF or XPS loses hyperlinks on images

     

     

    Viele Grüße,

    Alex

    Montag, 26. September 2011 08:09
  • Ich werde das probieren. Aber es sind 280 Seiten mit vielen Bildern etc.

     

    Das normale Inhaltsverzeichnis und die Verweise im Text funktionieren ja, nur die Abb. und Tab. Verzeichnisse nicht.

     

    Ich melde mich wieder.

    Montag, 26. September 2011 19:22
  • Hallo,

    Das normale Inhaltsverzeichnis und die Verweise im Text funktionieren ja, nur die Abb. und Tab. Verzeichnisse nicht.

    es wurden keine integrierten Bezeichnungen, sondern eigene ("Abb.", "Tab." ) verwendet? Blende per Alt+F9 die Feldfunktionen ein. Das Abbildungsverzeichnis sieht etwa so aus: { TOC \h \z \c "Abb." }?


    Viele Grüße
    Lisa [MS MVP Word]

    Mittwoch, 28. September 2011 12:29
  • Hallo,

    Ich habe das gleiche Problem wie Olaf und hoffe, dass hier noch Jemand antwortet, da auch ich bisher keine Lösung finden konnte.

    Beim Abbildungsverzeichnis steht tatsächlich { TOC \h \z \c "Abbildung" }, während beim Inhaltsverzeichnis (bei welchem die Links nach dem Export in pdf funktionieren) { TOC \o "1-3" \f \h \z \u } steht.

    Wenn ich auf einen Eintrag des Abbildungsverzeichnisses rechtsklicke und dann "Feldfunktionen ein / aus" anklicke, steht auch der volle Link zum Dokument da, während dies beim Inhaltsverzeichnis nicht der Fall ist.

    Bei mir handelt es sich um Word 2016.

    Ich wäre sehr froh über eine Hilfestellung!

    Viele Grüße,
    gadda4

    Samstag, 21. Januar 2017 11:32
  • Hallo,

    Ich habe das gleiche Problem wie Olaf und gadda4. Ich verwende Word 2013.

    Außerdem tritt der Fehler auch auf, wenn ich das Dokument in HTML exportiere/umwandle.

    Gibt es eine Lösung?


    • Bearbeitet M.Arman HH Dienstag, 2. Januar 2018 14:48
    Dienstag, 2. Januar 2018 14:46
  • Hallo,

    auch ich stehe vor diesem Problem. Ich habe festgestellt, dass das Problem nur bei textumflossenen Bildern auftritt, da dort die Bildunterschrift in ein Textfeld eingefügt wird. Wird die Bildunterschrift als normaler Test eingefügt funktionieren die Links. 

    Gibt es eine Lösung dafür, damit man trotzdem textumflossene Bilder verwenden kann, aber das Abbildungsverzeichnis auch noch in der PDF sinnvoll zu nutzen ist?

    Gruß

    lilly

    Dienstag, 3. Juli 2018 08:41
  • Hallo,

    habe dasselbe Problem in Word 2016. Ein Jahr später und keine Lösung liebes MS-Team?

    Mit besten Grüßen

    Donnerstag, 18. Juli 2019 14:46