none
Exchange 2016 schickt an falsche mx-preference RRS feed

  • Frage

  • Hallo zusammen,

    ich komme gerade leider nicht weiter.

    Wir haben unseren Exchange 2010 nach 2016 migriert. Hat soweit auch alles gut geklappt.

    Seit einiger Zeit aber habe ich Probleme Mails zu versenden.

    Wie es mir scheint findet unser Exchange MX-Einträge mit höherer Preference attraktiv. Das sind dann aber oft irgendwelche Backup-MXe die keine Mails annehmen. Ich sehe auch keine Kommunikation zu einem der anderen Server aus den MX-Einträgen. Es wird immer gleich einer mit hoher Pref. angesprochen. Z.B. cluster5a.eu.messagelabs.com statt cluster5.eu.messagelabs.com. Ich habe bisher leider nichts gefunden wo man einstellen kann, in welcher Reihenfolge der Exchange die MX-Einträge abarbeitet. Bin eigentlich davon ausgegangen, dass er bei der niedrigsten Pref. anfängt und sich dann weiterarbeitet.

    Kennt hier jemand so ein Verhalten und wenn ja was kann man dagegen tun?

    Besten Dank

    Jörg Uhl

    Donnerstag, 23. Mai 2019 11:48

Alle Antworten

  • Moin,

    nein, das Verhalten ist definitiv nicht Exchange-typisch.

    Wie ist der Weg nach draußen geregelt? Ist es NAT? Ist es sichergestellt, dass für die neuen Maschinen die gleiche abgehende öffentliche IP verwendet wird wie für die alten?

    Ansonsten: Connectivity Logging hoch drehen, da steht auch alles zur MX-Auflösung drin.


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Donnerstag, 23. Mai 2019 13:59
  • Der neue Exchange hat nen neue IP bekommen.

    Is auch alles richtig eingestellt, RDNS, spf, DMARC, …

    NAT haben wir nicht dazwischen, is voll geroutet.

    die DNS-Kommunikation hab ich bisher nur mit den NetMon beobachtet und die sah gut aus.

    Das Logging dreh ich jetzt mal hoch.

    Donnerstag, 23. Mai 2019 15:47
  • NAT haben wir nicht dazwischen, is voll geroutet.

    ...also hat der Exchange Server eine öffentliche IP?

    Evgenij Smirnov

    http://evgenij.smirnov.de

    Donnerstag, 23. Mai 2019 15:54
  • ja, hat er. steht in unserer DMZ.
    Donnerstag, 23. Mai 2019 16:13
  • So, was ein Schlag auf den Hinterkopf doch alles bewirken kann.

    Nachdem ich das Logging hochgestellt habe bin ich über Protokollfehler gestolpert. Der Exchange war doch brav und hat die Empfänger MX-Server der Reihe nach abgeklappert. Also musste ich nochmal tiefer ins Monitoring einsteigen und hab dann mit dem NetMon TLS Handshake-Fehler festgestellt.

    Das ende vom Lied: Meine TLS-Settings waren zu streng eingestellt (keine passenden Ciphers übrig gelassen).

    Was ich da aber auch gelernt habe ist das nmap Ciphers prüfen kann.

    nmap -sT -p 25 -Pn --script ssl-enum-ciphers.nse <MX-IP>

    Danke für die richtige Idee!

    Freitag, 24. Mai 2019 07:39