none
CDO Schreiben in öffentlichen Ordner RRS feed

  • Frage

  • Hallo zusammen

    Folgendes Problem:
    Unsere Entwicklungsabteilung hat ein Programm entwickelt, welches in einen öffentlichen Ordner schreibt.
    Dies funktioniert auf der Test Umgebung einwandfrei
    Exchange 2003 SP2 in Verbindung mit einem Exchange 2007.

    Auf unserer Produktiven Umgebung auch Exchange 2003 SP2 in Verbindung mit einem Exchange 2007 funktioniert dies nicht.

    Wir erhalten den folgenden Fehler:
    Fehler!:CreateFolder: (file://./backofficestorage/<DOMAINNAME>/Public Folders/gptest) -> Ausnahme von HRESULT: 0x80150804

    Ich habe bereits nach diesem Fehler gesucht, aber keine wirklich verwendbare Lösungen gefunden.

    Hat von euch jemand eine Idee, was das sein könnte, oder wie ich den Fehler weiter eingrenzen könnte?

    Besten Dank
    Daniel

    http://www.iteh.ch
    Montag, 18. Januar 2010 15:09

Antworten

  • Hallo zusammen

    Ich konnte das Problem eingrenzen und lösen.

    Martin hat mich da auf eine Idee gebracht.

    Das Problem ist, dass der Pfad "file://./backofficestorage/<DOMAINNAME>/Public Folders/gptest" dynamisch zusammengebaut wird.
    Der <Domainname> wird als DOMAINDSNNAME ausgelesen und eingesetzt.
    Dies hat auf der Test Umgebung funktioniert, da hier die Empfängerrichtlinien Default Policy (RUS) als  SMTP Adresse auch den DOMAINDSNNAME eingetragen hat.

    In der Produktiven Umgebung ist dies meist anders:
    z.b. intra.firma.ch und firma.ch als SMTP Adresse

    Somit funktioniert dieser Aufruf nicht korrekt.

    Als Lösung geben wir jetzt bei Organisationen mit unterschiedlichen Namen den DOMAINDSNNAME als parameter mit und übersteuern das auslesen.


    Daniel
    http://www.iteh.ch
    Dienstag, 19. Januar 2010 14:47

Alle Antworten

  • Hi Daniel,

    ich schiesse mal ins blaue. Wird der Pfad richtig übergeben (casesenstive)?


    Gruß
    Martin
    Montag, 18. Januar 2010 15:45
  • Hallo Martin

    Sollte denn alles klein sein?

    Nach meinem Wissen wird dieser Pfad direkt ausgelesen.

    Gruss Daniel
    http://www.iteh.ch
    Dienstag, 19. Januar 2010 06:46
  • Hallo zusammen

    Ich konnte das Problem eingrenzen und lösen.

    Martin hat mich da auf eine Idee gebracht.

    Das Problem ist, dass der Pfad "file://./backofficestorage/<DOMAINNAME>/Public Folders/gptest" dynamisch zusammengebaut wird.
    Der <Domainname> wird als DOMAINDSNNAME ausgelesen und eingesetzt.
    Dies hat auf der Test Umgebung funktioniert, da hier die Empfängerrichtlinien Default Policy (RUS) als  SMTP Adresse auch den DOMAINDSNNAME eingetragen hat.

    In der Produktiven Umgebung ist dies meist anders:
    z.b. intra.firma.ch und firma.ch als SMTP Adresse

    Somit funktioniert dieser Aufruf nicht korrekt.

    Als Lösung geben wir jetzt bei Organisationen mit unterschiedlichen Namen den DOMAINDSNNAME als parameter mit und übersteuern das auslesen.


    Daniel
    http://www.iteh.ch
    Dienstag, 19. Januar 2010 14:47