none
Exchange Database Content Index Status FailedAndSuspended Permanent

    Frage

  • Hello,

    Scenario :

    - i need to move our Existing Mailboxes to a new Exchange install on a New 2012r2

    - the automatically generated database at install starts with Content index Status : FailedAndSuspended

    - newly created  database start with : FailedAndSuspended

    - after restarting the Services MSExchange Services Host Controller and Search deleting the .single Folder the Status is : FailedAndSuspended

    -after creating a new Mailbox in the Database : FailedAndSuspended

    -after

    Stop-Service HostControllerService

    Stop-Service MSexchangeFastService

    Dismounting Database

    deleting Folder "GUID.single"

    start-Service HostControllerService

    start-Service MSexchangeFastService

    Mounting Database

    after that ContentIndexStatus goes to : Failed and Suspended

    And Administrator Event log Shows :

    The FastFeeder component received a connection exception from FAST. Error details: System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: Internal error while processing request (Fehlerdetail ist gleich Ein ExceptionDetail, vermutlich erstellt durch IncludeExceptionDetailInFaults=TRUE, mit dem Wert:
    Microsoft.Ceres.InteractionEngine.Component.ProcessingEngineException: Internal error while processing request
       bei Microsoft.Ceres.InteractionEngine.Component.CieProcessingEngine.LogAndRethrowException(Exception e)
       bei Microsoft.Ceres.InteractionEngine.Component.CieProcessingEngine.Close(Guid flowIdentifier)
       bei Microsoft.Ceres.InteractionEngine.Component.CieProcessingEngine.ExecuteSearchFlowAndGetResultCollection(String flowName, IEnumerable`1 inputData, String outputName)
       bei SyncInvokeExecuteSearchFlowAndGetResultCollection(Object , Object[] , Object[] )
       bei System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
       bei System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
       bei System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
       bei System.ServiceModel.Dispatche...).
    The indexing of mailbox database Live_sample1 encountered an unexpected exception. Error details: Microsoft.Exchange.Search.Core.Abstraction.OperationFailedException: The component operation has failed. ---> Microsoft.Exchange.Search.Engine.FeedingSkippedForCorruptionException: "Feeding was skipped for 'f14fa5db-4d58-4da1-8869-215c08a6a582 (Live_sample1)' due to the state 'Failed', error code: 'CatalogCorruption', failure code: '4321345', failure reason: 'Journal has been detected as invalid.'."
       bei Microsoft.Exchange.Search.Engine.SearchFeedingController.InternalExecutionStart()
       bei Microsoft.Exchange.Search.Core.Common.Executable.InternalExecutionStart(Object state)
       --- Ende der internen Ausnahmestapelüberwachung ---
       bei Microsoft.Exchange.Search.Core.Common.Executable.EndExecute(IAsyncResult asyncResult)
       bei Microsoft.Exchange.Search.Engine.SearchRootController.ExecuteComplete(IAsyncResult asyncResult)
    Beim Starten der Sitzung "FastDocTracingSession" ist der folgende Fehler aufgetreten: 0xC0000035.

    Please helpt any Feedback apreciated , i Need to move the Mailboxes asap to the new Server and database but dont want to risk it now .

    P.S. Test Mailbox on the database works
    There is no DAG as we have only 2 Servers and one of them we want to retire which is the whole point of the move .

    Exchange Version 2013 CU15

    Version 15.0 ‎(Build 1263.5)‎

    //EDIT:

    Content Index Error Message in Exchange PS :

    Get-MailboxDatabaseCopyStatus | select  ContentIndexErrorCode , ContentIndexErrorMessage

    Output:  19 The content index is corrupted.

    DiskPErcent Free Space 77%  ~ 700 GB

    Tried to move Logfiles to different Mounts even to USB mount still same result ...

    //EDIT: I have also followed this tutorial

    exchange-event-log-fehler-1012-msexchangeis-368343

    Removed all folders in C:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\Data\Nodes\Fsis\

    and uninstalled and installed search

    .\installconfig.ps1 -action U -datafolder "c:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\Data"
    
    02.

    .\installconfig.ps1 -action I -datafolder "c:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\Data"

    I have Followed this tutorial :

    1. Create a new Active Directory group that is named “ContentSubmitters,” and then grant Admistrators and NetworkService full access to the group. This is a dummy group and should be used as a placeholder only. You might want to add a description so that the group is not removed.
    2. Force or wait for Active Directory replication.
    3. Restart the following services:
      • Microsoft Exchange Search
      • Microsoft Exchange Search Host Controller

    Still isntantly FailedAndSuspended...

    Just Getting Event 1009 MsExchangeFastSearch ....

    // Now i have completly uninstalled exchange from the Server , removed all traces Folders / files and registry entries  , uninstalled UML 4.0 and reinstalled , repaired installed C++ redistributables and then tried reinstalling Exchange 2013 CU 15 fresh after install the autogenerated databases state is "FailedAndSuspended"
    Mittwoch, 10. April 2019 13:10

Alle Antworten

  • Hallo,

    ich antworte mal auf Deutsch, da du im Deutschen Forum gefragt hast.

    Exchange 2013 CU15 ist uralt und lange aus dem Support

    http://blog-schulenburg.de/index.php/kategorie-als-blog/87-exchange-build-nummern

    CU15 ist vom 12.12.2016!


    Gruß Norbert

    Mittwoch, 10. April 2019 18:12
    Moderator
  • Hallo, 

    ja ich weiss das zwar auch , will auch auf CU22 upgraden aber will auf dem altem Server kein upgrade machen da er schon sowieso andauernt einfriert und ihn nicht mehr belasten will . Also zuerst muss ich die Mailboxen auf den neuen verschieben , dies wird aber durch die fehlindexierung der databasen auf dem neuen geblockt , da wenn man keine Emails in seinen Postfaechern suchen kann wird dies natürlich nicht wirklich nützlich ...

    Hast du eventuell eine Idee zu der Indizierung der Datenbanken ? 


    Donnerstag, 11. April 2019 12:48
  • Nein.

    Ziehe einen neuen Server hoch und verschiebe die Mailboxen.

    Den Missbrauch-Tag habe ich entfernt.

    Du bekommst die gleiche Antwort, wenn du ein Ticket bei MS aufmachst...

    Ich korrigiere meine Antwort - in dem Englischen Teil hast du geschrieben, schon neu installiert - neue Maschine?
    Warum nicht gleich mit CU22 neu installiert? Jedes CU ist eine Vollinstallation...


    Gruß Norbert


    Freitag, 12. April 2019 16:41
    Moderator
  • Hallo, 

    Danke für die Antwort ! 

    Ist schön das ich so eine Antwort auch bei MS kriege ,aber ich würde eher  freude haben über etwas Konstruktiveres hören/lesen als 0815 "Please update!" wie von  Bots hören . 

    LG Marek Stepan 

    P.S. Ich hab mich missbraucht gefühlt !! ich kam her um mit erfahrenen Menschen zu reden , nicht Bot Nachrichten zu kriegen . 

    Freitag, 12. April 2019 16:46
  • Hast du das Gefühl, ich wäre in Bot?

    Dann mach mal schön weiter..

    PS: ich habe meine Antwort zwischenzeitlich editiert, noch mal lesen...


    Gruß Norbert


    Freitag, 12. April 2019 16:49
    Moderator
  • Nein Exchange habe ich komplet entfernt , auch registry durchstöbert und alte einträge entfernt . Neu installiert ohne fehler meldungen , und generierte leere datanbank indizierung zustand FailedAndSuspended 

    // den 2012r2 dort kann ich nicht neu aufsetzen da er in productions umfaellt ist 

    CU22 geht nicht Instalieren wenn der Laufende Server CU15 ist ... 


    Freitag, 12. April 2019 16:49
  • Läuft noch was auf dem Exchange, gibt es noch einen?

    Exchange kannst du nicht lokal entfernen, alle relevanten Informationen stehen im AD


    Gruß Norbert

    Freitag, 12. April 2019 16:52
    Moderator
  • Also jetzt laufen Zwei  2012r2 beide mit AD , der neue (DC02) hat das Problem mit der Indizierung , auf dem alten (DC01) lauft jetzt alleine der Exchange .  Ich habe die Registereinträge bei HKLM gemeint da mir nichts mehr einfiel was das Indizierung verhalten auslösen konnte , also hab ich mir gedacht vielleicht eine fehlerhafte Exchange Installation ?  Da wie du vorgeschlagen hast hab ich versucht  ganz am Anfang mit CU22   zu installieren was aber nicht wirklich funktioniert .... geht nur die Version  die du laufend hast zu installieren . 

    Freitag, 12. April 2019 16:59
  • Über wieviel Mailboxen reden wir?

    Und Exchange auf einem DC ist zwar (leider) supportet aber eher suboptimal, bei Bedarf kann man das mal erklären.

    Ist das Physik oder eine VM? RAM?

    Und nein, wenn du den eh komplett "gekillt" hast (nach wie vor - die Informationen stehen im AD und nicht lokal, auch nicht auf einem DC - und das ist nicht supportet...) kannst du natürlich frisch mit dem aktuellen CU installieren.

    Ausnahme: Setup mit Paramter /RecoverServer

    Liegen da jetzt Mailboxen produktiv drauf, wenn ja, wie viele?


    Gruß Norbert

    Freitag, 12. April 2019 17:36
    Moderator
  • Schade, das Marek nicht weiter geantwortet hat - so hat keiner was davon, der den Thread findet.

    Ich lasse den mal noch auf. ;)


    Gruß Norbert

    Donnerstag, 25. April 2019 22:13
    Moderator
  • ist VM , Ram ist ausreichend 51200 mb jetzt zugewiesen . 

    Im AD wurden die informationen vom dc02 gesucht und gelöscht .  Ich weiss dies ist nicht supported da aber auch eine Setup ausfuehrung mit /RecoverServer nicht geholfen hat blieb mir nichts anderes übrig als dies manuel zu machen . Da die installation fehlgeschlagen hat und die deinstallation per benutzeroberflaeche nicht moglich war .

    Auf DC01 liegen mailboxen produktiv drauf cca 20-30 . 3 Datenbanken , 1 Recovery datenbank .


    Marek Stepan

    Montag, 29. April 2019 17:39
  • Marek war Osterurlaub und ist wieder da . 

    Marek Stepan

    Montag, 29. April 2019 17:40